Skip to content

Commit 5d3895a

Browse files
authoredDec 5, 2023
chore: Pin node version in docker base images and bump nvmrc (#3537)
We were using a floating version of node in our base images, which means we didn't control when we updated the node version. Also, we were using an outdated version for local development, which didn't match the one used for the base images. This changeset bumps nvmrc to latest node (18.19.0) and pins down the version of all node base images across dockerfiles in the project. This PR was triggered by suddenly hitting [this error](TypeStrong/ts-node#2094) in CI.
1 parent c800502 commit 5d3895a

File tree

12 files changed

+14
-14
lines changed

12 files changed

+14
-14
lines changed
 

‎.nvmrc

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
v18.8.0
1+
v18.19.0

‎barretenberg/acir_tests/Dockerfile.bb

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/barretenberg-x86_64-linux-clang-assert
22
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/noir-acir-tests as noir-acir-tests
33

4-
FROM node:18-alpine
4+
FROM node:18.19.0-alpine
55
RUN apk update && apk add git bash curl jq coreutils
66
COPY --from=0 /usr/src/barretenberg/cpp/build /usr/src/barretenberg/cpp/build
77
COPY --from=noir-acir-tests /usr/src/noir/test_programs /usr/src/noir/test_programs

‎barretenberg/acir_tests/Dockerfile.bb.js

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/bb.js
22
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/noir-acir-tests as noir-acir-tests
33

4-
FROM node:18
4+
FROM node:18.19.0
55
COPY --from=0 /usr/src/barretenberg/ts /usr/src/barretenberg/ts
66
COPY --from=noir-acir-tests /usr/src/noir/test_programs /usr/src/noir/test_programs
77
RUN apt update && apt install -y lsof jq

‎barretenberg/acir_tests/Dockerfile.bb.sol

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@ FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/barretenberg-x86_64-linux-clan
22
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/barretenberg-x86_64-linux-clang-sol
33
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/noir-acir-tests as noir-acir-tests
44

5-
FROM node:18-alpine
5+
FROM node:18.19.0-alpine
66
RUN apk update && apk add git bash curl jq
77
COPY --from=0 /usr/src/barretenberg/cpp/build /usr/src/barretenberg/cpp/build
88
COPY --from=1 /usr/src/barretenberg/sol/src/ultra/BaseUltraVerifier.sol /usr/src/barretenberg/sol/src/ultra/BaseUltraVerifier.sol

‎barretenberg/ts/Dockerfile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/barretenberg-wasm-linux-clang
22

3-
FROM node:18-alpine
3+
FROM node:18.19.0-alpine
44
COPY --from=0 /usr/src/barretenberg /usr/src/barretenberg
55

66
# Create a standalone container that can run bb.js (and tests).

‎l1-contracts/Dockerfile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
# Linting requires node.
2-
FROM node:18-alpine
2+
FROM node:18.19.0-alpine
33
RUN apk update && apk add --no-cache build-base git python3 curl bash jq
44
WORKDIR /usr/src/l1-contracts
55
COPY . .

‎yarn-project/Dockerfile.prod

+2-2
Original file line numberDiff line numberDiff line change
@@ -3,7 +3,7 @@
33
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/yarn-project AS yarn-project
44

55
# Need new arch specific image.
6-
FROM node:18-alpine AS builder
6+
FROM node:18.19.0-alpine AS builder
77
RUN apk add bash jq --no-cache
88
COPY --from=yarn-project /usr/src /usr/src
99
WORKDIR /usr/src/yarn-project
@@ -18,5 +18,5 @@ RUN yarn workspaces focus @aztec/cli @aztec/aztec-sandbox @aztec/aztec-faucet --
1818
RUN rm -rf /usr/src/noir/target
1919

2020
# Create fresh minimal size image.
21-
FROM node:18-alpine
21+
FROM node:18.19.0-alpine
2222
COPY --from=builder /usr/src /usr/src

‎yarn-project/canary/Dockerfile

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
FROM node:18-alpine AS builder
1+
FROM node:18.19.0-alpine AS builder
22

33
RUN apk update && apk add --no-cache bash jq curl
44

@@ -20,7 +20,7 @@ WORKDIR /usr/src/canary
2020
RUN ./scripts/update_packages.sh canary ../end-to-end/
2121
RUN yarn && yarn build
2222

23-
FROM node:18-alpine
23+
FROM node:18.19.0-alpine
2424
RUN apk update && apk add --no-cache udev ttf-freefont chromium bash
2525
ENV CHROME_BIN="/usr/bin/chromium-browser" PUPPETEER_SKIP_CHROMIUM_DOWNLOAD="true"
2626

‎yarn-project/canary/Dockerfile.build

+1-1
Original file line numberDiff line numberDiff line change
@@ -3,7 +3,7 @@ WORKDIR /usr/src/yarn-project/canary
33
# Productionify. See comment in yarn-project-base/Dockerfile.
44
RUN yarn cache clean && yarn workspaces focus --production
55

6-
FROM node:18-alpine
6+
FROM node:18.19.0-alpine
77
COPY --from=builder /usr/src /usr/src
88
WORKDIR /usr/src/yarn-project/canary
99
ENTRYPOINT ["yarn", "test"]

‎yarn-project/end-to-end/Dockerfile

+1-1
Original file line numberDiff line numberDiff line change
@@ -10,7 +10,7 @@ RUN yarn workspaces focus --production && yarn cache clean
1010

1111
# Create final, minimal size image.
1212
# TODO: Not very minimal as chromium adds about 500MB of bloat :/ Separate or install at test runtime?
13-
FROM node:18-alpine
13+
FROM node:18.19.0-alpine
1414
RUN apk update && apk add --no-cache \
1515
jq \
1616
bash \

‎yarn-project/yarn-project-base/Dockerfile

+1-1
Original file line numberDiff line numberDiff line change
@@ -47,7 +47,7 @@ FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/bb.js as bb.js
4747
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/noir as noir
4848
FROM 278380418400.dkr.ecr.eu-west-2.amazonaws.com/noir-packages as noir-packages
4949

50-
FROM node:18-alpine
50+
FROM node:18.19.0-alpine
5151
RUN apk update && apk add --no-cache bash jq curl
5252

5353
# Copy L1 contracts.

‎yellow-paper/Dockerfile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
FROM node:18-alpine
1+
FROM node:18.19.0-alpine
22
WORKDIR /usr/src
33
COPY . .
44
RUN yarn && yarn build --no-minify

0 commit comments

Comments
 (0)