Skip to content

Commit 64e7cf3

Browse files
authored
chore(master): Release 0.54.0 (#8449)
🤖 I have created a release *beep* *boop* --- <details><summary>aztec-package: 0.54.0</summary> ## [0.54.0](aztec-package-v0.53.0...aztec-package-v0.54.0) (2024-09-10) ### Features * Archiver fork block num ([#8425](#8425)) ([a9f2364](a9f2364)) ### Miscellaneous * Merge devnet to master ([#8472](#8472)) ([26706e9](26706e9)) </details> <details><summary>barretenberg.js: 0.54.0</summary> ## [0.54.0](barretenberg.js-v0.53.0...barretenberg.js-v0.54.0) (2024-09-10) ### Miscellaneous * **barretenberg.js:** Synchronize aztec-packages versions </details> <details><summary>aztec-packages: 0.54.0</summary> ## [0.54.0](aztec-packages-v0.53.0...aztec-packages-v0.54.0) (2024-09-10) ### ⚠ BREAKING CHANGES * **avm:** variants for binary operations ([#8473](#8473)) * **avm:** make JUMP(I) 16-bit ([#8443](#8443)) * **avm:** variants for SET opcode ([#8441](#8441)) * **avm:** variants for MOV opcode ([#8440](#8440)) ### Features * (bb) 128-bit challenges ([#8406](#8406)) ([d5b2397](d5b2397)) * `Module::add_item` (noir-lang/noir#5947) ([8ac81b1](8ac81b1)) * Add `Expr::as_let` (noir-lang/noir#5964) ([8ac81b1](8ac81b1)) * Add `FunctionDefinition::module` and `StructDefinition::module` (noir-lang/noir#5956) ([8ac81b1](8ac81b1)) * Add `FunctionDefinition` methods `is_unconstrained` and `set_unconstrained` (noir-lang/noir#5962) ([8ac81b1](8ac81b1)) * Add `StructDefinition::add_generic` (noir-lang/noir#5961) ([8ac81b1](8ac81b1)) * Add `StructDefinition::name` (noir-lang/noir#5960) ([8ac81b1](8ac81b1)) * Add a `panic` method to the stdlib (noir-lang/noir#5966) ([8ac81b1](8ac81b1)) * Archiver fork block num ([#8425](#8425)) ([a9f2364](a9f2364)) * Arithmetic Generics (noir-lang/noir#5950) ([8ac81b1](8ac81b1)) * **avm-transpiler:** Optionally count opcode types ([#8439](#8439)) ([21c06b5](21c06b5)) * **avm/public:** User space PublicContext::get_args_hash ([#8292](#8292)) ([56ce16a](56ce16a)) * **avm:** DSL integration of AVM recursive verifier ([#8405](#8405)) ([467120e](467120e)), closes [#8285](#8285) * **avm:** Make JUMP(I) 16-bit ([#8443](#8443)) ([5bb38b1](5bb38b1)) * **avm:** Variants for binary operations ([#8473](#8473)) ([8de1f2a](8de1f2a)) * **avm:** Variants for MOV opcode ([#8440](#8440)) ([5b27fbc](5b27fbc)) * **avm:** Variants for SET opcode ([#8441](#8441)) ([dc43306](dc43306)) * **bb:** Towards reduced polynomial memory usage ([#7990](#7990)) ([372f23c](372f23c)) * Let `nargo` and LSP work well in the stdlib (noir-lang/noir#5969) ([8ac81b1](8ac81b1)) * LSP autocompletion for attributes (noir-lang/noir#5963) ([8ac81b1](8ac81b1)) * LSP now suggests self fields and methods (noir-lang/noir#5955) ([8ac81b1](8ac81b1)) * Show doc comments in LSP (noir-lang/noir#5968) ([8ac81b1](8ac81b1)) ### Bug Fixes * Add re-exports back ([#8453](#8453)) ([b6cab90](b6cab90)) * **avm:** Full proving kernel fix ([#8468](#8468)) ([684d962](684d962)) * **bb:** Mac release ([#8450](#8450)) ([1b3f914](1b3f914)) * **docs:** Some docs updates ([#8412](#8412)) ([ad73f30](ad73f30)) * Error when `quote` is used in runtime code (noir-lang/noir#5978) ([8ac81b1](8ac81b1)) * Error when comptime functions are used in runtime code (noir-lang/noir#5976) ([8ac81b1](8ac81b1)) * Fmt ([#8454](#8454)) ([34b4a8a](34b4a8a)) * Guesstimate gas for propose ([#8445](#8445)) ([bff0338](bff0338)) * Let `derive(Eq)` work for empty structs (noir-lang/noir#5965) ([8ac81b1](8ac81b1)) * LSP document symbol didn't work for primitive impls (noir-lang/noir#5970) ([8ac81b1](8ac81b1)) * **mem2reg:** Handle aliases better when setting a known value for a load (noir-lang/noir#5959) ([8ac81b1](8ac81b1)) * **mem2reg:** Handle aliases in function last store cleanup and additional alias unit test (noir-lang/noir#5967) ([8ac81b1](8ac81b1)) * Public data reads and writes verification ([#8296](#8296)) ([ae86347](ae86347)) * Restrict keccak256_injective test input to 8 bits (noir-lang/noir#5977) ([8ac81b1](8ac81b1)) * Suggest trait attributes in LSP (noir-lang/noir#5972) ([8ac81b1](8ac81b1)) ### Miscellaneous * **bb:** Remove poly downsizing, other fast-follow from structured polys ([#8475](#8475)) ([ac88f30](ac88f30)) * **ci:** Rerun ci when ready for review + don't allow draft merge ([#8456](#8456)) ([ede16d3](ede16d3)) * **docs:** Update box readme, remove duplicated features, added box install to the docs ([#8254](#8254)) ([b747ac1](b747ac1)) * Document BoundedVec (noir-lang/noir#5974) ([8ac81b1](8ac81b1)) * Document HashMap (noir-lang/noir#5984) ([8ac81b1](8ac81b1)) * Merge devnet to master ([#8472](#8472)) ([26706e9](26706e9)) * Remove 3 unused functions warnings in the stdlib (noir-lang/noir#5973) ([8ac81b1](8ac81b1)) * Remove warnings from protocol circuits ([#8420](#8420)) ([c4dbcab](c4dbcab)) * Rename files relating to what were "instances" ([#8383](#8383)) ([a934e85](a934e85)) * Replace relative paths to noir-protocol-circuits ([1c43bae](1c43bae)) </details> <details><summary>barretenberg: 0.54.0</summary> ## [0.54.0](barretenberg-v0.53.0...barretenberg-v0.54.0) (2024-09-10) ### ⚠ BREAKING CHANGES * **avm:** variants for binary operations ([#8473](#8473)) * **avm:** make JUMP(I) 16-bit ([#8443](#8443)) * **avm:** variants for SET opcode ([#8441](#8441)) * **avm:** variants for MOV opcode ([#8440](#8440)) ### Features * (bb) 128-bit challenges ([#8406](#8406)) ([d5b2397](d5b2397)) * **avm:** DSL integration of AVM recursive verifier ([#8405](#8405)) ([467120e](467120e)), closes [#8285](#8285) * **avm:** Make JUMP(I) 16-bit ([#8443](#8443)) ([5bb38b1](5bb38b1)) * **avm:** Variants for binary operations ([#8473](#8473)) ([8de1f2a](8de1f2a)) * **avm:** Variants for MOV opcode ([#8440](#8440)) ([5b27fbc](5b27fbc)) * **avm:** Variants for SET opcode ([#8441](#8441)) ([dc43306](dc43306)) * **bb:** Towards reduced polynomial memory usage ([#7990](#7990)) ([372f23c](372f23c)) ### Bug Fixes * **avm:** Full proving kernel fix ([#8468](#8468)) ([684d962](684d962)) * **bb:** Mac release ([#8450](#8450)) ([1b3f914](1b3f914)) ### Miscellaneous * **bb:** Remove poly downsizing, other fast-follow from structured polys ([#8475](#8475)) ([ac88f30](ac88f30)) * Rename files relating to what were "instances" ([#8383](#8383)) ([a934e85](a934e85)) </details> --- This PR was generated with [Release Please](https://github.com/googleapis/release-please). See [documentation](https://github.com/googleapis/release-please#release-please).
1 parent 8ac81b1 commit 64e7cf3

File tree

8 files changed

+126
-7
lines changed

8 files changed

+126
-7
lines changed

.release-please-manifest.json

+4-4
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
{
2-
".": "0.53.0",
2+
".": "0.54.0",
33
"yarn-project/cli": "0.35.1",
4-
"yarn-project/aztec": "0.53.0",
5-
"barretenberg": "0.53.0",
6-
"barretenberg/ts": "0.53.0"
4+
"yarn-project/aztec": "0.54.0",
5+
"barretenberg": "0.54.0",
6+
"barretenberg/ts": "0.54.0"
77
}

CHANGELOG.md

+68
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,73 @@
11
# Changelog
22

3+
## [0.54.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.53.0...aztec-packages-v0.54.0) (2024-09-10)
4+
5+
6+
### ⚠ BREAKING CHANGES
7+
8+
* **avm:** variants for binary operations ([#8473](https://github.com/AztecProtocol/aztec-packages/issues/8473))
9+
* **avm:** make JUMP(I) 16-bit ([#8443](https://github.com/AztecProtocol/aztec-packages/issues/8443))
10+
* **avm:** variants for SET opcode ([#8441](https://github.com/AztecProtocol/aztec-packages/issues/8441))
11+
* **avm:** variants for MOV opcode ([#8440](https://github.com/AztecProtocol/aztec-packages/issues/8440))
12+
13+
### Features
14+
15+
* (bb) 128-bit challenges ([#8406](https://github.com/AztecProtocol/aztec-packages/issues/8406)) ([d5b2397](https://github.com/AztecProtocol/aztec-packages/commit/d5b239745178d1ce4eb8b8d32fa4b366c13c3c94))
16+
* `Module::add_item` (https://github.com/noir-lang/noir/pull/5947) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
17+
* Add `Expr::as_let` (https://github.com/noir-lang/noir/pull/5964) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
18+
* Add `FunctionDefinition::module` and `StructDefinition::module` (https://github.com/noir-lang/noir/pull/5956) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
19+
* Add `FunctionDefinition` methods `is_unconstrained` and `set_unconstrained` (https://github.com/noir-lang/noir/pull/5962) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
20+
* Add `StructDefinition::add_generic` (https://github.com/noir-lang/noir/pull/5961) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
21+
* Add `StructDefinition::name` (https://github.com/noir-lang/noir/pull/5960) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
22+
* Add a `panic` method to the stdlib (https://github.com/noir-lang/noir/pull/5966) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
23+
* Archiver fork block num ([#8425](https://github.com/AztecProtocol/aztec-packages/issues/8425)) ([a9f2364](https://github.com/AztecProtocol/aztec-packages/commit/a9f2364264e5cba4d01f09ef18801dd5ff39ae87))
24+
* Arithmetic Generics (https://github.com/noir-lang/noir/pull/5950) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
25+
* **avm-transpiler:** Optionally count opcode types ([#8439](https://github.com/AztecProtocol/aztec-packages/issues/8439)) ([21c06b5](https://github.com/AztecProtocol/aztec-packages/commit/21c06b5c497cea2ec1a0be457204508bc39516a6))
26+
* **avm/public:** User space PublicContext::get_args_hash ([#8292](https://github.com/AztecProtocol/aztec-packages/issues/8292)) ([56ce16a](https://github.com/AztecProtocol/aztec-packages/commit/56ce16a104476e070a627a5f0c5dcb3425691bcd))
27+
* **avm:** DSL integration of AVM recursive verifier ([#8405](https://github.com/AztecProtocol/aztec-packages/issues/8405)) ([467120e](https://github.com/AztecProtocol/aztec-packages/commit/467120e5a95de267910c2f95b65dcb62c60f995d)), closes [#8285](https://github.com/AztecProtocol/aztec-packages/issues/8285)
28+
* **avm:** Make JUMP(I) 16-bit ([#8443](https://github.com/AztecProtocol/aztec-packages/issues/8443)) ([5bb38b1](https://github.com/AztecProtocol/aztec-packages/commit/5bb38b1692469520f29a1c85bc381c1ca9eb4032))
29+
* **avm:** Variants for binary operations ([#8473](https://github.com/AztecProtocol/aztec-packages/issues/8473)) ([8de1f2a](https://github.com/AztecProtocol/aztec-packages/commit/8de1f2a942024aad955ea0f318cb044e3692b7fc))
30+
* **avm:** Variants for MOV opcode ([#8440](https://github.com/AztecProtocol/aztec-packages/issues/8440)) ([5b27fbc](https://github.com/AztecProtocol/aztec-packages/commit/5b27fbca982442251a350d6571bdd007b715d575))
31+
* **avm:** Variants for SET opcode ([#8441](https://github.com/AztecProtocol/aztec-packages/issues/8441)) ([dc43306](https://github.com/AztecProtocol/aztec-packages/commit/dc433064391b2ac93bca6b838adac271fbd28991))
32+
* **bb:** Towards reduced polynomial memory usage ([#7990](https://github.com/AztecProtocol/aztec-packages/issues/7990)) ([372f23c](https://github.com/AztecProtocol/aztec-packages/commit/372f23ce0aa44a3aa6e1ef2f864df303a3229e6b))
33+
* Let `nargo` and LSP work well in the stdlib (https://github.com/noir-lang/noir/pull/5969) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
34+
* LSP autocompletion for attributes (https://github.com/noir-lang/noir/pull/5963) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
35+
* LSP now suggests self fields and methods (https://github.com/noir-lang/noir/pull/5955) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
36+
* Show doc comments in LSP (https://github.com/noir-lang/noir/pull/5968) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
37+
38+
39+
### Bug Fixes
40+
41+
* Add re-exports back ([#8453](https://github.com/AztecProtocol/aztec-packages/issues/8453)) ([b6cab90](https://github.com/AztecProtocol/aztec-packages/commit/b6cab90428be1b3576cbfedf17ab287fd9a659c8))
42+
* **avm:** Full proving kernel fix ([#8468](https://github.com/AztecProtocol/aztec-packages/issues/8468)) ([684d962](https://github.com/AztecProtocol/aztec-packages/commit/684d96271669116380facfa48db6cba3a5d945de))
43+
* **bb:** Mac release ([#8450](https://github.com/AztecProtocol/aztec-packages/issues/8450)) ([1b3f914](https://github.com/AztecProtocol/aztec-packages/commit/1b3f914fc069ec84fbd93621eb369128c3ba0dc5))
44+
* **docs:** Some docs updates ([#8412](https://github.com/AztecProtocol/aztec-packages/issues/8412)) ([ad73f30](https://github.com/AztecProtocol/aztec-packages/commit/ad73f304147027c8720b9720d92d2d8c409f599d))
45+
* Error when `quote` is used in runtime code (https://github.com/noir-lang/noir/pull/5978) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
46+
* Error when comptime functions are used in runtime code (https://github.com/noir-lang/noir/pull/5976) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
47+
* Fmt ([#8454](https://github.com/AztecProtocol/aztec-packages/issues/8454)) ([34b4a8a](https://github.com/AztecProtocol/aztec-packages/commit/34b4a8a012d373a0f2d2f10252e29d8201b8c003))
48+
* Guesstimate gas for propose ([#8445](https://github.com/AztecProtocol/aztec-packages/issues/8445)) ([bff0338](https://github.com/AztecProtocol/aztec-packages/commit/bff03382fc5f4be00ba0481564416f643b864f40))
49+
* Let `derive(Eq)` work for empty structs (https://github.com/noir-lang/noir/pull/5965) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
50+
* LSP document symbol didn't work for primitive impls (https://github.com/noir-lang/noir/pull/5970) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
51+
* **mem2reg:** Handle aliases better when setting a known value for a load (https://github.com/noir-lang/noir/pull/5959) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
52+
* **mem2reg:** Handle aliases in function last store cleanup and additional alias unit test (https://github.com/noir-lang/noir/pull/5967) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
53+
* Public data reads and writes verification ([#8296](https://github.com/AztecProtocol/aztec-packages/issues/8296)) ([ae86347](https://github.com/AztecProtocol/aztec-packages/commit/ae863471fed30ea3382aea8223d7ddf8e9eef4ee))
54+
* Restrict keccak256_injective test input to 8 bits (https://github.com/noir-lang/noir/pull/5977) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
55+
* Suggest trait attributes in LSP (https://github.com/noir-lang/noir/pull/5972) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
56+
57+
58+
### Miscellaneous
59+
60+
* **bb:** Remove poly downsizing, other fast-follow from structured polys ([#8475](https://github.com/AztecProtocol/aztec-packages/issues/8475)) ([ac88f30](https://github.com/AztecProtocol/aztec-packages/commit/ac88f30808199c2625f889671f2767c3667becb5))
61+
* **ci:** Rerun ci when ready for review + don't allow draft merge ([#8456](https://github.com/AztecProtocol/aztec-packages/issues/8456)) ([ede16d3](https://github.com/AztecProtocol/aztec-packages/commit/ede16d31d99eb633630b037dc668e7c9b21ac769))
62+
* **docs:** Update box readme, remove duplicated features, added box install to the docs ([#8254](https://github.com/AztecProtocol/aztec-packages/issues/8254)) ([b747ac1](https://github.com/AztecProtocol/aztec-packages/commit/b747ac192bf63b2395c464f5b012ded9a3412846))
63+
* Document BoundedVec (https://github.com/noir-lang/noir/pull/5974) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
64+
* Document HashMap (https://github.com/noir-lang/noir/pull/5984) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
65+
* Merge devnet to master ([#8472](https://github.com/AztecProtocol/aztec-packages/issues/8472)) ([26706e9](https://github.com/AztecProtocol/aztec-packages/commit/26706e9d4339e6cf7603b6c86f1e7a1d3942bd63))
66+
* Remove 3 unused functions warnings in the stdlib (https://github.com/noir-lang/noir/pull/5973) ([8ac81b1](https://github.com/AztecProtocol/aztec-packages/commit/8ac81b15cd2a3b57493bfbfe444086deac8f3dc8))
67+
* Remove warnings from protocol circuits ([#8420](https://github.com/AztecProtocol/aztec-packages/issues/8420)) ([c4dbcab](https://github.com/AztecProtocol/aztec-packages/commit/c4dbcabf48e930b2c541a1d98d8c1e3807f4f4fc))
68+
* Rename files relating to what were "instances" ([#8383](https://github.com/AztecProtocol/aztec-packages/issues/8383)) ([a934e85](https://github.com/AztecProtocol/aztec-packages/commit/a934e85b416a029ae057e0e70277401fb7cfe4b9))
69+
* Replace relative paths to noir-protocol-circuits ([1c43bae](https://github.com/AztecProtocol/aztec-packages/commit/1c43bae21fbe909eff62d1f7ebb5789fbfa8bef3))
70+
371
## [0.53.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.52.0...aztec-packages-v0.53.0) (2024-09-09)
472

573

barretenberg/CHANGELOG.md

+32
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,37 @@
11
# Changelog
22

3+
## [0.54.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.53.0...barretenberg-v0.54.0) (2024-09-10)
4+
5+
6+
### ⚠ BREAKING CHANGES
7+
8+
* **avm:** variants for binary operations ([#8473](https://github.com/AztecProtocol/aztec-packages/issues/8473))
9+
* **avm:** make JUMP(I) 16-bit ([#8443](https://github.com/AztecProtocol/aztec-packages/issues/8443))
10+
* **avm:** variants for SET opcode ([#8441](https://github.com/AztecProtocol/aztec-packages/issues/8441))
11+
* **avm:** variants for MOV opcode ([#8440](https://github.com/AztecProtocol/aztec-packages/issues/8440))
12+
13+
### Features
14+
15+
* (bb) 128-bit challenges ([#8406](https://github.com/AztecProtocol/aztec-packages/issues/8406)) ([d5b2397](https://github.com/AztecProtocol/aztec-packages/commit/d5b239745178d1ce4eb8b8d32fa4b366c13c3c94))
16+
* **avm:** DSL integration of AVM recursive verifier ([#8405](https://github.com/AztecProtocol/aztec-packages/issues/8405)) ([467120e](https://github.com/AztecProtocol/aztec-packages/commit/467120e5a95de267910c2f95b65dcb62c60f995d)), closes [#8285](https://github.com/AztecProtocol/aztec-packages/issues/8285)
17+
* **avm:** Make JUMP(I) 16-bit ([#8443](https://github.com/AztecProtocol/aztec-packages/issues/8443)) ([5bb38b1](https://github.com/AztecProtocol/aztec-packages/commit/5bb38b1692469520f29a1c85bc381c1ca9eb4032))
18+
* **avm:** Variants for binary operations ([#8473](https://github.com/AztecProtocol/aztec-packages/issues/8473)) ([8de1f2a](https://github.com/AztecProtocol/aztec-packages/commit/8de1f2a942024aad955ea0f318cb044e3692b7fc))
19+
* **avm:** Variants for MOV opcode ([#8440](https://github.com/AztecProtocol/aztec-packages/issues/8440)) ([5b27fbc](https://github.com/AztecProtocol/aztec-packages/commit/5b27fbca982442251a350d6571bdd007b715d575))
20+
* **avm:** Variants for SET opcode ([#8441](https://github.com/AztecProtocol/aztec-packages/issues/8441)) ([dc43306](https://github.com/AztecProtocol/aztec-packages/commit/dc433064391b2ac93bca6b838adac271fbd28991))
21+
* **bb:** Towards reduced polynomial memory usage ([#7990](https://github.com/AztecProtocol/aztec-packages/issues/7990)) ([372f23c](https://github.com/AztecProtocol/aztec-packages/commit/372f23ce0aa44a3aa6e1ef2f864df303a3229e6b))
22+
23+
24+
### Bug Fixes
25+
26+
* **avm:** Full proving kernel fix ([#8468](https://github.com/AztecProtocol/aztec-packages/issues/8468)) ([684d962](https://github.com/AztecProtocol/aztec-packages/commit/684d96271669116380facfa48db6cba3a5d945de))
27+
* **bb:** Mac release ([#8450](https://github.com/AztecProtocol/aztec-packages/issues/8450)) ([1b3f914](https://github.com/AztecProtocol/aztec-packages/commit/1b3f914fc069ec84fbd93621eb369128c3ba0dc5))
28+
29+
30+
### Miscellaneous
31+
32+
* **bb:** Remove poly downsizing, other fast-follow from structured polys ([#8475](https://github.com/AztecProtocol/aztec-packages/issues/8475)) ([ac88f30](https://github.com/AztecProtocol/aztec-packages/commit/ac88f30808199c2625f889671f2767c3667becb5))
33+
* Rename files relating to what were "instances" ([#8383](https://github.com/AztecProtocol/aztec-packages/issues/8383)) ([a934e85](https://github.com/AztecProtocol/aztec-packages/commit/a934e85b416a029ae057e0e70277401fb7cfe4b9))
34+
335
## [0.53.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.52.0...barretenberg-v0.53.0) (2024-09-09)
436

537

barretenberg/cpp/CMakeLists.txt

+1-1
Original file line numberDiff line numberDiff line change
@@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24 FATAL_ERROR)
66
project(
77
Barretenberg
88
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
9-
VERSION 0.53.0 # x-release-please-version
9+
VERSION 0.54.0 # x-release-please-version
1010
LANGUAGES CXX C
1111
)
1212
# Insert version into `bb` config file

barretenberg/ts/CHANGELOG.md

+7
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,12 @@
11
# Changelog
22

3+
## [0.54.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.53.0...barretenberg.js-v0.54.0) (2024-09-10)
4+
5+
6+
### Miscellaneous
7+
8+
* **barretenberg.js:** Synchronize aztec-packages versions
9+
310
## [0.53.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.52.0...barretenberg.js-v0.53.0) (2024-09-09)
411

512

barretenberg/ts/package.json

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
{
22
"name": "@aztec/bb.js",
33
"packageManager": "yarn@1.22.22",
4-
"version": "0.53.0",
4+
"version": "0.54.0",
55
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/barretenberg/ts",
66
"license": "MIT",
77
"type": "module",

yarn-project/aztec/CHANGELOG.md

+12
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,17 @@
11
# Changelog
22

3+
## [0.54.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.53.0...aztec-package-v0.54.0) (2024-09-10)
4+
5+
6+
### Features
7+
8+
* Archiver fork block num ([#8425](https://github.com/AztecProtocol/aztec-packages/issues/8425)) ([a9f2364](https://github.com/AztecProtocol/aztec-packages/commit/a9f2364264e5cba4d01f09ef18801dd5ff39ae87))
9+
10+
11+
### Miscellaneous
12+
13+
* Merge devnet to master ([#8472](https://github.com/AztecProtocol/aztec-packages/issues/8472)) ([26706e9](https://github.com/AztecProtocol/aztec-packages/commit/26706e9d4339e6cf7603b6c86f1e7a1d3942bd63))
14+
315
## [0.53.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.52.0...aztec-package-v0.53.0) (2024-09-09)
416

517

yarn-project/aztec/package.json

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
{
22
"name": "@aztec/aztec",
3-
"version": "0.53.0",
3+
"version": "0.54.0",
44
"type": "module",
55
"exports": {
66
".": "./dest/index.js"

0 commit comments

Comments
 (0)