Skip to content

Commit 7f6dba2

Browse files
committed
chore(master): Release 0.49.0
1 parent 33d47d2 commit 7f6dba2

File tree

8 files changed

+95
-7
lines changed

8 files changed

+95
-7
lines changed

.release-please-manifest.json

+4-4
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
{
2-
".": "0.48.0",
2+
".": "0.49.0",
33
"yarn-project/cli": "0.35.1",
4-
"yarn-project/aztec": "0.48.0",
5-
"barretenberg": "0.48.0",
6-
"barretenberg/ts": "0.48.0"
4+
"yarn-project/aztec": "0.49.0",
5+
"barretenberg": "0.49.0",
6+
"barretenberg/ts": "0.49.0"
77
}

CHANGELOG.md

+58
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,63 @@
11
# Changelog
22

3+
## [0.49.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.48.0...aztec-packages-v0.49.0) (2024-08-13)
4+
5+
6+
### ⚠ BREAKING CHANGES
7+
8+
* Sequencer no longer proves ([#7860](https://github.com/AztecProtocol/aztec-packages/issues/7860))
9+
10+
### Features
11+
12+
* Add `FunctionDefinition::parameters`, `FunctionDefinition::return_type` and `impl Eq for Quoted` (https://github.com/noir-lang/noir/pull/5681) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
13+
* Add `Type::as_struct` (https://github.com/noir-lang/noir/pull/5680) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
14+
* Add `Type::is_field` and `Type::as_integer` (https://github.com/noir-lang/noir/pull/5670) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
15+
* Add `Type` methods: `as_tuple`, `as_slice`, `as_array`, `as_constant`, `is_bool` (https://github.com/noir-lang/noir/pull/5678) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
16+
* Add a limited form of arithmetic on generics (https://github.com/noir-lang/noir/pull/5625) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
17+
* Add array_to_str_lossy (https://github.com/noir-lang/noir/pull/5613) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
18+
* Add mutating FunctionDefinition functions (https://github.com/noir-lang/noir/pull/5685) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
19+
* Add some `Module` comptime functions (https://github.com/noir-lang/noir/pull/5684) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
20+
* Derive `Ord` and `Hash` in the stdlib; add `std::meta::make_impl` helper (https://github.com/noir-lang/noir/pull/5683) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
21+
* Enable UltraHonk verifier ([#7923](https://github.com/AztecProtocol/aztec-packages/issues/7923)) ([5e8b4a8](https://github.com/AztecProtocol/aztec-packages/commit/5e8b4a80b8b65d8b5563c9487d33e5aa3d837a2d)), closes [#7373](https://github.com/AztecProtocol/aztec-packages/issues/7373)
22+
* Implement closures in the comptime interpreter (https://github.com/noir-lang/noir/pull/5682) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
23+
* LSP closing brace hints (https://github.com/noir-lang/noir/pull/5686) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
24+
* LSP hover now includes "Go to" links (https://github.com/noir-lang/noir/pull/5677) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
25+
* **noir_js:** Expose UltraHonk and integration tests (https://github.com/noir-lang/noir/pull/5656) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
26+
* Resolve arguments to attributes (https://github.com/noir-lang/noir/pull/5649) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
27+
* **ssa:** Simple serialization of unoptimized SSA to file (https://github.com/noir-lang/noir/pull/5679) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
28+
* Update honk ultra_recursive_verifier to do aggregation ([#7582](https://github.com/AztecProtocol/aztec-packages/issues/7582)) ([a96a5ad](https://github.com/AztecProtocol/aztec-packages/commit/a96a5ad2b153cbe995de753cb7db1da0d0072e0c))
29+
30+
31+
### Bug Fixes
32+
33+
* Add locations to most SSA instructions (https://github.com/noir-lang/noir/pull/5697) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
34+
* Allow txs on block zero ([#7928](https://github.com/AztecProtocol/aztec-packages/issues/7928)) ([5e25cd6](https://github.com/AztecProtocol/aztec-packages/commit/5e25cd688b7a2ce23d693c26ec9d2c1bd7fcb764))
35+
* Build error in e2e_block_building ([0d0646d](https://github.com/AztecProtocol/aztec-packages/commit/0d0646d1c55df0ba072a48887f3c3c344c4dc208))
36+
* Derive generic types (https://github.com/noir-lang/noir/pull/5674) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
37+
* Do not duplicate redundant Brillig debug metadata (https://github.com/noir-lang/noir/pull/5696) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
38+
* Elaborate struct & trait annotations in the correct module (https://github.com/noir-lang/noir/pull/5643) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
39+
* Fix where clause issue in items generated from attributes (https://github.com/noir-lang/noir/pull/5673) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
40+
* Let a trait impl that relies on another trait work (https://github.com/noir-lang/noir/pull/5646) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
41+
* Only record bytecode if >0 ([#7932](https://github.com/AztecProtocol/aztec-packages/issues/7932)) ([3f145b3](https://github.com/AztecProtocol/aztec-packages/commit/3f145b386bc59b76ec6f65173de06289d8c17c0e))
42+
* Remove missing file ([#7941](https://github.com/AztecProtocol/aztec-packages/issues/7941)) ([4d9290f](https://github.com/AztecProtocol/aztec-packages/commit/4d9290f009d4cf3202a3decf224005b3a6f86f42))
43+
* Switch verify proof to arrays (https://github.com/noir-lang/noir/pull/5664) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
44+
* Track L1 block for last L2 block body retrieved ([#7927](https://github.com/AztecProtocol/aztec-packages/issues/7927)) ([cd36be4](https://github.com/AztecProtocol/aztec-packages/commit/cd36be499911cc683480723792c16b3506a83c9d)), closes [#7918](https://github.com/AztecProtocol/aztec-packages/issues/7918)
45+
* Unexpose get note nonces on pxe ([#7889](https://github.com/AztecProtocol/aztec-packages/issues/7889)) ([163c3a6](https://github.com/AztecProtocol/aztec-packages/commit/163c3a63df930c86832f8056e004ed3c1bc16221))
46+
* Workaround from_slice with nested slices (https://github.com/noir-lang/noir/pull/5648) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
47+
48+
49+
### Miscellaneous
50+
51+
* Add docs tip about filenames between commands (https://github.com/noir-lang/noir/pull/5695) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
52+
* Add parser support for `<MyType as Trait>::ident` (https://github.com/noir-lang/noir/pull/5688) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
53+
* **bb:** Constexpr simplifications ([#7906](https://github.com/AztecProtocol/aztec-packages/issues/7906)) ([65d3b7f](https://github.com/AztecProtocol/aztec-packages/commit/65d3b7f68fe921d7cf7495a92863c555783636d9))
54+
* **ci:** Print detailed target timings ([#7934](https://github.com/AztecProtocol/aztec-packages/issues/7934)) ([fb574aa](https://github.com/AztecProtocol/aztec-packages/commit/fb574aaf70dc98bb006b1f649a77b0c14b87d60e))
55+
* Move siloing to reset ([#7871](https://github.com/AztecProtocol/aztec-packages/issues/7871)) ([014b5f0](https://github.com/AztecProtocol/aztec-packages/commit/014b5f03f720e8f56199ec0b1c34694bd0e100e1))
56+
* Release Noir(0.33.0) (https://github.com/noir-lang/noir/pull/5550) ([b1c7374](https://github.com/AztecProtocol/aztec-packages/commit/b1c737442a7f295be0079a4c50261bf9c82314d1))
57+
* Replace relative paths to noir-protocol-circuits ([54c4441](https://github.com/AztecProtocol/aztec-packages/commit/54c44416272d87035d024acc9635ef0d515356ca))
58+
* Sequencer no longer proves ([#7860](https://github.com/AztecProtocol/aztec-packages/issues/7860)) ([7168290](https://github.com/AztecProtocol/aztec-packages/commit/71682901b04215d78c613f627a0a46a642001019))
59+
* Update provernet docker compose template ([#7929](https://github.com/AztecProtocol/aztec-packages/issues/7929)) ([33d47d2](https://github.com/AztecProtocol/aztec-packages/commit/33d47d2739a71e8b7589cbd5fcae726982f43ffe))
60+
361
## [0.48.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.47.1...aztec-packages-v0.48.0) (2024-08-12)
462

563

barretenberg/CHANGELOG.md

+12
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,17 @@
11
# Changelog
22

3+
## [0.49.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.48.0...barretenberg-v0.49.0) (2024-08-13)
4+
5+
6+
### Features
7+
8+
* Update honk ultra_recursive_verifier to do aggregation ([#7582](https://github.com/AztecProtocol/aztec-packages/issues/7582)) ([a96a5ad](https://github.com/AztecProtocol/aztec-packages/commit/a96a5ad2b153cbe995de753cb7db1da0d0072e0c))
9+
10+
11+
### Miscellaneous
12+
13+
* **bb:** Constexpr simplifications ([#7906](https://github.com/AztecProtocol/aztec-packages/issues/7906)) ([65d3b7f](https://github.com/AztecProtocol/aztec-packages/commit/65d3b7f68fe921d7cf7495a92863c555783636d9))
14+
315
## [0.48.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.47.1...barretenberg-v0.48.0) (2024-08-12)
416

517

barretenberg/cpp/CMakeLists.txt

+1-1
Original file line numberDiff line numberDiff line change
@@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24 FATAL_ERROR)
66
project(
77
Barretenberg
88
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
9-
VERSION 0.48.0 # x-release-please-version
9+
VERSION 0.49.0 # x-release-please-version
1010
LANGUAGES CXX C
1111
)
1212
# Insert version into `bb` config file

barretenberg/ts/CHANGELOG.md

+7
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,12 @@
11
# Changelog
22

3+
## [0.49.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.48.0...barretenberg.js-v0.49.0) (2024-08-13)
4+
5+
6+
### Miscellaneous
7+
8+
* **barretenberg.js:** Synchronize aztec-packages versions
9+
310
## [0.48.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.47.1...barretenberg.js-v0.48.0) (2024-08-12)
411

512

barretenberg/ts/package.json

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
{
22
"name": "@aztec/bb.js",
3-
"version": "0.48.0",
3+
"version": "0.49.0",
44
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/barretenberg/ts",
55
"license": "MIT",
66
"type": "module",

yarn-project/aztec/CHANGELOG.md

+11
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,16 @@
11
# Changelog
22

3+
## [0.49.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.48.0...aztec-package-v0.49.0) (2024-08-13)
4+
5+
6+
### ⚠ BREAKING CHANGES
7+
8+
* Sequencer no longer proves ([#7860](https://github.com/AztecProtocol/aztec-packages/issues/7860))
9+
10+
### Miscellaneous
11+
12+
* Sequencer no longer proves ([#7860](https://github.com/AztecProtocol/aztec-packages/issues/7860)) ([7168290](https://github.com/AztecProtocol/aztec-packages/commit/71682901b04215d78c613f627a0a46a642001019))
13+
314
## [0.48.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.47.1...aztec-package-v0.48.0) (2024-08-12)
415

516

yarn-project/aztec/package.json

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
{
22
"name": "@aztec/aztec",
3-
"version": "0.48.0",
3+
"version": "0.49.0",
44
"type": "module",
55
"exports": {
66
".": "./dest/index.js"

0 commit comments

Comments
 (0)