Skip to content

Commit 86b2490

Browse files
authored
feat(deploys): OTEL_RESOURCE_ATTRIBUTES (#9642)
This adds k8s environment to otel resources bringing back parity with filtering when we had the daemonset <img width="851" alt="Screenshot 2024-10-31 at 9 47 55 PM" src="https://github.com/user-attachments/assets/7bfb672e-7569-4e1a-8b13-b4c7a994318a">
1 parent 1aef553 commit 86b2490

File tree

4 files changed

+14
-0
lines changed

4 files changed

+14
-0
lines changed

spartan/aztec-network/templates/boot-node.yaml

+2
Original file line numberDiff line numberDiff line change
@@ -135,6 +135,8 @@ spec:
135135
value: "0.0.0.0:{{ .Values.bootNode.service.p2pUdpPort }}"
136136
- name: VALIDATOR_PRIVATE_KEY
137137
value: "0xac0974bec39a17e36ba4a6b4d238ff944bacb478cbed5efcae784d7bf4f2ff80"
138+
- name: OTEL_RESOURCE_ATTRIBUTES
139+
value: service.name={{ .Release.Name }},service.namespace={{ .Release.Namespace }},service.version={{ .Chart.AppVersion }},environment={{ .Values.environment | default "production" }}
138140
- name: OTEL_EXPORTER_OTLP_METRICS_ENDPOINT
139141
value: {{ include "aztec-network.otelCollectorMetricsEndpoint" . | quote }}
140142
- name: OTEL_EXPORTER_OTLP_TRACES_ENDPOINT

spartan/aztec-network/templates/prover-agent.yaml

+2
Original file line numberDiff line numberDiff line change
@@ -64,6 +64,8 @@ spec:
6464
value: {{ .Values.proverAgent.concurrency | quote }}
6565
- name: HARDWARE_CONCURRENCY
6666
value: {{ .Values.proverAgent.bb.hardwareConcurrency | quote }}
67+
- name: OTEL_RESOURCE_ATTRIBUTES
68+
value: service.name={{ .Release.Name }},service.namespace={{ .Release.Namespace }},service.version={{ .Chart.AppVersion }},environment={{ .Values.environment | default "production" }}
6769
- name: OTEL_EXPORTER_OTLP_METRICS_ENDPOINT
6870
value: {{ include "aztec-network.otelCollectorMetricsEndpoint" . | quote }}
6971
- name: OTEL_EXPORTER_OTLP_TRACES_ENDPOINT

spartan/aztec-network/templates/prover-node.yaml

+8
Original file line numberDiff line numberDiff line change
@@ -92,9 +92,17 @@ spec:
9292
value: "{{ .Values.proverNode.proverAgentEnabled }}"
9393
- name: PROVER_PUBLISHER_PRIVATE_KEY
9494
value: "0xac0974bec39a17e36ba4a6b4d238ff944bacb478cbed5efcae784d7bf4f2ff80"
95+
- name: OTEL_RESOURCE_ATTRIBUTES
96+
value: service.name={{ .Release.Name }},service.namespace={{ .Release.Namespace }},service.version={{ .Chart.AppVersion }},environment={{ .Values.environment | default "production" }}
9597
# get private proofs from the boot node
9698
- name: PROVER_JOB_SOURCE_URL
9799
value: "http://$(POD_IP):{{ .Values.proverNode.service.nodePort }}"
100+
- name: OTEL_EXPORTER_OTLP_METRICS_ENDPOINT
101+
value: {{ include "aztec-network.otelCollectorMetricsEndpoint" . | quote }}
102+
- name: OTEL_EXPORTER_OTLP_TRACES_ENDPOINT
103+
value: {{ include "aztec-network.otelCollectorTracesEndpoint" . | quote }}
104+
- name: OTEL_EXPORTER_OTLP_LOGS_ENDPOINT
105+
value: {{ include "aztec-network.otelCollectorLogsEndpoint" . | quote }}
98106
- name: P2P_ENABLED
99107
value: "{{ .Values.proverNode.p2pEnabled }}"
100108
- name: P2P_TCP_ANNOUNCE_ADDR

spartan/aztec-network/templates/validator.yaml

+2
Original file line numberDiff line numberDiff line change
@@ -136,6 +136,8 @@ spec:
136136
value: "0.0.0.0:{{ .Values.validator.service.p2pTcpPort }}"
137137
- name: P2P_UDP_LISTEN_ADDR
138138
value: "0.0.0.0:{{ .Values.validator.service.p2pUdpPort }}"
139+
- name: OTEL_RESOURCE_ATTRIBUTES
140+
value: service.name={{ .Release.Name }},service.namespace={{ .Release.Namespace }},service.version={{ .Chart.AppVersion }},environment={{ .Values.environment | default "production" }}
139141
- name: OTEL_EXPORTER_OTLP_METRICS_ENDPOINT
140142
value: {{ include "aztec-network.otelCollectorMetricsEndpoint" . | quote }}
141143
- name: OTEL_EXPORTER_OTLP_TRACES_ENDPOINT

0 commit comments

Comments
 (0)