Skip to content

Commit de8e126

Browse files
committed
[1 changes] feat: trait aliases (noir-lang/noir#6431)
chore: Added test showcasing performance regression (noir-lang/noir#6566) chore: embed package name in logs (noir-lang/noir#6564) chore: remove separate acvm versioning (noir-lang/noir#6561) chore: switch to 1.0.0-beta versioning (noir-lang/noir#6503) chore: Release Noir(0.39.0) (noir-lang/noir#6484) feat: Sync from aztec-packages (noir-lang/noir#6557) feat(ssa): Unroll small loops in brillig (noir-lang/noir#6505) fix: Do a shallow follow_bindings before unification (noir-lang/noir#6558) chore: remove some `_else_condition` tech debt (noir-lang/noir#6522) chore: revert #6375 (noir-lang/noir#6552) feat: simplify constant MSM calls in SSA (noir-lang/noir#6547) chore(test): Remove duplicate brillig tests (noir-lang/noir#6523) chore: restructure `noirc_evaluator` crate (noir-lang/noir#6534) fix: take blackbox function outputs into account when merging expressions (noir-lang/noir#6532) chore: Add `Instruction::MakeArray` to SSA (noir-lang/noir#6071) feat(profiler): Reduce memory in Brillig execution flamegraph (noir-lang/noir#6538) chore: convert some tests to use SSA parser (noir-lang/noir#6543) chore(ci): bump mac github runner image to `macos-14` (noir-lang/noir#6545) chore(test): More descriptive labels in test matrix (noir-lang/noir#6542) chore: Remove unused methods from implicit numeric generics (noir-lang/noir#6541) fix: Fix poor handling of aliased references in flattening pass causing some values to be zeroed (noir-lang/noir#6434) fix: allow range checks to be performed within the comptime intepreter (noir-lang/noir#6514) fix: disallow `#[test]` on associated functions (noir-lang/noir#6449) chore(ssa): Skip array_set pass for Brillig functions (noir-lang/noir#6513) chore: Reverse ssa parser diff order (noir-lang/noir#6511) chore: Parse negatives in SSA parser (noir-lang/noir#6510) feat: avoid unnecessary ssa passes while loop unrolling (noir-lang/noir#6509) fix(tests): Use a file lock as well as a mutex to isolate tests cases (noir-lang/noir#6508) fix: set local_module before elaborating each trait (noir-lang/noir#6506) fix: parse Slice type in SSa (noir-lang/noir#6507) fix: perform arithmetic simplification through `CheckedCast` (noir-lang/noir#6502) feat: SSA parser (noir-lang/noir#6489) chore(test): Run test matrix on test_programs (noir-lang/noir#6429) chore(ci): fix cargo deny (noir-lang/noir#6501) feat: Deduplicate instructions across blocks (noir-lang/noir#6499) chore: move tests for arithmetic generics closer to the code (noir-lang/noir#6497) fix(docs): Fix broken links in oracles doc (noir-lang/noir#6488) fix: Treat all parameters as possible aliases of each other (noir-lang/noir#6477) chore: bump rust dependencies (noir-lang/noir#6482) feat: use a full `BlackBoxFunctionSolver` implementation when execution brillig during acirgen (noir-lang/noir#6481) chore(docs): Update How to Oracles (noir-lang/noir#5675) chore: Release Noir(0.38.0) (noir-lang/noir#6422) fix(ssa): Change array_set to not mutate slices coming from function inputs (noir-lang/noir#6463) chore: update example to show how to split public inputs in bash (noir-lang/noir#6472) fix: Discard optimisation that would change execution ordering or that is related to call outputs (noir-lang/noir#6461) chore: proptest for `canonicalize` on infix type expressions (noir-lang/noir#6269) fix: let formatter respect newlines between comments (noir-lang/noir#6458) fix: check infix expression is valid in program input (noir-lang/noir#6450) fix: don't crash on AsTraitPath with empty path (noir-lang/noir#6454) fix(tests): Prevent EOF error while running test programs (noir-lang/noir#6455) fix(sea): mem2reg to treat block input references as alias (noir-lang/noir#6452) chore: revamp attributes (noir-lang/noir#6424) feat!: Always Check Arithmetic Generics at Monomorphization (noir-lang/noir#6329) chore: split path and import lookups (noir-lang/noir#6430) fix(ssa): Resolve value IDs in terminator before comparing to array (noir-lang/noir#6448) fix: right shift is not a regular division (noir-lang/noir#6400)
1 parent 58761fc commit de8e126

File tree

276 files changed

+17278
-2474
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

276 files changed

+17278
-2474
lines changed

.noir-sync-commit

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
13856a121125b1ccca15919942081a5d157d280e
1+
68c32b4ffd9b069fe4b119327dbf4018c17ab9d4

noir/noir-repo/.github/workflows/publish-nargo.yml

+2-2
Original file line numberDiff line numberDiff line change
@@ -23,7 +23,7 @@ permissions:
2323

2424
jobs:
2525
build-apple-darwin:
26-
runs-on: macos-12
26+
runs-on: macos-14
2727
env:
2828
CROSS_CONFIG: ${{ github.workspace }}/.github/Cross.toml
2929
NIGHTLY_RELEASE: ${{ inputs.tag == '' }}
@@ -41,7 +41,7 @@ jobs:
4141
- name: Setup for Apple Silicon
4242
if: matrix.target == 'aarch64-apple-darwin'
4343
run: |
44-
sudo xcode-select -s /Applications/Xcode_13.2.1.app/Contents/Developer/
44+
sudo xcode-select -s /Applications/Xcode_15.4.0.app/Contents/Developer/
4545
echo "SDKROOT=$(xcrun -sdk macosx$(sw_vers -productVersion) --show-sdk-path)" >> $GITHUB_ENV
4646
echo "MACOSX_DEPLOYMENT_TARGET=$(xcrun -sdk macosx$(sw_vers -productVersion) --show-sdk-platform-version)" >> $GITHUB_ENV
4747

noir/noir-repo/.github/workflows/release.yml

+1-2
Original file line numberDiff line numberDiff line change
@@ -15,10 +15,9 @@ jobs:
1515
steps:
1616
- name: Run release-please
1717
id: release
18-
uses: google-github-actions/release-please-action@v3
18+
uses: google-github-actions/release-please-action@v4
1919
with:
2020
token: ${{ secrets.NOIR_RELEASES_TOKEN }}
21-
command: manifest
2221

2322
update-acvm-workspace-package-versions:
2423
name: Update acvm workspace package versions
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,3 @@
11
{
2-
".": "0.38.0",
3-
"acvm-repo": "0.54.0"
2+
".": "0.39.0"
43
}

noir/noir-repo/CHANGELOG.md

+42
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,47 @@
11
# Changelog
22

3+
## [0.39.0](https://github.com/noir-lang/noir/compare/v0.38.0...v0.39.0) (2024-11-19)
4+
5+
6+
### ⚠ BREAKING CHANGES
7+
8+
* Remove `recursive` from ACIR format; add them to API and CLI (https://github.com/AztecProtocol/aztec-packages/pull/9479)
9+
10+
### Features
11+
12+
* Avoid unnecessary ssa passes while loop unrolling ([#6509](https://github.com/noir-lang/noir/issues/6509)) ([f81c649](https://github.com/noir-lang/noir/commit/f81c6497ff88e1cc6f3f5c183e679090c6433c65))
13+
* Deduplicate instructions across blocks ([#6499](https://github.com/noir-lang/noir/issues/6499)) ([b65a63d](https://github.com/noir-lang/noir/commit/b65a63d8d898e46cc686baa500f0b8070e45df14))
14+
* Encode static error strings in the ABI (https://github.com/AztecProtocol/aztec-packages/pull/9552) ([7dd71c1](https://github.com/noir-lang/noir/commit/7dd71c15cbcbf025ba049b506c94924903b32754))
15+
* Parallelize DIE pass (https://github.com/AztecProtocol/aztec-packages/pull/9933) ([7dd71c1](https://github.com/noir-lang/noir/commit/7dd71c15cbcbf025ba049b506c94924903b32754))
16+
* **profiler:** Reduce memory in Brillig execution flamegraph ([#6538](https://github.com/noir-lang/noir/issues/6538)) ([1cad7c8](https://github.com/noir-lang/noir/commit/1cad7c887893ebfb5de57a71d7965c8b88158a14))
17+
* Simplify constant MSM calls in SSA ([#6547](https://github.com/noir-lang/noir/issues/6547)) ([f291e37](https://github.com/noir-lang/noir/commit/f291e3702589a5cd043acfded5e187f56ec765cc))
18+
* SSA parser ([#6489](https://github.com/noir-lang/noir/issues/6489)) ([21c9db5](https://github.com/noir-lang/noir/commit/21c9db5f325beef91df024838c4b33ff7f704332))
19+
* **ssa:** Unroll small loops in brillig ([#6505](https://github.com/noir-lang/noir/issues/6505)) ([5d5175e](https://github.com/noir-lang/noir/commit/5d5175e1c076bd651702b6c84a00c85bc4fea860))
20+
* Stop with HeapVector (https://github.com/AztecProtocol/aztec-packages/pull/9810) ([7dd71c1](https://github.com/noir-lang/noir/commit/7dd71c15cbcbf025ba049b506c94924903b32754))
21+
* Sync from noir (https://github.com/AztecProtocol/aztec-packages/pull/9711) ([7dd71c1](https://github.com/noir-lang/noir/commit/7dd71c15cbcbf025ba049b506c94924903b32754))
22+
* Use a full `BlackBoxFunctionSolver` implementation when execution brillig during acirgen ([#6481](https://github.com/noir-lang/noir/issues/6481)) ([22fc11a](https://github.com/noir-lang/noir/commit/22fc11ace31b515287f62219c0e6d6ed3d1bedd7))
23+
24+
25+
### Bug Fixes
26+
27+
* Allow range checks to be performed within the comptime intepreter ([#6514](https://github.com/noir-lang/noir/issues/6514)) ([852c87a](https://github.com/noir-lang/noir/commit/852c87ae9ecdd441ee4c2ab3e78e86b2da07d8a4))
28+
* Disallow `#[test]` on associated functions ([#6449](https://github.com/noir-lang/noir/issues/6449)) ([35408ab](https://github.com/noir-lang/noir/commit/35408ab303f1018c1e2c38e6ea55430a2c89dc4c))
29+
* Do a shallow follow_bindings before unification ([#6558](https://github.com/noir-lang/noir/issues/6558)) ([32a9ed9](https://github.com/noir-lang/noir/commit/32a9ed9ad19cf81275c31ca77e4970bc1598c112))
30+
* **docs:** Fix broken links in oracles doc ([#6488](https://github.com/noir-lang/noir/issues/6488)) ([aa37cd5](https://github.com/noir-lang/noir/commit/aa37cd5be25412919f466a938260ae1a485ee096))
31+
* Fix poor handling of aliased references in flattening pass causing some values to be zeroed ([#6434](https://github.com/noir-lang/noir/issues/6434)) ([8932dac](https://github.com/noir-lang/noir/commit/8932dac4847c643341320c2893f7e4297c78c621))
32+
* Parse Slice type in SSa ([#6507](https://github.com/noir-lang/noir/issues/6507)) ([34ad666](https://github.com/noir-lang/noir/commit/34ad6669b210173ddf0484b04e47161b2cfbcadf))
33+
* Perform arithmetic simplification through `CheckedCast` ([#6502](https://github.com/noir-lang/noir/issues/6502)) ([72e8de0](https://github.com/noir-lang/noir/commit/72e8de0656c4789f57ff1d3ddecc8901df627aab))
34+
* Set local_module before elaborating each trait ([#6506](https://github.com/noir-lang/noir/issues/6506)) ([1df8c45](https://github.com/noir-lang/noir/commit/1df8c456d6d256f120d6df6ae3e6735cb7eb7dae))
35+
* Take blackbox function outputs into account when merging expressions ([#6532](https://github.com/noir-lang/noir/issues/6532)) ([713df69](https://github.com/noir-lang/noir/commit/713df69aad56fc5aaefd5d140275a3217de4d866))
36+
* **tests:** Use a file lock as well as a mutex to isolate tests cases ([#6508](https://github.com/noir-lang/noir/issues/6508)) ([cfc22cb](https://github.com/noir-lang/noir/commit/cfc22cb0ca133fce49a25c3f055f5a6b8bd9b58e))
37+
* Treat all parameters as possible aliases of each other ([#6477](https://github.com/noir-lang/noir/issues/6477)) ([0262e5b](https://github.com/noir-lang/noir/commit/0262e5b93ab71a420365c6e56d3250b2d1eea659))
38+
* Typing of artifacts (https://github.com/AztecProtocol/aztec-packages/pull/9581) ([7dd71c1](https://github.com/noir-lang/noir/commit/7dd71c15cbcbf025ba049b506c94924903b32754))
39+
40+
41+
### Miscellaneous Chores
42+
43+
* Remove `recursive` from ACIR format; add them to API and CLI (https://github.com/AztecProtocol/aztec-packages/pull/9479) ([7dd71c1](https://github.com/noir-lang/noir/commit/7dd71c15cbcbf025ba049b506c94924903b32754))
44+
345
## [0.38.0](https://github.com/noir-lang/noir/compare/v0.37.0...v0.38.0) (2024-11-08)
446

547

noir/noir-repo/Cargo.lock

+28-28
Some generated files are not rendered by default. Learn more about customizing how changed files appear on GitHub.

noir/noir-repo/Cargo.toml

+8-8
Original file line numberDiff line numberDiff line change
@@ -40,7 +40,7 @@ resolver = "2"
4040

4141
[workspace.package]
4242
# x-release-please-start-version
43-
version = "0.38.0"
43+
version = "0.39.0"
4444
# x-release-please-end
4545
authors = ["The Noir Team <team@noir-lang.org>"]
4646
edition = "2021"
@@ -57,13 +57,13 @@ unused_qualifications = "warn"
5757
[workspace.dependencies]
5858

5959
# ACVM workspace dependencies
60-
acir_field = { version = "0.54.0", path = "acvm-repo/acir_field", default-features = false }
61-
acir = { version = "0.54.0", path = "acvm-repo/acir", default-features = false }
62-
acvm = { version = "0.54.0", path = "acvm-repo/acvm" }
63-
brillig = { version = "0.54.0", path = "acvm-repo/brillig", default-features = false }
64-
brillig_vm = { version = "0.54.0", path = "acvm-repo/brillig_vm", default-features = false }
65-
acvm_blackbox_solver = { version = "0.54.0", path = "acvm-repo/blackbox_solver", default-features = false }
66-
bn254_blackbox_solver = { version = "0.54.0", path = "acvm-repo/bn254_blackbox_solver", default-features = false }
60+
acir_field = { version = "0.55.0", path = "acvm-repo/acir_field", default-features = false }
61+
acir = { version = "0.55.0", path = "acvm-repo/acir", default-features = false }
62+
acvm = { version = "0.55.0", path = "acvm-repo/acvm" }
63+
brillig = { version = "0.55.0", path = "acvm-repo/brillig", default-features = false }
64+
brillig_vm = { version = "0.55.0", path = "acvm-repo/brillig_vm", default-features = false }
65+
acvm_blackbox_solver = { version = "0.55.0", path = "acvm-repo/blackbox_solver", default-features = false }
66+
bn254_blackbox_solver = { version = "0.55.0", path = "acvm-repo/bn254_blackbox_solver", default-features = false }
6767

6868
# Noir compiler workspace dependencies
6969
fm = { path = "compiler/fm" }

0 commit comments

Comments
 (0)