Skip to content

Commit 9a3b92e

Browse files
committed
pypi-configparser: Autospec creation for update from version 5.3.0 to version 6.0.0
Jason R. Coombs (61): Add PyPy to the test matrix on Linux. Fixes jaraco/skeleton#63. When rendering docs, preserve the syntax for defaults. Fixes jaraco/path#197. Adopt furo theme for docs. Indicate to use latest Python version (workaround for readthedocs/readthedocs.org/#9623). Requires also specifying the OS version (workaround for readthedocs/readthedocs.org#9635). GHA pretty env (#67) Pin mypy to '<0.990' due to realpython/pytest-mypy#141 Remove the hyperlink for the Python versions badge. The PyPI badge is a better anchor for the hyperlink. Apply explicit_package_bases for mypy and unpin the version. Ref python/mypy#14057. Add Python 3.12 to matrix. Only test 3.8-3.10 on Linux. Disable flake8 on Python 3.12. Workaround for tholo/pytest-flake8#87. Honor ResourceWarnings. Fixes jaraco/skeleton#73. tox 4 requires a boolean value, so use '1' to FORCE_COLOR. Fixes jaraco/skeleton#74. Remove unnecessary shebang and encoding header in docs conf. Prevent Python 3.12 from blocking checks. Run tests on Windows again. Fixes #58. Exclude Python 3.7 + Windows from the matrix as permanent workaround for #58. Build docs in CI, including sphinx-lint. Put tidelift docs dependency in its own section to limit merge conflicts. Remove 'configparser' as that renders the stdlib docs. Update badge for 2023 ALLOW_UNICODE no longer needed on Python 3. As a result, ELLIPSES is also now enabled by default. Enable default encoding warning where available. See PEP 597. Suppress EncodingWarning in pytest_black. Workaround for shopkeep/pytest-black#67. Exempt warning. Workaround for realpython/pytest-mypy#152 Add #upstream markers for filtered warnings. Add filter for platform module (ref python/cpython#100750). Remove reference to EncodingWarning as it doesn't exist on some Pythons. Revert "exclude build env from cov reporting (jaraco/skeleton#60)" Disable couldnt-parse warnings. Prescribed workaround for nedbat/coveragepy#1392. Fixes python/importlib_resources#279 and fixes jaraco/skeleton#56. ⚫ Fade to black. Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. Make substitution fields more prominent and distinct from true 'skeleton' references. (#71) Suppress EncodingWarning in build.env. Ref pypa/build#615. Remove reference to EncodingWarning as it doesn't exist on some Pythons. Update RTD boilerplate to new issue. Ref readthedocs/readthedocs.org#10401. Add badge for Ruff. Remove inclusion of python version for docs Adopt towncrier for managing changelog. Fixes jaraco/skeleton#83. Replace workaround for actions/setup-python#508 with 'allow-prereleases' Remove tox boilerplate, no longer necessary with later versions of tox. Require Python 3.8 or later. Expand 'finalize' to commit and tag the change. Leverage pytest-enabler 2.2 for the default config. Prefer 3.x for Python version (latest stable). Collapse skeleton history. Workaround for jaraco/skeleton#87. Add links to project home page and pypi. Fixes jaraco/skeleton#77. Replace redundant step names with simple 'Run'. Increase visibility of security policy. (#4) Normalized headings in readme. 👹 Feed the hobgoblins (delint). Bump exclusion to Python 3.8 now that Windows tests run there. Closes #67. Restore Windows tests on older Pythons (#68) Comment out just the option. cpython-v3.12.0b3 rev=f992a60014b7 Apply pyupgrade for Python 3.8+ to test_backport. Move tests out of the package. Move package out of src Re-enable doctests now that pytest-dev/pytest#3396 is solved. Remove legacy support in configparser module. Skip unimportant coverage checks Finalize Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76) Zach Burnett (1): rename `.readthedocs.yml` to `.readthedocs.yaml` (RTD docs indicate that `.readthedocs.yml` will be deprecated) (#68)
1 parent 2a8b613 commit 9a3b92e

File tree

5 files changed

+23
-22
lines changed

5 files changed

+23
-22
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-configparser
2-
URL = https://files.pythonhosted.org/packages/4b/c0/3a47084aca7a940ed1334f89ed2e67bcb42168c4f40c486e267fe71e7aa0/configparser-5.3.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/0b/65/bad3eb64f30657ee9fa2e00e80b3ad42037db5eb534fadd15a94a11fe979/configparser-6.0.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+4-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-configparser
3-
url = https://files.pythonhosted.org/packages/4b/c0/3a47084aca7a940ed1334f89ed2e67bcb42168c4f40c486e267fe71e7aa0/configparser-5.3.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/0b/65/bad3eb64f30657ee9fa2e00e80b3ad42037db5eb534fadd15a94a11fe979/configparser-6.0.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/configparser/
66
domain =
@@ -19,6 +19,8 @@ autoupdate = true
1919
broken_c++ = false
2020
# disable parallelization during build
2121
broken_parallel_build = false
22+
# create vendor archive with cargo
23+
cargo_vendor = false
2224
# this package is a library compatibility package and only ships versioned library files
2325
compat = false
2426
# set conservative build flags
@@ -58,7 +60,7 @@ skip_tests = false
5860
# add .so files to the lib package instead of dev
5961
so_to_lib = false
6062
# configure build for avx2
61-
use_avx2 = false
63+
use_avx2 = true
6264
# configure build for avx512
6365
use_avx512 = false
6466
# add clang flags

pypi-configparser.spec

+16-17
Original file line numberDiff line numberDiff line change
@@ -1,12 +1,13 @@
11
#
22
# This file is auto-generated. DO NOT EDIT
33
# Generated by: autospec.py
4+
# Using build pattern: pyproject
45
#
56
Name : pypi-configparser
6-
Version : 5.3.0
7-
Release : 15
8-
URL : https://files.pythonhosted.org/packages/4b/c0/3a47084aca7a940ed1334f89ed2e67bcb42168c4f40c486e267fe71e7aa0/configparser-5.3.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/4b/c0/3a47084aca7a940ed1334f89ed2e67bcb42168c4f40c486e267fe71e7aa0/configparser-5.3.0.tar.gz
7+
Version : 6.0.0
8+
Release : 16
9+
URL : https://files.pythonhosted.org/packages/0b/65/bad3eb64f30657ee9fa2e00e80b3ad42037db5eb534fadd15a94a11fe979/configparser-6.0.0.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/0b/65/bad3eb64f30657ee9fa2e00e80b3ad42037db5eb534fadd15a94a11fe979/configparser-6.0.0.tar.gz
1011
Summary : Updated configparser from stdlib for earlier Pythons.
1112
Group : Development/Tools
1213
License : MIT
@@ -27,9 +28,7 @@ BuildRequires : pypi-virtualenv
2728

2829
%description
2930
.. image:: https://img.shields.io/pypi/v/configparser.svg
30-
:target: `PyPI link`_
31-
.. image:: https://img.shields.io/pypi/pyversions/configparser.svg
32-
:target: `PyPI link`_
31+
:target: https://pypi.org/project/configparser
3332

3433
%package license
3534
Summary: license components for the pypi-configparser package.
@@ -59,26 +58,26 @@ python3 components for the pypi-configparser package.
5958

6059

6160
%prep
62-
%setup -q -n configparser-5.3.0
63-
cd %{_builddir}/configparser-5.3.0
61+
%setup -q -n configparser-6.0.0
62+
cd %{_builddir}/configparser-6.0.0
6463
pushd ..
65-
cp -a configparser-5.3.0 buildavx2
64+
cp -a configparser-6.0.0 buildavx2
6665
popd
6766

6867
%build
6968
export http_proxy=http://127.0.0.1:9/
7069
export https_proxy=http://127.0.0.1:9/
7170
export no_proxy=localhost,127.0.0.1,0.0.0.0
7271
export LANG=C.UTF-8
73-
export SOURCE_DATE_EPOCH=1672264667
72+
export SOURCE_DATE_EPOCH=1689001911
7473
export GCC_IGNORE_WERROR=1
7574
export AR=gcc-ar
7675
export RANLIB=gcc-ranlib
7776
export NM=gcc-nm
78-
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
79-
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
80-
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
81-
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
77+
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
78+
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
79+
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
80+
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8281
export MAKEFLAGS=%{?_smp_mflags}
8382
python3 -m build --wheel --skip-dependency-check --no-isolation
8483
pushd ../buildavx2/
@@ -95,7 +94,7 @@ popd
9594
export MAKEFLAGS=%{?_smp_mflags}
9695
rm -rf %{buildroot}
9796
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-configparser
98-
cp %{_builddir}/configparser-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-configparser/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
97+
cp %{_builddir}/configparser-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-configparser/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
9998
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
10099
echo ----[ mark ]----
101100
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -115,7 +114,7 @@ popd
115114

116115
%files license
117116
%defattr(0644,root,root,0755)
118-
/usr/share/package-licenses/pypi-configparser/8e6689d37f82d5617b7f7f7232c94024d41066d1
117+
/usr/share/package-licenses/pypi-configparser/0445ed0f69910eeaee036f09a39a13c6e1f37e12
119118

120119
%files python
121120
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
15
1+
16

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
0096b707d906a9f3b0e52d6e758acdc2b8bde78b/configparser-5.3.0.tar.gz
1+
67e1640b1e3c4462282facbe30d0837c2e81a3b9/configparser-6.0.0.tar.gz

0 commit comments

Comments
 (0)