Skip to content

Commit 436dc93

Browse files
committed
pypi-importlib_metadata: Autospec creation for update from version 4.12.0 to version 5.0.0
Anderson Bravalheri (13): Capture expectations about _normalized_name compatibility in test Add compatibility layer for Python 3.8 stdlib lack of _normalized_name Add compatibility for EntryPoint.matches in stdlib 3.8/3.9 Add type annotations to EntryPoint.name/value/group Make sure Python 3.8/3.9 compatibility tests run on CI Workaround missing distribution name Fix typecheck error by simplifying compatibility shim Add "short circuit" optimization Extract tests for Python 3.9 compatibility into their own file Extract Python 3.9 compatibility layer into its own file Add comments clarifying implementation choices Fix imports Skip coverage in type checking statement C.A.M. Gerlach (6): Add intersphinx support for packaging.python.org Clarify import vs distribution package terms in using.rst Link distribution/import package terms to PyPA glossary on 1st use Add admonition further clarifying import vs distribution packages Link to canonical core metadata spec instead of an old historical PEP Mention API ref & migration guide in importlib_metadata See Also Jason R. Coombs (35): Add Tidelift template Rely on alabaster theme to support sidebar rendering. Use nicer, simpler phrasing Add support for automatic publishing of release notes Use technique for environment passing matching that found in jaraco/skeleton Move Tidelift token into Travis configuration Update badge URL Add funding reference to project List sidebars to avoid errors looking for template 't' Rebrand to 'For Enterprise' Add a 'For Enterprise' section to the README Include token passthrough for azure pipelines publish stage. Move Tidelift release note publishing to Github Actions. Tidelift no longer requires or expects publishing release notes. Remove Tidelift from main.yml, no longer needed Implement tidelift banner using a Sphinx directive implemented by jaraco.tidelift. Consolidate more language between the backport and the canonical usage docs. Ran pre-commit autoupdate Use '-dev' for every Python version. Ref actions/setup-python#213. Use Python 3.11 for cutting releases. Pin flake8. Workaround for tholo/pytest-flake8#87. Update to setup-python v4. Fixes jaraco/skeleton#65. Also update release to v4 Add PyPy to the test matrix on Linux. Fixes jaraco/skeleton#63. When rendering docs, preserve the syntax for defaults. Fixes jaraco/path#197. Adopt furo theme for docs. Update changelog Expand possibilities for "top-level names". Remove SelectableGroups Remove DeprecatedList Remove compatibility for EntryPoints.__getitem__ by index. Remove support for cast of iterable of entry points to dict. Ref #97. Update changelog Disable flake8 due to incompatibility. Update documentation around removal of SelectableGroups. Oleg Iarygin (1): gh-93851: Fix all broken links in Doc/ (GH-93853) Ville Skyttä (1): bpo-22295: use python -m pip rather than plain pip in more examples (GH-24003)
1 parent 93838e4 commit 436dc93

6 files changed

+14
-14
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-importlib_metadata
2-
URL = https://files.pythonhosted.org/packages/1a/16/441080c907df829016729e71d8bdd42d99b9bdde48b01492ed08912c0aa9/importlib_metadata-4.12.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/7e/ec/97f2ce958b62961fddd7258e0ceede844953606ad09b672fa03b86c453d3/importlib_metadata-5.0.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-importlib_metadata
3-
url = https://files.pythonhosted.org/packages/1a/16/441080c907df829016729e71d8bdd42d99b9bdde48b01492ed08912c0aa9/importlib_metadata-4.12.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/7e/ec/97f2ce958b62961fddd7258e0ceede844953606ad09b672fa03b86c453d3/importlib_metadata-5.0.0.tar.gz
44
archives =
55
giturl = https://github.com/python/importlib_metadata/
66
domain =

pypi-importlib_metadata.spec

+9-9
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-importlib_metadata
6-
Version : 4.12.0
7-
Release : 93
8-
URL : https://files.pythonhosted.org/packages/1a/16/441080c907df829016729e71d8bdd42d99b9bdde48b01492ed08912c0aa9/importlib_metadata-4.12.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/1a/16/441080c907df829016729e71d8bdd42d99b9bdde48b01492ed08912c0aa9/importlib_metadata-4.12.0.tar.gz
6+
Version : 5.0.0
7+
Release : 94
8+
URL : https://files.pythonhosted.org/packages/7e/ec/97f2ce958b62961fddd7258e0ceede844953606ad09b672fa03b86c453d3/importlib_metadata-5.0.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/7e/ec/97f2ce958b62961fddd7258e0ceede844953606ad09b672fa03b86c453d3/importlib_metadata-5.0.0.tar.gz
1010
Summary : Read metadata from Python packages
1111
Group : Development/Tools
1212
License : Apache-2.0
@@ -59,19 +59,19 @@ python3 components for the pypi-importlib_metadata package.
5959

6060

6161
%prep
62-
%setup -q -n importlib_metadata-4.12.0
63-
cd %{_builddir}/importlib_metadata-4.12.0
62+
%setup -q -n importlib_metadata-5.0.0
63+
cd %{_builddir}/importlib_metadata-5.0.0
6464
%patch1 -p1
6565
pushd ..
66-
cp -a importlib_metadata-4.12.0 buildavx2
66+
cp -a importlib_metadata-5.0.0 buildavx2
6767
popd
6868

6969
%build
7070
export http_proxy=http://127.0.0.1:9/
7171
export https_proxy=http://127.0.0.1:9/
7272
export no_proxy=localhost,127.0.0.1,0.0.0.0
7373
export LANG=C.UTF-8
74-
export SOURCE_DATE_EPOCH=1656342835
74+
export SOURCE_DATE_EPOCH=1664807086
7575
export GCC_IGNORE_WERROR=1
7676
export CFLAGS="$CFLAGS -fno-lto "
7777
export FCFLAGS="$FFLAGS -fno-lto "
@@ -93,7 +93,7 @@ popd
9393
export MAKEFLAGS=%{?_smp_mflags}
9494
rm -rf %{buildroot}
9595
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-importlib_metadata
96-
cp %{_builddir}/importlib_metadata-4.12.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-importlib_metadata/2b8b815229aa8a61e483fb4ba0588b8b6c491890
96+
cp %{_builddir}/importlib_metadata-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-importlib_metadata/2b8b815229aa8a61e483fb4ba0588b8b6c491890 || :
9797
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
9898
echo ----[ mark ]----
9999
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
93
1+
94

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
ec68de1ec1800048de8656b9d211e22b7fe7c53e/importlib_metadata-4.12.0.tar.gz
1+
38794db2afb90ed0be04bd8b5996a5b5fd45acc2/importlib_metadata-5.0.0.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
4.12.0
1+
5.0.0

0 commit comments

Comments
 (0)