Skip to content

Commit 6a24f29

Browse files
committed
pypi-importlib_metadata: Autospec creation for update from version 7.1.0 to version 8.0.0
Adam Turner (1): GH-109653: Defer import of ``importlib.metadata._adapters`` (python/cpython#109829) Avasam (1): Allow mypy on PyPy (jaraco/skeleton#111) Bartosz Sławecki (2): Add link to blog entry from jaraco/skeleton#115 above CI build matrix. Move project metadata to `pyproject.toml` (jaraco/skeleton#122) Dan Blanchard (4): Add support for egg packages with files outside site-packages Tweak test Update importlib_metadata/__init__.py Fix mypy failure that has nothing to do with this PR Jason R. Coombs (23): Re-enable ignoring of temporary merge queue branches. Closes jaraco/skeleton#103. Fetch unshallow clones in readthedocs. Closes jaraco/skeleton#114. Move Python 3.11 out of the test matrix. Configure pytest to support namespace packages. Ref pytest-dev/pytest#12112. Pin against pytest 8.1.x due to pytest-dev/pytest#12194. Migrated config to pyproject.toml using jaraco.develop.migrate-config and ini2toml. Allow macos on Python 3.8 to fail as GitHub CI has dropped support. Move project.urls to appear in the order that ini2toml generates it. Remove project.scripts. Revert "Allow macos on Python 3.8 to fail as GitHub CI has dropped support." Rename extras to align with core metadata spec. gh-120801: Update fixtures. Finalize Prefer "Source" to "Homepage" for the repository label. Move _relative_to compatibility to a compat module. Update wrapper to rely on 'relative_to(walk_up=True)' on Python 3.12 and compatibility wrapper on Python 3.11 and earlier. Mark compat code as uncovered. Revert "Fix mypy failure that has nothing to do with this PR" Remove additional method in SimplePath. Add news fragment Finalize Removed deprecated support for Distribution subclasses not implementing abstract methods. Message.__getitem__ now raises a KeyError on missing keys. Finalize
1 parent 2a11ef9 commit 6a24f29

7 files changed

+17
-18
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-importlib_metadata
2-
URL = https://files.pythonhosted.org/packages/a0/fc/c4e6078d21fc4fa56300a241b87eae76766aa380a23fc450fc85bb7bf547/importlib_metadata-7.1.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/20/ff/bd28f70283b9cca0cbf0c2a6082acbecd822d1962ae7b2a904861b9965f8/importlib_metadata-8.0.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+3-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-importlib_metadata
3-
url = https://files.pythonhosted.org/packages/a0/fc/c4e6078d21fc4fa56300a241b87eae76766aa380a23fc450fc85bb7bf547/importlib_metadata-7.1.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/20/ff/bd28f70283b9cca0cbf0c2a6082acbecd822d1962ae7b2a904861b9965f8/importlib_metadata-8.0.0.tar.gz
44
archives =
55
giturl = https://github.com/python/importlib_metadata/
66
domain =
@@ -71,6 +71,8 @@ use_avx512 = false
7171
use_clang = false
7272
# configure build for lto
7373
use_lto = false
74+
# use ninja build files
75+
use_ninja = false
7476
# require package verification for build
7577
verify_required = false
7678

pumpAutospec

-1
This file was deleted.

pypi-importlib_metadata.spec

+10-12
Original file line numberDiff line numberDiff line change
@@ -2,14 +2,14 @@
22
# This file is auto-generated. DO NOT EDIT
33
# Generated by: autospec.py
44
# Using build pattern: pyproject
5-
# autospec version: v4
6-
# autospec commit: f4bef72
5+
# autospec version: v16
6+
# autospec commit: b858a2a
77
#
88
Name : pypi-importlib_metadata
9-
Version : 7.1.0
10-
Release : 116
11-
URL : https://files.pythonhosted.org/packages/a0/fc/c4e6078d21fc4fa56300a241b87eae76766aa380a23fc450fc85bb7bf547/importlib_metadata-7.1.0.tar.gz
12-
Source0 : https://files.pythonhosted.org/packages/a0/fc/c4e6078d21fc4fa56300a241b87eae76766aa380a23fc450fc85bb7bf547/importlib_metadata-7.1.0.tar.gz
9+
Version : 8.0.0
10+
Release : 117
11+
URL : https://files.pythonhosted.org/packages/20/ff/bd28f70283b9cca0cbf0c2a6082acbecd822d1962ae7b2a904861b9965f8/importlib_metadata-8.0.0.tar.gz
12+
Source0 : https://files.pythonhosted.org/packages/20/ff/bd28f70283b9cca0cbf0c2a6082acbecd822d1962ae7b2a904861b9965f8/importlib_metadata-8.0.0.tar.gz
1313
Summary : Read metadata from Python packages
1414
Group : Development/Tools
1515
License : Apache-2.0
@@ -28,7 +28,6 @@ BuildRequires : pypi-virtualenv
2828
# Suppress stripping binaries
2929
%define __strip /bin/true
3030
%define debug_package %{nil}
31-
Patch1: deps.patch
3231

3332
%description
3433
.. image:: https://img.shields.io/pypi/v/importlib_metadata.svg
@@ -63,19 +62,18 @@ python3 components for the pypi-importlib_metadata package.
6362

6463

6564
%prep
66-
%setup -q -n importlib_metadata-7.1.0
67-
cd %{_builddir}/importlib_metadata-7.1.0
68-
%patch -P 1 -p1
65+
%setup -q -n importlib_metadata-8.0.0
66+
cd %{_builddir}/importlib_metadata-8.0.0
6967
pushd ..
70-
cp -a importlib_metadata-7.1.0 buildavx2
68+
cp -a importlib_metadata-8.0.0 buildavx2
7169
popd
7270

7371
%build
7472
export http_proxy=http://127.0.0.1:9/
7573
export https_proxy=http://127.0.0.1:9/
7674
export no_proxy=localhost,127.0.0.1,0.0.0.0
7775
export LANG=C.UTF-8
78-
export SOURCE_DATE_EPOCH=1711032812
76+
export SOURCE_DATE_EPOCH=1721085543
7977
export GCC_IGNORE_WERROR=1
8078
CLEAR_INTERMEDIATE_CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8179
CLEAR_INTERMEDIATE_FCFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
116
1+
117

series

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
deps.patch
1+
#deps.patch

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
cf7e771152556ebd26c6617e7ba46699d5f3d64b/importlib_metadata-7.1.0.tar.gz
1+
937d5a9068811a3cf33517fe2af539dcf336404f/importlib_metadata-8.0.0.tar.gz

0 commit comments

Comments
 (0)