Skip to content

Commit f036e68

Browse files
committed
pypi-inflect: Autospec creation for update from version 6.0.4 to version 6.1.1
Jason R. Coombs (23): Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. Make substitution fields more prominent and distinct from true 'skeleton' references. (#71) Suppress EncodingWarning in build.env. Ref pypa/build#615. Remove reference to EncodingWarning as it doesn't exist on some Pythons. Update RTD boilerplate to new issue. Ref readthedocs/readthedocs.org#10401. Add badge for Ruff. Remove inclusion of python version for docs Adopt towncrier for managing changelog. Fixes jaraco/skeleton#83. Replace workaround for actions/setup-python#508 with 'allow-prereleases' Remove tox boilerplate, no longer necessary with later versions of tox. Require Python 3.8 or later. Expand 'finalize' to commit and tag the change. Leverage pytest-enabler 2.2 for the default config. 👹 Feed the hobgoblins (delint). Add comment linking to ongoing issue. Update changelog. Update changelog. Finalize Handle numeric inputs to ordinal without first casting to string. Fixes #178. Convert examples to doctests. Add test coverage for string-based numbers. Finalize Jennifer Richards (2): Pin pydantic to 1.x Pin pydantic to 1.x Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76)
1 parent 44c1c98 commit f036e68

File tree

5 files changed

+21
-19
lines changed

5 files changed

+21
-19
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-inflect
2-
URL = https://files.pythonhosted.org/packages/3b/9b/6e44523788cadec2a2bef2632c21264a74ab172cf9a13fab5c94b10db7f2/inflect-6.0.4.tar.gz
2+
URL = https://files.pythonhosted.org/packages/29/45/b65eef08acc1ecfc91bbb78f2514642fcb6c2e293fad6a58775417cd3914/inflect-6.1.1.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-inflect
3-
url = https://files.pythonhosted.org/packages/3b/9b/6e44523788cadec2a2bef2632c21264a74ab172cf9a13fab5c94b10db7f2/inflect-6.0.4.tar.gz
3+
url = https://files.pythonhosted.org/packages/29/45/b65eef08acc1ecfc91bbb78f2514642fcb6c2e293fad6a58775417cd3914/inflect-6.1.1.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/inflect/
66
domain =
@@ -60,7 +60,7 @@ skip_tests = false
6060
# add .so files to the lib package instead of dev
6161
so_to_lib = false
6262
# configure build for avx2
63-
use_avx2 = false
63+
use_avx2 = true
6464
# configure build for avx512
6565
use_avx512 = false
6666
# add clang flags

pypi-inflect.spec

+16-14
Original file line numberDiff line numberDiff line change
@@ -4,10 +4,10 @@
44
# Using build pattern: pyproject
55
#
66
Name : pypi-inflect
7-
Version : 6.0.4
8-
Release : 22
9-
URL : https://files.pythonhosted.org/packages/3b/9b/6e44523788cadec2a2bef2632c21264a74ab172cf9a13fab5c94b10db7f2/inflect-6.0.4.tar.gz
10-
Source0 : https://files.pythonhosted.org/packages/3b/9b/6e44523788cadec2a2bef2632c21264a74ab172cf9a13fab5c94b10db7f2/inflect-6.0.4.tar.gz
7+
Version : 6.1.1
8+
Release : 23
9+
URL : https://files.pythonhosted.org/packages/29/45/b65eef08acc1ecfc91bbb78f2514642fcb6c2e293fad6a58775417cd3914/inflect-6.1.1.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/29/45/b65eef08acc1ecfc91bbb78f2514642fcb6c2e293fad6a58775417cd3914/inflect-6.1.1.tar.gz
1111
Summary : Correctly generate plurals, singular nouns, ordinals, indefinite articles; convert numbers to words
1212
Group : Development/Tools
1313
License : MIT
@@ -16,6 +16,8 @@ Requires: pypi-inflect-python = %{version}-%{release}
1616
Requires: pypi-inflect-python3 = %{version}-%{release}
1717
BuildRequires : buildreq-distutils3
1818
BuildRequires : pypi(py)
19+
BuildRequires : pypi(setuptools)
20+
BuildRequires : pypi(setuptools_scm)
1921
BuildRequires : pypi-pluggy
2022
BuildRequires : pypi-pytest
2123
BuildRequires : pypi-tox
@@ -57,26 +59,26 @@ python3 components for the pypi-inflect package.
5759

5860

5961
%prep
60-
%setup -q -n inflect-6.0.4
61-
cd %{_builddir}/inflect-6.0.4
62+
%setup -q -n inflect-6.1.1
63+
cd %{_builddir}/inflect-6.1.1
6264
pushd ..
63-
cp -a inflect-6.0.4 buildavx2
65+
cp -a inflect-6.1.1 buildavx2
6466
popd
6567

6668
%build
6769
export http_proxy=http://127.0.0.1:9/
6870
export https_proxy=http://127.0.0.1:9/
6971
export no_proxy=localhost,127.0.0.1,0.0.0.0
7072
export LANG=C.UTF-8
71-
export SOURCE_DATE_EPOCH=1680793454
73+
export SOURCE_DATE_EPOCH=1688410217
7274
export GCC_IGNORE_WERROR=1
7375
export AR=gcc-ar
7476
export RANLIB=gcc-ranlib
7577
export NM=gcc-nm
76-
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
77-
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
78-
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
79-
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
78+
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
79+
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
80+
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
81+
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8082
export MAKEFLAGS=%{?_smp_mflags}
8183
python3 -m build --wheel --skip-dependency-check --no-isolation
8284
pushd ../buildavx2/
@@ -93,7 +95,7 @@ popd
9395
export MAKEFLAGS=%{?_smp_mflags}
9496
rm -rf %{buildroot}
9597
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-inflect
96-
cp %{_builddir}/inflect-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-inflect/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
98+
cp %{_builddir}/inflect-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-inflect/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
9799
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
98100
echo ----[ mark ]----
99101
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -113,7 +115,7 @@ popd
113115

114116
%files license
115117
%defattr(0644,root,root,0755)
116-
/usr/share/package-licenses/pypi-inflect/8e6689d37f82d5617b7f7f7232c94024d41066d1
118+
/usr/share/package-licenses/pypi-inflect/0445ed0f69910eeaee036f09a39a13c6e1f37e12
117119

118120
%files python
119121
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
22
1+
23

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
c4f4796ed3a038e37824f0addb6b2483cf175760/inflect-6.0.4.tar.gz
1+
19a09bbef0ae01f5369e7d4c858d2490c6e7004c/inflect-6.1.1.tar.gz

0 commit comments

Comments
 (0)