Skip to content
This repository was archived by the owner on Nov 5, 2024. It is now read-only.

Commit 301cbd1

Browse files
committed
pypi-jaraco.collections: Autospec creation for update from version 4.1.0 to version 4.2.0
Jason R. Coombs (7): Remove mention of deprecated DictFilter from readme. Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. Make substitution fields more prominent and distinct from true 'skeleton' references. (#71) Suppress EncodingWarning in build.env. Ref pypa/build#615. Remove reference to EncodingWarning as it doesn't exist on some Pythons. Add Mask object, the inverse of a Projection. Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76)
1 parent 844b917 commit 301cbd1

File tree

5 files changed

+21
-19
lines changed

5 files changed

+21
-19
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-jaraco.collections
2-
URL = https://files.pythonhosted.org/packages/39/5f/3d235b6c12b117c7bc0d96a2bc6ab6bdac00567f8e595729a0cfe14994a7/jaraco.collections-4.1.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/95/60/2cf3c42c0dc26342885390a61a71cb5cb7b49f9bf181bb3e56573ae28a0e/jaraco.collections-4.2.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-jaraco.collections
3-
url = https://files.pythonhosted.org/packages/39/5f/3d235b6c12b117c7bc0d96a2bc6ab6bdac00567f8e595729a0cfe14994a7/jaraco.collections-4.1.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/95/60/2cf3c42c0dc26342885390a61a71cb5cb7b49f9bf181bb3e56573ae28a0e/jaraco.collections-4.2.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/jaraco.collections/
66
domain =
@@ -60,7 +60,7 @@ skip_tests = false
6060
# add .so files to the lib package instead of dev
6161
so_to_lib = false
6262
# configure build for avx2
63-
use_avx2 = false
63+
use_avx2 = true
6464
# configure build for avx512
6565
use_avx512 = false
6666
# add clang flags

pypi-jaraco.collections.spec

+16-14
Original file line numberDiff line numberDiff line change
@@ -4,10 +4,10 @@
44
# Using build pattern: pyproject
55
#
66
Name : pypi-jaraco.collections
7-
Version : 4.1.0
8-
Release : 41
9-
URL : https://files.pythonhosted.org/packages/39/5f/3d235b6c12b117c7bc0d96a2bc6ab6bdac00567f8e595729a0cfe14994a7/jaraco.collections-4.1.0.tar.gz
10-
Source0 : https://files.pythonhosted.org/packages/39/5f/3d235b6c12b117c7bc0d96a2bc6ab6bdac00567f8e595729a0cfe14994a7/jaraco.collections-4.1.0.tar.gz
7+
Version : 4.2.0
8+
Release : 42
9+
URL : https://files.pythonhosted.org/packages/95/60/2cf3c42c0dc26342885390a61a71cb5cb7b49f9bf181bb3e56573ae28a0e/jaraco.collections-4.2.0.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/95/60/2cf3c42c0dc26342885390a61a71cb5cb7b49f9bf181bb3e56573ae28a0e/jaraco.collections-4.2.0.tar.gz
1111
Summary : Collection objects similar to those in stdlib by jaraco
1212
Group : Development/Tools
1313
License : MIT
@@ -16,6 +16,8 @@ Requires: pypi-jaraco.collections-python = %{version}-%{release}
1616
Requires: pypi-jaraco.collections-python3 = %{version}-%{release}
1717
BuildRequires : buildreq-distutils3
1818
BuildRequires : pypi(py)
19+
BuildRequires : pypi(setuptools)
20+
BuildRequires : pypi(setuptools_scm)
1921
BuildRequires : pypi-pluggy
2022
BuildRequires : pypi-pytest
2123
BuildRequires : pypi-tox
@@ -57,26 +59,26 @@ python3 components for the pypi-jaraco.collections package.
5759

5860

5961
%prep
60-
%setup -q -n jaraco.collections-4.1.0
61-
cd %{_builddir}/jaraco.collections-4.1.0
62+
%setup -q -n jaraco.collections-4.2.0
63+
cd %{_builddir}/jaraco.collections-4.2.0
6264
pushd ..
63-
cp -a jaraco.collections-4.1.0 buildavx2
65+
cp -a jaraco.collections-4.2.0 buildavx2
6466
popd
6567

6668
%build
6769
export http_proxy=http://127.0.0.1:9/
6870
export https_proxy=http://127.0.0.1:9/
6971
export no_proxy=localhost,127.0.0.1,0.0.0.0
7072
export LANG=C.UTF-8
71-
export SOURCE_DATE_EPOCH=1680793552
73+
export SOURCE_DATE_EPOCH=1685719181
7274
export GCC_IGNORE_WERROR=1
7375
export AR=gcc-ar
7476
export RANLIB=gcc-ranlib
7577
export NM=gcc-nm
76-
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
77-
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
78-
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
79-
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
78+
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
79+
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
80+
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
81+
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8082
export MAKEFLAGS=%{?_smp_mflags}
8183
python3 -m build --wheel --skip-dependency-check --no-isolation
8284
pushd ../buildavx2/
@@ -93,7 +95,7 @@ popd
9395
export MAKEFLAGS=%{?_smp_mflags}
9496
rm -rf %{buildroot}
9597
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections
96-
cp %{_builddir}/jaraco.collections-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
98+
cp %{_builddir}/jaraco.collections-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
9799
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
98100
echo ----[ mark ]----
99101
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -116,7 +118,7 @@ rm -f %{buildroot}*/usr/lib/python3.*/site-packages/jaraco/__pycache__/__init__.
116118

117119
%files license
118120
%defattr(0644,root,root,0755)
119-
/usr/share/package-licenses/pypi-jaraco.collections/8e6689d37f82d5617b7f7f7232c94024d41066d1
121+
/usr/share/package-licenses/pypi-jaraco.collections/0445ed0f69910eeaee036f09a39a13c6e1f37e12
120122

121123
%files python
122124
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
41
1+
42

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
7cac8f642eaacd982d70b0aa5ac6a3b25d1d2668/jaraco.collections-4.1.0.tar.gz
1+
77036ceb808c922dae838424c2c14f67d63b6e80/jaraco.collections-4.2.0.tar.gz

0 commit comments

Comments
 (0)