4
4
# Using build pattern: pyproject
5
5
#
6
6
Name : pypi-jaraco.collections
7
- Version : 4.1 .0
8
- Release : 41
9
- URL : https://files.pythonhosted.org/packages/39/5f/3d235b6c12b117c7bc0d96a2bc6ab6bdac00567f8e595729a0cfe14994a7 /jaraco.collections-4.1 .0.tar.gz
10
- Source0 : https://files.pythonhosted.org/packages/39/5f/3d235b6c12b117c7bc0d96a2bc6ab6bdac00567f8e595729a0cfe14994a7 /jaraco.collections-4.1 .0.tar.gz
7
+ Version : 4.2 .0
8
+ Release : 42
9
+ URL : https://files.pythonhosted.org/packages/95/60/2cf3c42c0dc26342885390a61a71cb5cb7b49f9bf181bb3e56573ae28a0e /jaraco.collections-4.2 .0.tar.gz
10
+ Source0 : https://files.pythonhosted.org/packages/95/60/2cf3c42c0dc26342885390a61a71cb5cb7b49f9bf181bb3e56573ae28a0e /jaraco.collections-4.2 .0.tar.gz
11
11
Summary : Collection objects similar to those in stdlib by jaraco
12
12
Group : Development/Tools
13
13
License : MIT
@@ -16,6 +16,8 @@ Requires: pypi-jaraco.collections-python = %{version}-%{release}
16
16
Requires: pypi-jaraco.collections-python3 = %{version }-%{release }
17
17
BuildRequires : buildreq-distutils3
18
18
BuildRequires : pypi(py)
19
+ BuildRequires : pypi(setuptools)
20
+ BuildRequires : pypi(setuptools_scm)
19
21
BuildRequires : pypi-pluggy
20
22
BuildRequires : pypi-pytest
21
23
BuildRequires : pypi-tox
@@ -57,26 +59,26 @@ python3 components for the pypi-jaraco.collections package.
57
59
58
60
59
61
%prep
60
- %setup -q -n jaraco.collections-4.1 .0
61
- cd %{_builddir }/jaraco.collections-4.1 .0
62
+ %setup -q -n jaraco.collections-4.2 .0
63
+ cd %{_builddir }/jaraco.collections-4.2 .0
62
64
pushd ..
63
- cp -a jaraco.collections-4.1 .0 buildavx2
65
+ cp -a jaraco.collections-4.2 .0 buildavx2
64
66
popd
65
67
66
68
%build
67
69
export http_proxy=http://127.0.0.1:9/
68
70
export https_proxy=http://127.0.0.1:9/
69
71
export no_proxy=localhost,127.0.0.1,0.0.0.0
70
72
export LANG=C.UTF-8
71
- export SOURCE_DATE_EPOCH=1680793552
73
+ export SOURCE_DATE_EPOCH=1685719181
72
74
export GCC_IGNORE_WERROR=1
73
75
export AR=gcc-ar
74
76
export RANLIB=gcc-ranlib
75
77
export NM=gcc-nm
76
- export CFLAGS=" $CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
77
- export FCFLAGS=" $FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
78
- export FFLAGS=" $FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
79
- export CXXFLAGS=" $CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
78
+ export CFLAGS=" $CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
79
+ export FCFLAGS=" $FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
80
+ export FFLAGS=" $FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
81
+ export CXXFLAGS=" $CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
80
82
export MAKEFLAGS=%{?_smp_mflags }
81
83
python3 -m build --wheel --skip-dependency-check --no-isolation
82
84
pushd ../buildavx2/
93
95
export MAKEFLAGS=%{?_smp_mflags }
94
96
rm -rf %{buildroot }
95
97
mkdir -p %{buildroot }/usr/share/package-licenses/pypi-jaraco.collections
96
- cp %{_builddir }/jaraco.collections-%{version }/LICENSE %{buildroot }/usr/share/package-licenses/pypi-jaraco.collections/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
98
+ cp %{_builddir }/jaraco.collections-%{version }/LICENSE %{buildroot }/usr/share/package-licenses/pypi-jaraco.collections/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
97
99
pip install --root=%{buildroot } --no-deps --ignore-installed dist/* .whl
98
100
echo ----[ mark ]----
99
101
cat %{buildroot }/usr/lib/python3* /site-packages/* /requires.txt || :
@@ -116,7 +118,7 @@ rm -f %{buildroot}*/usr/lib/python3.*/site-packages/jaraco/__pycache__/__init__.
116
118
117
119
%files license
118
120
%defattr(0644,root,root,0755)
119
- /usr/share/package-licenses/pypi-jaraco.collections/8e6689d37f82d5617b7f7f7232c94024d41066d1
121
+ /usr/share/package-licenses/pypi-jaraco.collections/0445ed0f69910eeaee036f09a39a13c6e1f37e12
120
122
121
123
%files python
122
124
%defattr(-,root,root,-)
0 commit comments