Skip to content
This repository was archived by the owner on Nov 5, 2024. It is now read-only.

Commit 94bd3b8

Browse files
committed
pypi-jaraco.collections: Autospec creation for update from version 3.5.2 to version 3.6.0
Jason R. Coombs (18): Use '-dev' for every Python version. Ref actions/setup-python#213. Use Python 3.11 for cutting releases. Pin flake8. Workaround for tholo/pytest-flake8#87. Update to setup-python v4. Fixes jaraco/skeleton#65. Also update release to v4 Add PyPy to the test matrix on Linux. Fixes jaraco/skeleton#63. When rendering docs, preserve the syntax for defaults. Fixes jaraco/path#197. Adopt furo theme for docs. Indicate to use latest Python version (workaround for readthedocs/readthedocs.org/#9623). Requires also specifying the OS version (workaround for readthedocs/readthedocs.org#9635). GHA pretty env (#67) Remove Python 2 compatibility in repr test. Add failing test for __contains__ on DictFilter. Revise DictFilter to rely on Mapping primitives. Fixes issue with `__contains__`. Add illustration in dictfilter on excluding items by prefix. Retain order in DictFilter Prefer pipe for symmetry. Rely on base class for DictFilter.values. Update changelog Zach Burnett (1): rename `.readthedocs.yml` to `.readthedocs.yaml` (RTD docs indicate that `.readthedocs.yml` will be deprecated) (#68)
1 parent b578933 commit 94bd3b8

6 files changed

+14
-14
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-jaraco.collections
2-
URL = https://files.pythonhosted.org/packages/cb/ef/e249700b1cec81a6b1c64e876005f8c203022d388ea10b104c5eaacb9473/jaraco.collections-3.5.2.tar.gz
2+
URL = https://files.pythonhosted.org/packages/55/9b/4ebba6848d257831953354b4c9129fc28bd948204d61aea7a1d9ee13ad59/jaraco.collections-3.6.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-jaraco.collections
3-
url = https://files.pythonhosted.org/packages/cb/ef/e249700b1cec81a6b1c64e876005f8c203022d388ea10b104c5eaacb9473/jaraco.collections-3.5.2.tar.gz
3+
url = https://files.pythonhosted.org/packages/55/9b/4ebba6848d257831953354b4c9129fc28bd948204d61aea7a1d9ee13ad59/jaraco.collections-3.6.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/jaraco.collections/
66
domain =

pypi-jaraco.collections.spec

+9-9
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-jaraco.collections
6-
Version : 3.5.2
7-
Release : 31
8-
URL : https://files.pythonhosted.org/packages/cb/ef/e249700b1cec81a6b1c64e876005f8c203022d388ea10b104c5eaacb9473/jaraco.collections-3.5.2.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/cb/ef/e249700b1cec81a6b1c64e876005f8c203022d388ea10b104c5eaacb9473/jaraco.collections-3.5.2.tar.gz
6+
Version : 3.6.0
7+
Release : 32
8+
URL : https://files.pythonhosted.org/packages/55/9b/4ebba6848d257831953354b4c9129fc28bd948204d61aea7a1d9ee13ad59/jaraco.collections-3.6.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/55/9b/4ebba6848d257831953354b4c9129fc28bd948204d61aea7a1d9ee13ad59/jaraco.collections-3.6.0.tar.gz
1010
Summary : Collection objects similar to those in stdlib by jaraco
1111
Group : Development/Tools
1212
License : MIT
@@ -58,18 +58,18 @@ python3 components for the pypi-jaraco.collections package.
5858

5959

6060
%prep
61-
%setup -q -n jaraco.collections-3.5.2
62-
cd %{_builddir}/jaraco.collections-3.5.2
61+
%setup -q -n jaraco.collections-3.6.0
62+
cd %{_builddir}/jaraco.collections-3.6.0
6363
pushd ..
64-
cp -a jaraco.collections-3.5.2 buildavx2
64+
cp -a jaraco.collections-3.6.0 buildavx2
6565
popd
6666

6767
%build
6868
export http_proxy=http://127.0.0.1:9/
6969
export https_proxy=http://127.0.0.1:9/
7070
export no_proxy=localhost,127.0.0.1,0.0.0.0
7171
export LANG=C.UTF-8
72-
export SOURCE_DATE_EPOCH=1657810126
72+
export SOURCE_DATE_EPOCH=1666630309
7373
export GCC_IGNORE_WERROR=1
7474
export AR=gcc-ar
7575
export RANLIB=gcc-ranlib
@@ -94,7 +94,7 @@ popd
9494
export MAKEFLAGS=%{?_smp_mflags}
9595
rm -rf %{buildroot}
9696
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections
97-
cp %{_builddir}/jaraco.collections-3.5.2/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections/8e6689d37f82d5617b7f7f7232c94024d41066d1
97+
cp %{_builddir}/jaraco.collections-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
9898
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
9999
echo ----[ mark ]----
100100
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
31
1+
32

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
fe8c65b850d94777bfbc3c1dca065a1be86df66e/jaraco.collections-3.5.2.tar.gz
1+
5f77bd3804e34ed576f469aea12ee81420d1f1b1/jaraco.collections-3.6.0.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
3.5.2
1+
3.6.0

0 commit comments

Comments
 (0)