Skip to content

Commit a55671a

Browse files
committed
pypi-jaraco.functools: Autospec creation for update from version 3.5.2 to version 3.6.0
Jason R. Coombs (28): Update documentation of call_aside detailing the motivation and benefits of the construct. Adopt furo theme for docs. Indicate to use latest Python version (workaround for readthedocs/readthedocs.org/#9623). Requires also specifying the OS version (workaround for readthedocs/readthedocs.org#9635). GHA pretty env (#67) Pin mypy to '<0.990' due to realpython/pytest-mypy#141 Remove the hyperlink for the Python versions badge. The PyPI badge is a better anchor for the hyperlink. Apply explicit_package_bases for mypy and unpin the version. Ref python/mypy#14057. Add Python 3.12 to matrix. Only test 3.8-3.10 on Linux. Disable flake8 on Python 3.12. Workaround for tholo/pytest-flake8#87. Honor ResourceWarnings. Fixes jaraco/skeleton#73. tox 4 requires a boolean value, so use '1' to FORCE_COLOR. Fixes jaraco/skeleton#74. Remove unnecessary shebang and encoding header in docs conf. Prevent Python 3.12 from blocking checks. Build docs in CI, including sphinx-lint. Restore doctests by utilizing importlib. Ref pytest-dev/pytest#3396. Put tidelift docs dependency in its own section to limit merge conflicts. Update badge for 2023 ALLOW_UNICODE no longer needed on Python 3. As a result, ELLIPSES is also now enabled by default. Enable default encoding warning where available. See PEP 597. Suppress EncodingWarning in pytest_black. Workaround for shopkeep/pytest-black#67. Exempt warning. Workaround for realpython/pytest-mypy#152 Add #upstream markers for filtered warnings. Add filter for platform module (ref python/cpython#100750). Remove reference to EncodingWarning as it doesn't exist on some Pythons. Revert "exclude build env from cov reporting (jaraco/skeleton#60)" Disable couldnt-parse warnings. Prescribed workaround for nedbat/coveragepy#1392. Fixes python/importlib_resources#279 and fixes jaraco/skeleton#56. Renamed 'call_aside' to 'invoke'. Fixes #21. Replace 'called_with' with 'assert_called_with'. 🚡 Toil the docs. Zach Burnett (1): rename `.readthedocs.yml` to `.readthedocs.yaml` (RTD docs indicate that `.readthedocs.yml` will be deprecated) (#68)
1 parent 6aba461 commit a55671a

6 files changed

+14
-14
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-jaraco.functools
2-
URL = https://files.pythonhosted.org/packages/b4/ea/9abca360081de9157668fcc52765989158aaf29b4826f26fcb17852d08e6/jaraco.functools-3.5.2.tar.gz
2+
URL = https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-jaraco.functools
3-
url = https://files.pythonhosted.org/packages/b4/ea/9abca360081de9157668fcc52765989158aaf29b4826f26fcb17852d08e6/jaraco.functools-3.5.2.tar.gz
3+
url = https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/jaraco.functools/
66
domain =

pypi-jaraco.functools.spec

+9-9
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-jaraco.functools
6-
Version : 3.5.2
7-
Release : 50
8-
URL : https://files.pythonhosted.org/packages/b4/ea/9abca360081de9157668fcc52765989158aaf29b4826f26fcb17852d08e6/jaraco.functools-3.5.2.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/b4/ea/9abca360081de9157668fcc52765989158aaf29b4826f26fcb17852d08e6/jaraco.functools-3.5.2.tar.gz
6+
Version : 3.6.0
7+
Release : 51
8+
URL : https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
1010
Summary : Functools like those found in stdlib
1111
Group : Development/Tools
1212
License : MIT
@@ -28,7 +28,7 @@ BuildRequires : pypi-virtualenv
2828

2929
%description
3030
.. image:: https://img.shields.io/pypi/v/jaraco.functools.svg
31-
:target: `PyPI link`_
31+
:target: https://pypi.org/project/jaraco.functools
3232

3333
%package license
3434
Summary: license components for the pypi-jaraco.functools package.
@@ -59,18 +59,18 @@ python3 components for the pypi-jaraco.functools package.
5959

6060

6161
%prep
62-
%setup -q -n jaraco.functools-3.5.2
63-
cd %{_builddir}/jaraco.functools-3.5.2
62+
%setup -q -n jaraco.functools-3.6.0
63+
cd %{_builddir}/jaraco.functools-3.6.0
6464
pushd ..
65-
cp -a jaraco.functools-3.5.2 buildavx2
65+
cp -a jaraco.functools-3.6.0 buildavx2
6666
popd
6767

6868
%build
6969
export http_proxy=http://127.0.0.1:9/
7070
export https_proxy=http://127.0.0.1:9/
7171
export no_proxy=localhost,127.0.0.1,0.0.0.0
7272
export LANG=C.UTF-8
73-
export SOURCE_DATE_EPOCH=1672283392
73+
export SOURCE_DATE_EPOCH=1676920033
7474
export GCC_IGNORE_WERROR=1
7575
export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
7676
export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
50
1+
51

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
db84a399cd9d9e9bf37ee7245417cc2871922638/jaraco.functools-3.5.2.tar.gz
1+
c37c641d5b39a3b383e69191601a942ee7161e19/jaraco.functools-3.6.0.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
3.5.2
1+
3.6.0

0 commit comments

Comments
 (0)