Skip to content

Commit 76fa4c1

Browse files
committed
pypi-keyring: Autospec creation for update from version 24.3.0 to version 24.3.1
Bartosz Sławecki (1): Tweak coverage configuration for type checking (jaraco/skeleton#97) Christian Clauss (2): Upgrade GitHub Actions checkout (jaraco/skeleton#94) GitHub Actions: Combine tox jobs diffcov and docs (jaraco/skeleton#95) David Hotham (3): simplify and fix typing of priority() ruff formatting appease mypy Dimitri Papadopoulos Orfanos (2): Use the ruff formatter (jaraco/skeleton#99) ruff: extended-ignore → ignore (jaraco/skeleton#105) Jason R. Coombs (25): Move keyring_jeepney to the bottom of the list and mention limitation. Closes #646. Fix implementation of strip_last_newline and added test. Add test for do_set called_once_with is not valid Remove news fragment after allowing time to be processed downstream. Suppress deprecation warning in dateutil. Workaround for dateutil/dateutil#1284. Update Github Actions badge per actions/starter-workflows#1525. Separate collateral jobs on different lines for easier override/extension. Drop minimum requirement on pytest-mypy as most environments are already running much later. Closes jaraco/skeleton#96. Remove sole entry for branches-ignore. Workaround for and closes jaraco/skeleton#103. Bump year on badge Remove build and dist from excludes. It appears they are not needed and their presence blocks the names of packages like 'builder' and 'distutils'. Ref pypa/distutils#224. Exclude docs and tests directories properly per Setuptools behavior. Rely on default discovery for good heuristics for finding packages. Enable preview to enable preserving quotes. Use latest versions in RTD boilerplate. Registering project with tea. Correct the name of tea.yaml. 👹 Feed the hobgoblins (delint). Fix EncodingWarnings 🧎‍♀️ Genuflect to the types. Replace the type returned by priority to be a 'Number'. 🧎‍♀️ Genuflect to the types. Add news fragment. Finalize Marcel Telka (1): Remove useless shebang from cli.py Sviatoslav Sydorenko (1): Enable testing merge queues @ GitHub Actions CI/CD (jaraco/skeleton#93)
1 parent 49b4922 commit 76fa4c1

File tree

5 files changed

+28
-24
lines changed

5 files changed

+28
-24
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-keyring
2-
URL = https://files.pythonhosted.org/packages/69/cd/889c6569a7e5e9524bc1e423fd2badd967c4a5dcd670c04c2eff92a9d397/keyring-24.3.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/ae/6c/bd2cfc6c708ce7009bdb48c85bb8cad225f5638095ecc8f49f15e8e1f35e/keyring-24.3.1.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+5-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-keyring
3-
url = https://files.pythonhosted.org/packages/69/cd/889c6569a7e5e9524bc1e423fd2badd967c4a5dcd670c04c2eff92a9d397/keyring-24.3.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/ae/6c/bd2cfc6c708ce7009bdb48c85bb8cad225f5638095ecc8f49f15e8e1f35e/keyring-24.3.1.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/keyring/
66
domain =
@@ -9,6 +9,8 @@ alias =
99
[autospec]
1010
# build 32 bit libraries
1111
32bit = false
12+
# allow windows executables (*.exe, *.dll) to be packaged
13+
allow_exe = false
1214
# allow package to build with test failures
1315
allow_test_failures = true
1416
# unset %build ld_as_needed variable
@@ -59,6 +61,8 @@ server = false
5961
skip_tests = false
6062
# add .so files to the lib package instead of dev
6163
so_to_lib = false
64+
# configure build for apx
65+
use_apx = false
6266
# configure build for avx2
6367
use_avx2 = true
6468
# configure build for avx512

pypi-keyring.spec

+20-20
Original file line numberDiff line numberDiff line change
@@ -2,14 +2,14 @@
22
# This file is auto-generated. DO NOT EDIT
33
# Generated by: autospec.py
44
# Using build pattern: pyproject
5-
# autospec version: v2
6-
# autospec commit: 250a666
5+
# autospec version: v4
6+
# autospec commit: e738c51
77
#
88
Name : pypi-keyring
9-
Version : 24.3.0
10-
Release : 141
11-
URL : https://files.pythonhosted.org/packages/69/cd/889c6569a7e5e9524bc1e423fd2badd967c4a5dcd670c04c2eff92a9d397/keyring-24.3.0.tar.gz
12-
Source0 : https://files.pythonhosted.org/packages/69/cd/889c6569a7e5e9524bc1e423fd2badd967c4a5dcd670c04c2eff92a9d397/keyring-24.3.0.tar.gz
9+
Version : 24.3.1
10+
Release : 142
11+
URL : https://files.pythonhosted.org/packages/ae/6c/bd2cfc6c708ce7009bdb48c85bb8cad225f5638095ecc8f49f15e8e1f35e/keyring-24.3.1.tar.gz
12+
Source0 : https://files.pythonhosted.org/packages/ae/6c/bd2cfc6c708ce7009bdb48c85bb8cad225f5638095ecc8f49f15e8e1f35e/keyring-24.3.1.tar.gz
1313
Summary : Store and access your passwords safely.
1414
Group : Development/Tools
1515
License : MIT Python-2.0
@@ -69,18 +69,18 @@ python3 components for the pypi-keyring package.
6969

7070

7171
%prep
72-
%setup -q -n keyring-24.3.0
73-
cd %{_builddir}/keyring-24.3.0
72+
%setup -q -n keyring-24.3.1
73+
cd %{_builddir}/keyring-24.3.1
7474
pushd ..
75-
cp -a keyring-24.3.0 buildavx2
75+
cp -a keyring-24.3.1 buildavx2
7676
popd
7777

7878
%build
7979
export http_proxy=http://127.0.0.1:9/
8080
export https_proxy=http://127.0.0.1:9/
8181
export no_proxy=localhost,127.0.0.1,0.0.0.0
8282
export LANG=C.UTF-8
83-
export SOURCE_DATE_EPOCH=1699895988
83+
export SOURCE_DATE_EPOCH=1709079387
8484
export GCC_IGNORE_WERROR=1
8585
export AR=gcc-ar
8686
export RANLIB=gcc-ranlib
@@ -98,11 +98,11 @@ LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS"
9898
export MAKEFLAGS=%{?_smp_mflags}
9999
python3 -m build --wheel --skip-dependency-check --no-isolation
100100
pushd ../buildavx2/
101-
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
102-
CXXFLAGS="$CLEAR_INTERMEDIATE_CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
103-
FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
104-
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -m64 -march=x86-64-v3 "
105-
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -m64 -march=x86-64-v3 "
101+
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
102+
CXXFLAGS="$CLEAR_INTERMEDIATE_CXXFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
103+
FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
104+
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -march=x86-64-v3 "
105+
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -march=x86-64-v3 "
106106
python3 -m build --wheel --skip-dependency-check --no-isolation
107107

108108
popd
@@ -138,11 +138,11 @@ echo ----[ mark ]----
138138
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
139139
echo ----[ mark ]----
140140
pushd ../buildavx2/
141-
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
142-
CXXFLAGS="$CLEAR_INTERMEDIATE_CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
143-
FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
144-
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -m64 -march=x86-64-v3 "
145-
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -m64 -march=x86-64-v3 "
141+
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
142+
CXXFLAGS="$CLEAR_INTERMEDIATE_CXXFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
143+
FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -march=x86-64-v3 -Wl,-z,x86-64-v3 "
144+
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -march=x86-64-v3 "
145+
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -march=x86-64-v3 "
146146
python3 -m installer --destdir=%{buildroot}-v3 dist/*.whl
147147
popd
148148
/usr/bin/elf-move.py avx2 %{buildroot}-v3 %{buildroot} %{buildroot}/usr/share/clear/filemap/filemap-%{name}

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
141
1+
142

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
8b79f021fa2ed16dcfe1219b2061f8f53ebc072a/keyring-24.3.0.tar.gz
1+
855d35dc2a944029f593cb5ec72ffbcd90ec31ba/keyring-24.3.1.tar.gz

0 commit comments

Comments
 (0)