Skip to content

Commit c349edb

Browse files
committed
pypi-keyring: Autospec creation for update from version 23.13.1 to version 24.0.0
Jason R. Coombs (28): Build docs in CI, including sphinx-lint. Put tidelift docs dependency in its own section to limit merge conflicts. Update badge for 2023 ALLOW_UNICODE no longer needed on Python 3. As a result, ELLIPSES is also now enabled by default. Enable default encoding warning where available. See PEP 597. Suppress EncodingWarning in pytest_black. Workaround for shopkeep/pytest-black#67. Exempt warning. Workaround for realpython/pytest-mypy#152 Add #upstream markers for filtered warnings. Add filter for platform module (ref python/cpython#100750). Remove reference to EncodingWarning as it doesn't exist on some Pythons. Warn if the keychain property is set. Fixes #623. Removed OS_X module. Ref #487. Removed deprecated keyring.util.properties module. Revert "exclude build env from cov reporting (jaraco/skeleton#60)" Disable couldnt-parse warnings. Prescribed workaround for nedbat/coveragepy#1392. Fixes python/importlib_resources#279 and fixes jaraco/skeleton#56. Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. ⚫ Fade to black. ⚫ Fade to black. Make substitution fields more prominent and distinct from true 'skeleton' references. (#71) Suppress EncodingWarning in build.env. Ref pypa/build#615. Remove reference to EncodingWarning as it doesn't exist on some Pythons. Update RTD boilerplate to new issue. Ref readthedocs/readthedocs.org#10401. Add badge for Ruff. Remove inclusion of python version for docs Update platform_ to return pathlib objects. Extract function for _config_path. Add diagnose command. Fixes #633. Mark multiprocess tests as xfail for now. Ref #634. Update changelog. Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76) Philipp Hörist (4): docs: Remove trailing whitespace Add type annotations for core.py Add type annotations for backend.py Make defining priority property more consistent wzy (1): Fix a typo of README.rst
1 parent b418ccb commit c349edb

File tree

5 files changed

+22
-22
lines changed

5 files changed

+22
-22
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-keyring
2-
URL = https://files.pythonhosted.org/packages/55/fe/282f4c205add8e8bb3a1635cbbac59d6def2e0891b145aa553a0e40dd2d0/keyring-23.13.1.tar.gz
2+
URL = https://files.pythonhosted.org/packages/31/42/f29907a72907df16326fa425cfd3a144f00d9a613063467f8b58d2ac58a5/keyring-24.0.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+4-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-keyring
3-
url = https://files.pythonhosted.org/packages/55/fe/282f4c205add8e8bb3a1635cbbac59d6def2e0891b145aa553a0e40dd2d0/keyring-23.13.1.tar.gz
3+
url = https://files.pythonhosted.org/packages/31/42/f29907a72907df16326fa425cfd3a144f00d9a613063467f8b58d2ac58a5/keyring-24.0.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/keyring/
66
domain =
@@ -19,6 +19,8 @@ autoupdate = true
1919
broken_c++ = false
2020
# disable parallelization during build
2121
broken_parallel_build = false
22+
# create vendor archive with cargo
23+
cargo_vendor = false
2224
# this package is a library compatibility package and only ships versioned library files
2325
compat = false
2426
# set conservative build flags
@@ -58,7 +60,7 @@ skip_tests = false
5860
# add .so files to the lib package instead of dev
5961
so_to_lib = false
6062
# configure build for avx2
61-
use_avx2 = false
63+
use_avx2 = true
6264
# configure build for avx512
6365
use_avx512 = false
6466
# add clang flags

pypi-keyring.spec

+15-17
Original file line numberDiff line numberDiff line change
@@ -1,12 +1,13 @@
11
#
22
# This file is auto-generated. DO NOT EDIT
33
# Generated by: autospec.py
4+
# Using build pattern: pyproject
45
#
56
Name : pypi-keyring
6-
Version : 23.13.1
7-
Release : 134
8-
URL : https://files.pythonhosted.org/packages/55/fe/282f4c205add8e8bb3a1635cbbac59d6def2e0891b145aa553a0e40dd2d0/keyring-23.13.1.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/55/fe/282f4c205add8e8bb3a1635cbbac59d6def2e0891b145aa553a0e40dd2d0/keyring-23.13.1.tar.gz
7+
Version : 24.0.0
8+
Release : 135
9+
URL : https://files.pythonhosted.org/packages/31/42/f29907a72907df16326fa425cfd3a144f00d9a613063467f8b58d2ac58a5/keyring-24.0.0.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/31/42/f29907a72907df16326fa425cfd3a144f00d9a613063467f8b58d2ac58a5/keyring-24.0.0.tar.gz
1011
Summary : Store and access your passwords safely.
1112
Group : Development/Tools
1213
License : MIT Python-2.0
@@ -16,9 +17,6 @@ Requires: pypi-keyring-python = %{version}-%{release}
1617
Requires: pypi-keyring-python3 = %{version}-%{release}
1718
Requires: pypi(secretstorage)
1819
BuildRequires : buildreq-distutils3
19-
BuildRequires : pypi(jaraco.classes)
20-
BuildRequires : pypi(jeepney)
21-
BuildRequires : pypi(secretstorage)
2220
BuildRequires : pypi(setuptools)
2321
BuildRequires : pypi(setuptools_scm)
2422
# Suppress stripping binaries
@@ -70,26 +68,26 @@ python3 components for the pypi-keyring package.
7068

7169

7270
%prep
73-
%setup -q -n keyring-23.13.1
74-
cd %{_builddir}/keyring-23.13.1
71+
%setup -q -n keyring-24.0.0
72+
cd %{_builddir}/keyring-24.0.0
7573
pushd ..
76-
cp -a keyring-23.13.1 buildavx2
74+
cp -a keyring-24.0.0 buildavx2
7775
popd
7876

7977
%build
8078
export http_proxy=http://127.0.0.1:9/
8179
export https_proxy=http://127.0.0.1:9/
8280
export no_proxy=localhost,127.0.0.1,0.0.0.0
8381
export LANG=C.UTF-8
84-
export SOURCE_DATE_EPOCH=1672286493
82+
export SOURCE_DATE_EPOCH=1687273280
8583
export GCC_IGNORE_WERROR=1
8684
export AR=gcc-ar
8785
export RANLIB=gcc-ranlib
8886
export NM=gcc-nm
89-
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
90-
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
91-
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
92-
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
87+
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
88+
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
89+
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
90+
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
9391
export MAKEFLAGS=%{?_smp_mflags}
9492
python3 -m build --wheel --skip-dependency-check --no-isolation
9593
pushd ../buildavx2/
@@ -113,7 +111,7 @@ python setup.py ptr || :
113111
export MAKEFLAGS=%{?_smp_mflags}
114112
rm -rf %{buildroot}
115113
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-keyring
116-
cp %{_builddir}/keyring-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
114+
cp %{_builddir}/keyring-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-keyring/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
117115
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
118116
echo ----[ mark ]----
119117
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -137,7 +135,7 @@ popd
137135

138136
%files license
139137
%defattr(0644,root,root,0755)
140-
/usr/share/package-licenses/pypi-keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
138+
/usr/share/package-licenses/pypi-keyring/0445ed0f69910eeaee036f09a39a13c6e1f37e12
141139

142140
%files python
143141
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
134
1+
135

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
d26055ab21fe4c6dbc468bd6d268b840c446bacb/keyring-23.13.1.tar.gz
1+
9e03805d443885246376dd0851bdef80d04a8c37/keyring-24.0.0.tar.gz

0 commit comments

Comments
 (0)