Skip to content

Commit 5302ba3

Browse files
committed
pypi-portend: Autospec creation for update from version 3.1.0 to version 3.2.0
Anderson Bravalheri (2): Ignore flake8/black warnings with pytest 7.0.1 (jaraco/skeleton#58) Update Github actions to v3 (#62) Hugo van Kemenade (1): Update base URL for PEPs (#61) Jason R. Coombs (56): Remove filtered warnings, addressed upstream. Update badge year Remove setup.py, no longer needed. Add exclusions for pytest 7 deprecations in plugins. Fixes jaraco/skeleton#57. Use the parent category PytestDeprecationWarning, which is available on older pytest versions. Fixes jaraco/skeleton#57. Bump pytest-mypy and remove workaround for realpython/pytest-mypy#131. Require jaraco.packaging 9 adding compatibility for projects with no setup.py file. Ran pre-commit autoupdate Add Python 3.11 into the matrix using workaround from actions/setup-python#213. Drop 3.9 from matrix for efficiency. Prefer spaces for rst. Fixes jaraco/skeleton#64. Honor PEP 518 with pytest-enabler. Ran pre-commit autoupdate Use '-dev' for every Python version. Ref actions/setup-python#213. Use Python 3.11 for cutting releases. Pin flake8. Workaround for tholo/pytest-flake8#87. Update to setup-python v4. Fixes jaraco/skeleton#65. Also update release to v4 Add PyPy to the test matrix on Linux. Fixes jaraco/skeleton#63. When rendering docs, preserve the syntax for defaults. Fixes jaraco/path#197. Adopt furo theme for docs. Indicate to use latest Python version (workaround for readthedocs/readthedocs.org/#9623). Requires also specifying the OS version (workaround for readthedocs/readthedocs.org#9635). GHA pretty env (#67) Pin mypy to '<0.990' due to realpython/pytest-mypy#141 Remove the hyperlink for the Python versions badge. The PyPI badge is a better anchor for the hyperlink. Apply explicit_package_bases for mypy and unpin the version. Ref python/mypy#14057. Add Python 3.12 to matrix. Only test 3.8-3.10 on Linux. Disable flake8 on Python 3.12. Workaround for tholo/pytest-flake8#87. Honor ResourceWarnings. Fixes jaraco/skeleton#73. tox 4 requires a boolean value, so use '1' to FORCE_COLOR. Fixes jaraco/skeleton#74. Remove unnecessary shebang and encoding header in docs conf. Prevent Python 3.12 from blocking checks. Build docs in CI, including sphinx-lint. Update badge for 2023 ALLOW_UNICODE no longer needed on Python 3. As a result, ELLIPSES is also now enabled by default. Enable default encoding warning where available. See PEP 597. Suppress EncodingWarning in pytest_black. Workaround for shopkeep/pytest-black#67. Exempt warning. Workaround for realpython/pytest-mypy#152 Add #upstream markers for filtered warnings. Add filter for platform module (ref python/cpython#100750). Remove reference to EncodingWarning as it doesn't exist on some Pythons. Revert "exclude build env from cov reporting (jaraco/skeleton#60)" Disable couldnt-parse warnings. Prescribed workaround for nedbat/coveragepy#1392. Fixes python/importlib_resources#279 and fixes jaraco/skeleton#56. Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. Make substitution fields more prominent and distinct from true 'skeleton' references. (#71) Suppress EncodingWarning in build.env. Ref pypa/build#615. Remove reference to EncodingWarning as it doesn't exist on some Pythons. Update RTD boilerplate to new issue. Ref readthedocs/readthedocs.org#10401. Add badge for Ruff. Remove inclusion of python version for docs Adopt towncrier for managing changelog. Fixes jaraco/skeleton#83. Replace workaround for actions/setup-python#508 with 'allow-prereleases' Remove tox boilerplate, no longer necessary with later versions of tox. Require Python 3.8 or later. Expand 'finalize' to commit and tag the change. Leverage pytest-enabler 2.2 for the default config. Finalize Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76) Sviatoslav Sydorenko (1): Inject check job into CI workflow as ultimate flag (#55) Zach Burnett (1): rename `.readthedocs.yml` to `.readthedocs.yaml` (RTD docs indicate that `.readthedocs.yml` will be deprecated) (#68) wim glenn (1): exclude build env from cov reporting (#60)
1 parent 3c6e8b1 commit 5302ba3

File tree

5 files changed

+32
-25
lines changed

5 files changed

+32
-25
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-portend
2-
URL = https://files.pythonhosted.org/packages/6e/0a/42bcc9c97744958ce72d33f526e972379b9e90adede8a151f338818c41d4/portend-3.1.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/8f/fc/bcfc768996b438d6e4bde7a6c8cfd62089847b0f5381a0e0ec2d8ee6b202/portend-3.2.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+8-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-portend
3-
url = https://files.pythonhosted.org/packages/6e/0a/42bcc9c97744958ce72d33f526e972379b9e90adede8a151f338818c41d4/portend-3.1.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/8f/fc/bcfc768996b438d6e4bde7a6c8cfd62089847b0f5381a0e0ec2d8ee6b202/portend-3.2.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/portend.git
66
domain =
@@ -19,6 +19,8 @@ autoupdate = true
1919
broken_c++ = false
2020
# disable parallelization during build
2121
broken_parallel_build = false
22+
# create vendor archive with cargo
23+
cargo_vendor = false
2224
# this package is a library compatibility package and only ships versioned library files
2325
compat = false
2426
# set conservative build flags
@@ -27,6 +29,8 @@ conservative_flags = false
2729
dev_requires_extras = false
2830
# pass -ffast-math to compiler
2931
fast-math = false
32+
# compile full (traditional) debug info
33+
full-debug-info = false
3034
# optimize build for speed over size
3135
funroll-loops = false
3236
# set flags to smallest -02 flags possible
@@ -35,6 +39,8 @@ insecure_build = false
3539
keepstatic = false
3640
# do not require autostart subpackage
3741
no_autostart = false
42+
# do not use the replacement pattern for file matching
43+
no_glob = false
3844
# do not generate debuginfo for this package
3945
nodebug = false
4046
# disable stripping binaries
@@ -54,7 +60,7 @@ skip_tests = false
5460
# add .so files to the lib package instead of dev
5561
so_to_lib = false
5662
# configure build for avx2
57-
use_avx2 = false
63+
use_avx2 = true
5864
# configure build for avx512
5965
use_avx512 = false
6066
# add clang flags

pypi-portend.spec

+21-20
Original file line numberDiff line numberDiff line change
@@ -1,12 +1,13 @@
11
#
22
# This file is auto-generated. DO NOT EDIT
33
# Generated by: autospec.py
4+
# Using build pattern: pyproject
45
#
56
Name : pypi-portend
6-
Version : 3.1.0
7-
Release : 49
8-
URL : https://files.pythonhosted.org/packages/6e/0a/42bcc9c97744958ce72d33f526e972379b9e90adede8a151f338818c41d4/portend-3.1.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/6e/0a/42bcc9c97744958ce72d33f526e972379b9e90adede8a151f338818c41d4/portend-3.1.0.tar.gz
7+
Version : 3.2.0
8+
Release : 50
9+
URL : https://files.pythonhosted.org/packages/8f/fc/bcfc768996b438d6e4bde7a6c8cfd62089847b0f5381a0e0ec2d8ee6b202/portend-3.2.0.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/8f/fc/bcfc768996b438d6e4bde7a6c8cfd62089847b0f5381a0e0ec2d8ee6b202/portend-3.2.0.tar.gz
1011
Summary : TCP port monitoring and discovery
1112
Group : Development/Tools
1213
License : MIT
@@ -17,17 +18,17 @@ BuildRequires : buildreq-distutils3
1718
BuildRequires : pypi(py)
1819
BuildRequires : pypi(setuptools)
1920
BuildRequires : pypi(setuptools_scm)
20-
BuildRequires : pypi(tempora)
2121
BuildRequires : pypi-pluggy
2222
BuildRequires : pypi-pytest
2323
BuildRequires : pypi-tox
2424
BuildRequires : pypi-virtualenv
25+
# Suppress stripping binaries
26+
%define __strip /bin/true
27+
%define debug_package %{nil}
2528

2629
%description
2730
.. image:: https://img.shields.io/pypi/v/portend.svg
28-
:target: `PyPI link`_
29-
.. image:: https://img.shields.io/pypi/pyversions/portend.svg
30-
:target: `PyPI link`_
31+
:target: https://pypi.org/project/portend
3132

3233
%package license
3334
Summary: license components for the pypi-portend package.
@@ -58,28 +59,28 @@ python3 components for the pypi-portend package.
5859

5960

6061
%prep
61-
%setup -q -n portend-3.1.0
62-
cd %{_builddir}/portend-3.1.0
62+
%setup -q -n portend-3.2.0
63+
cd %{_builddir}/portend-3.2.0
6364
pushd ..
64-
cp -a portend-3.1.0 buildavx2
65+
cp -a portend-3.2.0 buildavx2
6566
popd
6667

6768
%build
6869
export http_proxy=http://127.0.0.1:9/
6970
export https_proxy=http://127.0.0.1:9/
7071
export no_proxy=localhost,127.0.0.1,0.0.0.0
7172
export LANG=C.UTF-8
72-
export SOURCE_DATE_EPOCH=1656395089
73+
export SOURCE_DATE_EPOCH=1687966867
7374
export GCC_IGNORE_WERROR=1
74-
export CFLAGS="$CFLAGS -fno-lto "
75-
export FCFLAGS="$FFLAGS -fno-lto "
76-
export FFLAGS="$FFLAGS -fno-lto "
77-
export CXXFLAGS="$CXXFLAGS -fno-lto "
75+
export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
76+
export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
77+
export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
78+
export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
7879
export MAKEFLAGS=%{?_smp_mflags}
7980
python3 -m build --wheel --skip-dependency-check --no-isolation
8081
pushd ../buildavx2/
81-
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx"
82-
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx "
82+
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
83+
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
8384
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
8485
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
8586
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
@@ -91,7 +92,7 @@ popd
9192
export MAKEFLAGS=%{?_smp_mflags}
9293
rm -rf %{buildroot}
9394
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-portend
94-
cp %{_builddir}/portend-3.1.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-portend/8e6689d37f82d5617b7f7f7232c94024d41066d1
95+
cp %{_builddir}/portend-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-portend/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
9596
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
9697
echo ----[ mark ]----
9798
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -111,7 +112,7 @@ popd
111112

112113
%files license
113114
%defattr(0644,root,root,0755)
114-
/usr/share/package-licenses/pypi-portend/8e6689d37f82d5617b7f7f7232c94024d41066d1
115+
/usr/share/package-licenses/pypi-portend/0445ed0f69910eeaee036f09a39a13c6e1f37e12
115116

116117
%files python
117118
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
49
1+
50

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
81cfdabc8448fc227b8eacfc74e9f8e0635eae11/portend-3.1.0.tar.gz
1+
a6d8f4ef4ee08ca85dde5e21a23912330c63c5b1/portend-3.2.0.tar.gz

0 commit comments

Comments
 (0)