Skip to content

Commit 765c101

Browse files
committed
pypi-setuptools: Autospec creation for update from version 67.7.2 to version 67.8.0
Anderson Bravalheri (3): Adequate venv fixtures to the latest change in virtualenv Add news fragment Attempt to use a valid PEP 440 version fallback Bo Bayles (1): Fix typo in docs Gregory Starck (7): Fix: reload and merge easy-install pth file before save Rework test_many_pth_distributions_merge_together Add better comments Check in memory before disk + force clean rewrite Flake8 pass Final comments Better comments again Jason R. Coombs (11): Fix linter error Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. Disable ruff on cygwin where rust compiler isn't available. Ref pypa/setuptools#3921. ⚫ Fade to black. 👹 Feed the hobgoblins (delint). Add changelog 👹 Feed the hobgoblins (delint). 👹 Feed the hobgoblins (delint). 👹 Feed the hobgoblins (delint). Bump version: 67.7.2 → 67.8.0 Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76)
1 parent e37e81e commit 765c101

File tree

5 files changed

+19
-19
lines changed

5 files changed

+19
-19
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-setuptools
2-
URL = https://files.pythonhosted.org/packages/fd/53/e5d7ae40d03e4ed20b7cba317cf9c0c97097c8debb39f9d72d182a6578a2/setuptools-67.7.2.tar.gz
2+
URL = https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-setuptools
3-
url = https://files.pythonhosted.org/packages/fd/53/e5d7ae40d03e4ed20b7cba317cf9c0c97097c8debb39f9d72d182a6578a2/setuptools-67.7.2.tar.gz
3+
url = https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz
44
archives =
55
giturl = https://github.com/pypa/setuptools.git
66
domain =
@@ -60,7 +60,7 @@ skip_tests = true
6060
# add .so files to the lib package instead of dev
6161
so_to_lib = false
6262
# configure build for avx2
63-
use_avx2 = false
63+
use_avx2 = true
6464
# configure build for avx512
6565
use_avx512 = false
6666
# add clang flags

pypi-setuptools.spec

+14-14
Original file line numberDiff line numberDiff line change
@@ -4,10 +4,10 @@
44
# Using build pattern: distutils3
55
#
66
Name : pypi-setuptools
7-
Version : 67.7.2
8-
Release : 301
9-
URL : https://files.pythonhosted.org/packages/fd/53/e5d7ae40d03e4ed20b7cba317cf9c0c97097c8debb39f9d72d182a6578a2/setuptools-67.7.2.tar.gz
10-
Source0 : https://files.pythonhosted.org/packages/fd/53/e5d7ae40d03e4ed20b7cba317cf9c0c97097c8debb39f9d72d182a6578a2/setuptools-67.7.2.tar.gz
7+
Version : 67.8.0
8+
Release : 302
9+
URL : https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz
1111
Summary : Easily download, build, install, upgrade, and uninstall Python packages
1212
Group : Development/Tools
1313
License : MIT Python-2.0 ZPL-2.0
@@ -61,26 +61,26 @@ python3 components for the pypi-setuptools package.
6161

6262

6363
%prep
64-
%setup -q -n setuptools-67.7.2
65-
cd %{_builddir}/setuptools-67.7.2
64+
%setup -q -n setuptools-67.8.0
65+
cd %{_builddir}/setuptools-67.8.0
6666
pushd ..
67-
cp -a setuptools-67.7.2 buildavx2
67+
cp -a setuptools-67.8.0 buildavx2
6868
popd
6969

7070
%build
7171
export http_proxy=http://127.0.0.1:9/
7272
export https_proxy=http://127.0.0.1:9/
7373
export no_proxy=localhost,127.0.0.1,0.0.0.0
7474
export LANG=C.UTF-8
75-
export SOURCE_DATE_EPOCH=1682351243
75+
export SOURCE_DATE_EPOCH=1684611878
7676
export GCC_IGNORE_WERROR=1
7777
export AR=gcc-ar
7878
export RANLIB=gcc-ranlib
7979
export NM=gcc-nm
80-
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
81-
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
82-
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
83-
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
80+
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
81+
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
82+
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
83+
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8484
export MAKEFLAGS=%{?_smp_mflags}
8585
python3 setup.py build
8686

@@ -97,7 +97,7 @@ popd
9797
export MAKEFLAGS=%{?_smp_mflags}
9898
rm -rf %{buildroot}
9999
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-setuptools
100-
cp %{_builddir}/setuptools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
100+
cp %{_builddir}/setuptools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
101101
python3 -tt setup.py build install --root=%{buildroot}
102102
echo ----[ mark ]----
103103
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -126,7 +126,7 @@ chmod 755 %{buildroot}/usr/bin/easy_install_is_deprecated
126126

127127
%files license
128128
%defattr(0644,root,root,0755)
129-
/usr/share/package-licenses/pypi-setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1
129+
/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12
130130

131131
%files python
132132
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
301
1+
302

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
caa89a603674611c904288ac13ef7f9592969881/setuptools-67.7.2.tar.gz
1+
04950ca6fa24599bd996fdbfb8d0a869d74cc8da/setuptools-67.8.0.tar.gz

0 commit comments

Comments
 (0)