|
4 | 4 | # Using build pattern: distutils3
|
5 | 5 | #
|
6 | 6 | Name : pypi-setuptools
|
7 |
| -Version : 67.7.2 |
8 |
| -Release : 301 |
9 |
| -URL : https://files.pythonhosted.org/packages/fd/53/e5d7ae40d03e4ed20b7cba317cf9c0c97097c8debb39f9d72d182a6578a2/setuptools-67.7.2.tar.gz |
10 |
| -Source0 : https://files.pythonhosted.org/packages/fd/53/e5d7ae40d03e4ed20b7cba317cf9c0c97097c8debb39f9d72d182a6578a2/setuptools-67.7.2.tar.gz |
| 7 | +Version : 67.8.0 |
| 8 | +Release : 302 |
| 9 | +URL : https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz |
| 10 | +Source0 : https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz |
11 | 11 | Summary : Easily download, build, install, upgrade, and uninstall Python packages
|
12 | 12 | Group : Development/Tools
|
13 | 13 | License : MIT Python-2.0 ZPL-2.0
|
@@ -61,26 +61,26 @@ python3 components for the pypi-setuptools package.
|
61 | 61 |
|
62 | 62 |
|
63 | 63 | %prep
|
64 |
| -%setup -q -n setuptools-67.7.2 |
65 |
| -cd %{_builddir}/setuptools-67.7.2 |
| 64 | +%setup -q -n setuptools-67.8.0 |
| 65 | +cd %{_builddir}/setuptools-67.8.0 |
66 | 66 | pushd ..
|
67 |
| -cp -a setuptools-67.7.2 buildavx2 |
| 67 | +cp -a setuptools-67.8.0 buildavx2 |
68 | 68 | popd
|
69 | 69 |
|
70 | 70 | %build
|
71 | 71 | export http_proxy=http://127.0.0.1:9/
|
72 | 72 | export https_proxy=http://127.0.0.1:9/
|
73 | 73 | export no_proxy=localhost,127.0.0.1,0.0.0.0
|
74 | 74 | export LANG=C.UTF-8
|
75 |
| -export SOURCE_DATE_EPOCH=1682351243 |
| 75 | +export SOURCE_DATE_EPOCH=1684611878 |
76 | 76 | export GCC_IGNORE_WERROR=1
|
77 | 77 | export AR=gcc-ar
|
78 | 78 | export RANLIB=gcc-ranlib
|
79 | 79 | export NM=gcc-nm
|
80 |
| -export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
81 |
| -export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
82 |
| -export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
83 |
| -export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
| 80 | +export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 81 | +export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 82 | +export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 83 | +export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
84 | 84 | export MAKEFLAGS=%{?_smp_mflags}
|
85 | 85 | python3 setup.py build
|
86 | 86 |
|
|
97 | 97 | export MAKEFLAGS=%{?_smp_mflags}
|
98 | 98 | rm -rf %{buildroot}
|
99 | 99 | mkdir -p %{buildroot}/usr/share/package-licenses/pypi-setuptools
|
100 |
| -cp %{_builddir}/setuptools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1 || : |
| 100 | +cp %{_builddir}/setuptools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || : |
101 | 101 | python3 -tt setup.py build install --root=%{buildroot}
|
102 | 102 | echo ----[ mark ]----
|
103 | 103 | cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
|
@@ -126,7 +126,7 @@ chmod 755 %{buildroot}/usr/bin/easy_install_is_deprecated
|
126 | 126 |
|
127 | 127 | %files license
|
128 | 128 | %defattr(0644,root,root,0755)
|
129 |
| -/usr/share/package-licenses/pypi-setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1 |
| 129 | +/usr/share/package-licenses/pypi-setuptools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 |
130 | 130 |
|
131 | 131 | %files python
|
132 | 132 | %defattr(-,root,root,-)
|
|
0 commit comments