Skip to content

Commit 3e0d119

Browse files
committed
pypi-tempora: Autospec creation for update from version 5.2.2 to version 5.3.0
Jason R. Coombs (7): Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. Replace abandoned pytest-freezegun with pytest-freezer. Make substitution fields more prominent and distinct from true 'skeleton' references. (#71) Suppress EncodingWarning in build.env. Ref pypa/build#615. Remove reference to EncodingWarning as it doesn't exist on some Pythons. Update changelog. Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76) Ville Skyttä (3): Avoid use of `datetime.utc*` deprecated in Python 3.12 Use aware datetimes in `StopWatch` start and end times Fix scheduler test, regression in f9b920b6e8d5d11bc586c6ef492ccb50574c2575
1 parent 7cfdea2 commit 3e0d119

File tree

5 files changed

+21
-19
lines changed

5 files changed

+21
-19
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-tempora
2-
URL = https://files.pythonhosted.org/packages/1c/32/963e37d9ad64582b822b8bf3288ac135ede936e5c8fe1c71da74164f0974/tempora-5.2.2.tar.gz
2+
URL = https://files.pythonhosted.org/packages/24/9e/fe5328123e2d416b39c5e790165074123c54e34e82aecca33473711dd439/tempora-5.3.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-tempora
3-
url = https://files.pythonhosted.org/packages/1c/32/963e37d9ad64582b822b8bf3288ac135ede936e5c8fe1c71da74164f0974/tempora-5.2.2.tar.gz
3+
url = https://files.pythonhosted.org/packages/24/9e/fe5328123e2d416b39c5e790165074123c54e34e82aecca33473711dd439/tempora-5.3.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/tempora.git
66
domain =
@@ -60,7 +60,7 @@ skip_tests = false
6060
# add .so files to the lib package instead of dev
6161
so_to_lib = false
6262
# configure build for avx2
63-
use_avx2 = false
63+
use_avx2 = true
6464
# configure build for avx512
6565
use_avx512 = false
6666
# add clang flags

pypi-tempora.spec

+16-14
Original file line numberDiff line numberDiff line change
@@ -4,10 +4,10 @@
44
# Using build pattern: pyproject
55
#
66
Name : pypi-tempora
7-
Version : 5.2.2
8-
Release : 59
9-
URL : https://files.pythonhosted.org/packages/1c/32/963e37d9ad64582b822b8bf3288ac135ede936e5c8fe1c71da74164f0974/tempora-5.2.2.tar.gz
10-
Source0 : https://files.pythonhosted.org/packages/1c/32/963e37d9ad64582b822b8bf3288ac135ede936e5c8fe1c71da74164f0974/tempora-5.2.2.tar.gz
7+
Version : 5.3.0
8+
Release : 60
9+
URL : https://files.pythonhosted.org/packages/24/9e/fe5328123e2d416b39c5e790165074123c54e34e82aecca33473711dd439/tempora-5.3.0.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/24/9e/fe5328123e2d416b39c5e790165074123c54e34e82aecca33473711dd439/tempora-5.3.0.tar.gz
1111
Summary : Objects and routines pertaining to date and time (tempora)
1212
Group : Development/Tools
1313
License : MIT
@@ -18,6 +18,8 @@ Requires: pypi-tempora-python3 = %{version}-%{release}
1818
Requires: pypi(jaraco.functools)
1919
BuildRequires : buildreq-distutils3
2020
BuildRequires : pypi(py)
21+
BuildRequires : pypi(setuptools)
22+
BuildRequires : pypi(setuptools_scm)
2123
BuildRequires : pypi-pluggy
2224
BuildRequires : pypi-pytest
2325
BuildRequires : pypi-tox
@@ -69,23 +71,23 @@ python3 components for the pypi-tempora package.
6971

7072

7173
%prep
72-
%setup -q -n tempora-5.2.2
73-
cd %{_builddir}/tempora-5.2.2
74+
%setup -q -n tempora-5.3.0
75+
cd %{_builddir}/tempora-5.3.0
7476
pushd ..
75-
cp -a tempora-5.2.2 buildavx2
77+
cp -a tempora-5.3.0 buildavx2
7678
popd
7779

7880
%build
7981
export http_proxy=http://127.0.0.1:9/
8082
export https_proxy=http://127.0.0.1:9/
8183
export no_proxy=localhost,127.0.0.1,0.0.0.0
8284
export LANG=C.UTF-8
83-
export SOURCE_DATE_EPOCH=1681145643
85+
export SOURCE_DATE_EPOCH=1686585592
8486
export GCC_IGNORE_WERROR=1
85-
export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
86-
export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
87-
export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
88-
export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
87+
export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
88+
export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
89+
export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
90+
export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8991
export MAKEFLAGS=%{?_smp_mflags}
9092
python3 -m build --wheel --skip-dependency-check --no-isolation
9193
pushd ../buildavx2/
@@ -102,7 +104,7 @@ popd
102104
export MAKEFLAGS=%{?_smp_mflags}
103105
rm -rf %{buildroot}
104106
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-tempora
105-
cp %{_builddir}/tempora-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-tempora/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
107+
cp %{_builddir}/tempora-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-tempora/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
106108
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
107109
echo ----[ mark ]----
108110
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -126,7 +128,7 @@ popd
126128

127129
%files license
128130
%defattr(0644,root,root,0755)
129-
/usr/share/package-licenses/pypi-tempora/8e6689d37f82d5617b7f7f7232c94024d41066d1
131+
/usr/share/package-licenses/pypi-tempora/0445ed0f69910eeaee036f09a39a13c6e1f37e12
130132

131133
%files python
132134
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
59
1+
60

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
7d19165eb2b947100e2fa6d648a9540b757055f0/tempora-5.2.2.tar.gz
1+
163c1a57c0a29105f2486a85a95dfd1cc5ca505b/tempora-5.3.0.tar.gz

0 commit comments

Comments
 (0)