|
1 | 1 | #
|
2 | 2 | # This file is auto-generated. DO NOT EDIT
|
3 | 3 | # Generated by: autospec.py
|
| 4 | +# Using build pattern: pyproject |
4 | 5 | #
|
5 | 6 | Name : pypi-zipp
|
6 |
| -Version : 3.15.0 |
7 |
| -Release : 61 |
8 |
| -URL : https://files.pythonhosted.org/packages/00/27/f0ac6b846684cecce1ee93d32450c45ab607f65c2e0255f0092032d91f07/zipp-3.15.0.tar.gz |
9 |
| -Source0 : https://files.pythonhosted.org/packages/00/27/f0ac6b846684cecce1ee93d32450c45ab607f65c2e0255f0092032d91f07/zipp-3.15.0.tar.gz |
| 7 | +Version : 3.16.0 |
| 8 | +Release : 62 |
| 9 | +URL : https://files.pythonhosted.org/packages/52/9a/d93b483b9a744e7f71b311ee9bb5a228f6846219ceb5d6dbcb3eddcd1932/zipp-3.16.0.tar.gz |
| 10 | +Source0 : https://files.pythonhosted.org/packages/52/9a/d93b483b9a744e7f71b311ee9bb5a228f6846219ceb5d6dbcb3eddcd1932/zipp-3.16.0.tar.gz |
10 | 11 | Summary : Backport of pathlib-compatible object wrapper for zip files
|
11 | 12 | Group : Development/Tools
|
12 | 13 | License : MIT
|
@@ -57,26 +58,26 @@ python3 components for the pypi-zipp package.
|
57 | 58 |
|
58 | 59 |
|
59 | 60 | %prep
|
60 |
| -%setup -q -n zipp-3.15.0 |
61 |
| -cd %{_builddir}/zipp-3.15.0 |
| 61 | +%setup -q -n zipp-3.16.0 |
| 62 | +cd %{_builddir}/zipp-3.16.0 |
62 | 63 | pushd ..
|
63 |
| -cp -a zipp-3.15.0 buildavx2 |
| 64 | +cp -a zipp-3.16.0 buildavx2 |
64 | 65 | popd
|
65 | 66 |
|
66 | 67 | %build
|
67 | 68 | export http_proxy=http://127.0.0.1:9/
|
68 | 69 | export https_proxy=http://127.0.0.1:9/
|
69 | 70 | export no_proxy=localhost,127.0.0.1,0.0.0.0
|
70 | 71 | export LANG=C.UTF-8
|
71 |
| -export SOURCE_DATE_EPOCH=1677369774 |
| 72 | +export SOURCE_DATE_EPOCH=1689006663 |
72 | 73 | export GCC_IGNORE_WERROR=1
|
73 | 74 | export AR=gcc-ar
|
74 | 75 | export RANLIB=gcc-ranlib
|
75 | 76 | export NM=gcc-nm
|
76 |
| -export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
77 |
| -export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
78 |
| -export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
79 |
| -export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
| 77 | +export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 78 | +export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 79 | +export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 80 | +export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
80 | 81 | export MAKEFLAGS=%{?_smp_mflags}
|
81 | 82 | python3 -m build --wheel --skip-dependency-check --no-isolation
|
82 | 83 | pushd ../buildavx2/
|
|
93 | 94 | export MAKEFLAGS=%{?_smp_mflags}
|
94 | 95 | rm -rf %{buildroot}
|
95 | 96 | mkdir -p %{buildroot}/usr/share/package-licenses/pypi-zipp
|
96 |
| -cp %{_builddir}/zipp-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-zipp/8e6689d37f82d5617b7f7f7232c94024d41066d1 || : |
| 97 | +cp %{_builddir}/zipp-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-zipp/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || : |
97 | 98 | pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
|
98 | 99 | echo ----[ mark ]----
|
99 | 100 | cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
|
|
113 | 114 |
|
114 | 115 | %files license
|
115 | 116 | %defattr(0644,root,root,0755)
|
116 |
| -/usr/share/package-licenses/pypi-zipp/8e6689d37f82d5617b7f7f7232c94024d41066d1 |
| 117 | +/usr/share/package-licenses/pypi-zipp/0445ed0f69910eeaee036f09a39a13c6e1f37e12 |
117 | 118 |
|
118 | 119 | %files python
|
119 | 120 | %defattr(-,root,root,-)
|
|
0 commit comments