Skip to content

Commit 26e4654

Browse files
committed
pypi-zipp: Autospec creation for update from version 3.15.0 to version 3.16.0
Jason R. Coombs (22): zipp 3.15 is now in Python 3.12. Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. Make substitution fields more prominent and distinct from true 'skeleton' references. (#71) Suppress EncodingWarning in build.env. Ref pypa/build#615. Remove reference to EncodingWarning as it doesn't exist on some Pythons. Update RTD boilerplate to new issue. Ref readthedocs/readthedocs.org#10401. Add badge for Ruff. Remove inclusion of python version for docs Adopt towncrier for managing changelog. Fixes jaraco/skeleton#83. Replace workaround for actions/setup-python#508 with 'allow-prereleases' Remove tox boilerplate, no longer necessary with later versions of tox. Require Python 3.8 or later. Expand 'finalize' to commit and tag the change. Leverage pytest-enabler 2.2 for the default config. Prefer 3.x for Python version (latest stable). Collapse skeleton history. Workaround for jaraco/skeleton#87. Add links to project home page and pypi. Fixes jaraco/skeleton#77. Replace redundant step names with simple 'Run'. Increase visibility of security policy. (#4) Remove Python 3.7 compatibility from py310compat Finalize Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76)
1 parent 90a0d97 commit 26e4654

File tree

5 files changed

+22
-19
lines changed

5 files changed

+22
-19
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-zipp
2-
URL = https://files.pythonhosted.org/packages/00/27/f0ac6b846684cecce1ee93d32450c45ab607f65c2e0255f0092032d91f07/zipp-3.15.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/52/9a/d93b483b9a744e7f71b311ee9bb5a228f6846219ceb5d6dbcb3eddcd1932/zipp-3.16.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+4-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-zipp
3-
url = https://files.pythonhosted.org/packages/00/27/f0ac6b846684cecce1ee93d32450c45ab607f65c2e0255f0092032d91f07/zipp-3.15.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/52/9a/d93b483b9a744e7f71b311ee9bb5a228f6846219ceb5d6dbcb3eddcd1932/zipp-3.16.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/zipp/
66
domain =
@@ -19,6 +19,8 @@ autoupdate = true
1919
broken_c++ = false
2020
# disable parallelization during build
2121
broken_parallel_build = false
22+
# create vendor archive with cargo
23+
cargo_vendor = false
2224
# this package is a library compatibility package and only ships versioned library files
2325
compat = false
2426
# set conservative build flags
@@ -58,7 +60,7 @@ skip_tests = false
5860
# add .so files to the lib package instead of dev
5961
so_to_lib = false
6062
# configure build for avx2
61-
use_avx2 = false
63+
use_avx2 = true
6264
# configure build for avx512
6365
use_avx512 = false
6466
# add clang flags

pypi-zipp.spec

+15-14
Original file line numberDiff line numberDiff line change
@@ -1,12 +1,13 @@
11
#
22
# This file is auto-generated. DO NOT EDIT
33
# Generated by: autospec.py
4+
# Using build pattern: pyproject
45
#
56
Name : pypi-zipp
6-
Version : 3.15.0
7-
Release : 61
8-
URL : https://files.pythonhosted.org/packages/00/27/f0ac6b846684cecce1ee93d32450c45ab607f65c2e0255f0092032d91f07/zipp-3.15.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/00/27/f0ac6b846684cecce1ee93d32450c45ab607f65c2e0255f0092032d91f07/zipp-3.15.0.tar.gz
7+
Version : 3.16.0
8+
Release : 62
9+
URL : https://files.pythonhosted.org/packages/52/9a/d93b483b9a744e7f71b311ee9bb5a228f6846219ceb5d6dbcb3eddcd1932/zipp-3.16.0.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/52/9a/d93b483b9a744e7f71b311ee9bb5a228f6846219ceb5d6dbcb3eddcd1932/zipp-3.16.0.tar.gz
1011
Summary : Backport of pathlib-compatible object wrapper for zip files
1112
Group : Development/Tools
1213
License : MIT
@@ -57,26 +58,26 @@ python3 components for the pypi-zipp package.
5758

5859

5960
%prep
60-
%setup -q -n zipp-3.15.0
61-
cd %{_builddir}/zipp-3.15.0
61+
%setup -q -n zipp-3.16.0
62+
cd %{_builddir}/zipp-3.16.0
6263
pushd ..
63-
cp -a zipp-3.15.0 buildavx2
64+
cp -a zipp-3.16.0 buildavx2
6465
popd
6566

6667
%build
6768
export http_proxy=http://127.0.0.1:9/
6869
export https_proxy=http://127.0.0.1:9/
6970
export no_proxy=localhost,127.0.0.1,0.0.0.0
7071
export LANG=C.UTF-8
71-
export SOURCE_DATE_EPOCH=1677369774
72+
export SOURCE_DATE_EPOCH=1689006663
7273
export GCC_IGNORE_WERROR=1
7374
export AR=gcc-ar
7475
export RANLIB=gcc-ranlib
7576
export NM=gcc-nm
76-
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
77-
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
78-
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
79-
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
77+
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
78+
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
79+
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
80+
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8081
export MAKEFLAGS=%{?_smp_mflags}
8182
python3 -m build --wheel --skip-dependency-check --no-isolation
8283
pushd ../buildavx2/
@@ -93,7 +94,7 @@ popd
9394
export MAKEFLAGS=%{?_smp_mflags}
9495
rm -rf %{buildroot}
9596
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-zipp
96-
cp %{_builddir}/zipp-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-zipp/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
97+
cp %{_builddir}/zipp-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-zipp/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
9798
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
9899
echo ----[ mark ]----
99100
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -113,7 +114,7 @@ popd
113114

114115
%files license
115116
%defattr(0644,root,root,0755)
116-
/usr/share/package-licenses/pypi-zipp/8e6689d37f82d5617b7f7f7232c94024d41066d1
117+
/usr/share/package-licenses/pypi-zipp/0445ed0f69910eeaee036f09a39a13c6e1f37e12
117118

118119
%files python
119120
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
61
1+
62

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
8428e729f1b4226b2f9a4b117e8b8edc0f153b6b/zipp-3.15.0.tar.gz
1+
03ba10581d56f6c7110d5c2cab4b61154a6ff260/zipp-3.16.0.tar.gz

0 commit comments

Comments
 (0)