Skip to content

Commit 983538c

Browse files
committed
[1 changes] chore!: make ResolverError::UnnecessaryPub a hard error (noir-lang/noir#7664)
fix: correctly format let followed by comment before unsafe (noir-lang/noir#7659) chore: bump external pinned commits (noir-lang/noir#7667) chore: fixing timeouts (noir-lang/noir#7666) chore(ssa): Do not print entire functions in underconstrained values check trace (noir-lang/noir#7665) chore(ci): Exclude enum tests from Brillig reports (noir-lang/noir#7661) chore: add regression tests for PR #7570 from lambda interpreter test (noir-lang/noir#7638) chore: remove some unused HIR code (noir-lang/noir#7643) chore: update examples to use UltraHonk (noir-lang/noir#7653) fix: allow method call after block, if and match (noir-lang/noir#7655) chore: address recurring typo in docs (noir-lang/noir#7656) fix(ssa): don't check Brillig calls for coverage if they don't return anything (e.g. println) (noir-lang/noir#7644)
1 parent f733879 commit 983538c

File tree

194 files changed

+5355
-1067
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

194 files changed

+5355
-1067
lines changed

.noir-sync-commit

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
5a3d2bc0e13a12b039c793c73d7817924c13e159
1+
70007925eb4e57a1e0482ae329862afce98c1119

noir/noir-repo/.github/benchmark_projects.yml

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
define: &AZ_COMMIT 3b981f9217f9b859bdfbcdba2f5c080392c98da6
1+
define: &AZ_COMMIT b764a9a48a19c4803671876f9df8b7af53fe3e49
22
projects:
33
private-kernel-inner:
44
repo: AztecProtocol/aztec-packages
@@ -15,7 +15,7 @@ projects:
1515
path: noir-projects/noir-protocol-circuits/crates/private-kernel-tail
1616
num_runs: 5
1717
timeout: 4
18-
compilation-timeout: 1.2
18+
compilation-timeout: 1.5
1919
execution-timeout: 0.04
2020
compilation-memory-limit: 250
2121
execution-memory-limit: 230

noir/noir-repo/.github/workflows/publish-nargo.yml

+2-2
Original file line numberDiff line numberDiff line change
@@ -54,6 +54,8 @@ jobs:
5454
cargo build --package nargo_cli --release --target ${{ matrix.target }} --no-default-features --features "${{ inputs.features }}"
5555
cargo build --package noir_profiler --release --target ${{ matrix.target }} --no-default-features --features "${{ inputs.features }}"
5656
cargo build --package noir_inspector --release --target ${{ matrix.target }} --no-default-features --features "${{ inputs.features }}"
57+
env:
58+
GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}
5759

5860
- name: Package artifacts
5961
run: |
@@ -237,5 +239,3 @@ jobs:
237239
make_latest: false
238240
overwrite: true
239241
tag: ${{ format('{0}-{1}', 'nightly', steps.date.outputs.date) }}
240-
241-

noir/noir-repo/.github/workflows/reports.yml

+6-4
Original file line numberDiff line numberDiff line change
@@ -42,6 +42,8 @@ jobs:
4242

4343
- name: Build Nargo
4444
run: cargo build --package nargo_cli --release
45+
env:
46+
GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}
4547

4648
- name: Package artifacts
4749
run: |
@@ -305,7 +307,7 @@ jobs:
305307
repository: ${{ matrix.repo }}
306308
path: test-repo
307309
ref: ${{ matrix.ref }}
308-
310+
309311
- name: Fetch noir dependencies
310312
working-directory: ./test-repo/${{ matrix.path }}
311313
run: |
@@ -341,7 +343,7 @@ jobs:
341343
path: ${{ steps.compilation_report.outputs.report_path }}
342344
retention-days: 3
343345
overwrite: true
344-
346+
345347
- name: Generate execution report
346348
id: execution_report
347349
working-directory: ./test-repo/${{ matrix.path }}
@@ -359,7 +361,7 @@ jobs:
359361
360362
echo "report_name=$REPORT_NAME" >> $GITHUB_OUTPUT
361363
echo "report_path=$REPORT_PATH" >> $GITHUB_OUTPUT
362-
364+
363365
- name: Upload execution report
364366
if: ${{ !matrix.cannot_execute }}
365367
uses: actions/upload-artifact@v4
@@ -716,7 +718,7 @@ jobs:
716718
- upload_compilation_memory_report
717719
- upload_execution_report
718720
- upload_execution_memory_report
719-
721+
720722
steps:
721723
- name: Report overall success
722724
run: |

noir/noir-repo/.github/workflows/test-js-packages.yml

+5-3
Original file line numberDiff line numberDiff line change
@@ -64,6 +64,8 @@ jobs:
6464

6565
- name: Build Nargo
6666
run: cargo build --package nargo_cli --release
67+
env:
68+
GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}
6769

6870
- name: Package artifacts
6971
run: |
@@ -519,8 +521,8 @@ jobs:
519521
working-directory: ./examples/prove_and_verify
520522
run: ./test.sh
521523

522-
- name: Run `codegen_verifier`
523-
working-directory: ./examples/codegen_verifier
524+
- name: Run `solidity_verifier`
525+
working-directory: ./examples/solidity_verifier
524526
run: ./test.sh
525527

526528
- name: Run `oracle_transcript`
@@ -535,7 +537,7 @@ jobs:
535537
fail-fast: false
536538
matrix:
537539
include: ${{ fromJson( needs.critical-library-list.outputs.libraries )}}
538-
540+
539541
name: Check external repo - ${{ matrix.repo }}/${{ matrix.path }}
540542
steps:
541543
- name: Checkout

noir/noir-repo/Cargo.lock

+128-4
Some generated files are not rendered by default. Learn more about customizing how changed files appear on GitHub.

noir/noir-repo/Cargo.toml

+7
Original file line numberDiff line numberDiff line change
@@ -37,6 +37,7 @@ members = [
3737
"acvm-repo/bn254_blackbox_solver",
3838
# Utility crates
3939
"utils/iter-extended",
40+
"utils/protobuf",
4041
]
4142
default-members = [
4243
"tooling/nargo_cli",
@@ -94,6 +95,7 @@ noirc_abi = { path = "tooling/noirc_abi" }
9495
noirc_artifacts = { path = "tooling/noirc_artifacts" }
9596
noirc_artifacts_info = { path = "tooling/noirc_artifacts_info" }
9697
noir_artifact_cli = { path = "tooling/artifact_cli" }
98+
noir_protobuf = { path = "utils/protobuf" }
9799

98100
# Arkworks
99101
ark-bn254 = { version = "^0.5.0", default-features = false, features = [
@@ -137,6 +139,11 @@ criterion = "0.5.0"
137139
# https://github.com/tikv/pprof-rs/pull/172
138140
pprof = { version = "0.14", features = ["flamegraph", "criterion"] }
139141

142+
# Protobuf
143+
prost = "0.13"
144+
prost-build = "0.13"
145+
protoc-prebuilt = "0.3"
146+
140147
cfg-if = "1.0.0"
141148
dirs = "4"
142149
serde = { version = "1.0.136", features = ["derive"] }

noir/noir-repo/EXTERNAL_NOIR_LIBRARIES.yml

+3-3
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
define: &AZ_COMMIT 3b981f9217f9b859bdfbcdba2f5c080392c98da6
1+
define: &AZ_COMMIT b764a9a48a19c4803671876f9df8b7af53fe3e49
22
libraries:
33
noir_check_shuffle:
44
repo: noir-lang/noir_check_shuffle
@@ -38,7 +38,7 @@ libraries:
3838
timeout: 2
3939
noir_rsa:
4040
repo: noir-lang/noir_rsa
41-
timeout: 2
41+
timeout: 4
4242
noir_json_parser:
4343
repo: noir-lang/noir_json_parser
4444
timeout: 12
@@ -60,7 +60,7 @@ libraries:
6060
repo: AztecProtocol/aztec-packages
6161
ref: *AZ_COMMIT
6262
path: noir-projects/noir-contracts
63-
timeout: 80
63+
timeout: 90
6464
blob:
6565
repo: AztecProtocol/aztec-packages
6666
ref: *AZ_COMMIT

0 commit comments

Comments
 (0)