Skip to content

Commit bcec12d

Browse files
authored
chore(master): Release 0.55.0 (#8478)
🤖 I have created a release *beep* *boop* --- <details><summary>aztec-package: 0.55.0</summary> ## [0.55.0](aztec-package-v0.54.0...aztec-package-v0.55.0) (2024-09-13) ### Bug Fixes * Load prover node config from env ([#8525](#8525)) ([7065962](7065962)) ### Miscellaneous * Remove unneeded propose and da oracle ([#8474](#8474)) ([274a6b7](274a6b7)) </details> <details><summary>barretenberg.js: 0.55.0</summary> ## [0.55.0](barretenberg.js-v0.54.0...barretenberg.js-v0.55.0) (2024-09-13) ### Features * New test programs for wasm benchmarking ([#8389](#8389)) ([0b46e96](0b46e96)) </details> <details><summary>aztec-packages: 0.55.0</summary> ## [0.55.0](aztec-packages-v0.54.0...aztec-packages-v0.55.0) (2024-09-13) ### ⚠ BREAKING CHANGES * Add Not instruction in brillig ([#8488](#8488)) * refactor NoteGetterOptions::select API ([#8504](#8504)) * **avm:** variants for CAST/NOT opcode ([#8497](#8497)) * **avm:** variants for REVERT opcode ([#8487](#8487)) ### Features * (bb) remove redundant constraints on field/group elements when using goblin plonk ([#8409](#8409)) ([12a093d](12a093d)) * Add `Module::structs` (noir-lang/noir#6017) ([cb20e07](cb20e07)) * Add `TypedExpr::get_type` (noir-lang/noir#5992) ([875cfe6](875cfe6)) * Add assertions for ACVM `FunctionInput` `bit_size` (noir-lang/noir#5864) ([20d7576](20d7576)) * Add Not instruction in brillig ([#8488](#8488)) ([ceda361](ceda361)) * Add timeouts for request / response stream connections ([#8434](#8434)) ([190c27f](190c27f)) * **avm:** Parallelize polynomial alloc and set ([#8520](#8520)) ([7e73531](7e73531)) * **avm:** Variants for CAST/NOT opcode ([#8497](#8497)) ([bc609fa](bc609fa)) * **avm:** Variants for REVERT opcode ([#8487](#8487)) ([a0c8915](a0c8915)) * **bb:** Iterative constexpr_for ([#8502](#8502)) ([02c3330](02c3330)) * Better error message for misplaced doc comments (noir-lang/noir#5990) ([875cfe6](875cfe6)) * Change the layout of arrays and vectors to be a single pointer ([#8448](#8448)) ([3ad624c](3ad624c)) * Checking finalized sizes + a test of two folding verifiers ([#8503](#8503)) ([d9e3f4d](d9e3f4d)) * Extract brillig slice ops to reusable procedures (noir-lang/noir#6002) ([20d7576](20d7576)) * Format trait impl functions (noir-lang/noir#6016) ([cb20e07](cb20e07)) * Impl Hash and Eq on more comptime types (noir-lang/noir#6022) ([cb20e07](cb20e07)) * Implement LSP code action "Implement missing members" (noir-lang/noir#6020) ([cb20e07](cb20e07)) * Let `has_named_attribute` work for built-in attributes (noir-lang/noir#6024) ([cb20e07](cb20e07)) * LSP completion function detail (noir-lang/noir#5993) ([875cfe6](875cfe6)) * Native world state ([#7516](#7516)) ([c1aa6f7](c1aa6f7)) * New test programs for wasm benchmarking ([#8389](#8389)) ([0b46e96](0b46e96)) * Output timestamps in prover-stats raw logs ([#8476](#8476)) ([aa67a14](aa67a14)) * Rate limit peers in request response p2p interactions ([#8498](#8498)) ([00146fa](00146fa)) * Refactor NoteGetterOptions::select API ([#8504](#8504)) ([e527992](e527992)) * Sync from aztec-packages (noir-lang/noir#5971) ([875cfe6](875cfe6)) * Sync from aztec-packages (noir-lang/noir#6001) ([20d7576](20d7576)) * Use Zac's quicksort algorithm in stdlib sorting (noir-lang/noir#5940) ([20d7576](20d7576)) * Validators ensure transactions live in their p2p pool before attesting ([#8410](#8410)) ([bce1eea](bce1eea)) * Verification key stuff ([#8431](#8431)) ([11dc8ff](11dc8ff)) ### Bug Fixes * Correctly print string tokens (noir-lang/noir#6021) ([cb20e07](cb20e07)) * Enable verifier when deploying the networks ([#8500](#8500)) ([f6d31f1](f6d31f1)) * Error when comptime types are used in runtime code (noir-lang/noir#5987) ([875cfe6](875cfe6)) * Error when mutating comptime variables in non-comptime code (noir-lang/noir#6003) ([20d7576](20d7576)) * Fix some mistakes in arithmetic generics docs (noir-lang/noir#5999) ([20d7576](20d7576)) * Fix using lazily elaborated comptime globals (noir-lang/noir#5995) ([20d7576](20d7576)) * Help link was outdated (noir-lang/noir#6004) ([20d7576](20d7576)) * Load prover node config from env ([#8525](#8525)) ([7065962](7065962)) * Remove claim_public from fee juice ([#8337](#8337)) ([dca74ae](dca74ae)) * Try to move constant terms to one side for arithmetic generics (noir-lang/noir#6008) ([cb20e07](cb20e07)) * Use module name as line after which we'll insert auto-import (noir-lang/noir#6025) ([cb20e07](cb20e07)) ### Miscellaneous * Add some `pub use` and remove unused imports ([#8521](#8521)) ([8bd0755](8bd0755)) * **bb:** Fix mac build ([#8505](#8505)) ([32fd347](32fd347)), closes [#8499](#8499) * **bb:** Fix mac build ([#8522](#8522)) ([986e703](986e703)) * **ci:** Fix bb publishing ([#8486](#8486)) ([c210c36](c210c36)) * Fix a load of warnings in aztec-nr ([#8501](#8501)) ([35dc1e1](35dc1e1)) * Protogalaxy verifier matches prover 1 ([#8414](#8414)) ([5a76ec6](5a76ec6)) * Remove RC tracking in mem2reg (noir-lang/noir#6019) ([cb20e07](cb20e07)) * Remove unneeded propose and da oracle ([#8474](#8474)) ([274a6b7](274a6b7)) * Replace relative paths to noir-protocol-circuits ([b179c6b](b179c6b)) * Replace relative paths to noir-protocol-circuits ([1c042be](1c042be)) * Replace relative paths to noir-protocol-circuits ([1c8409f](1c8409f)) * Run mac builds on master ([#8519](#8519)) ([c458a79](c458a79)) * Single install script for cargo-binstall (noir-lang/noir#5998) ([20d7576](20d7576)) * Use uint32_t instead of size_t for databus data ([#8479](#8479)) ([79995c8](79995c8)) </details> <details><summary>barretenberg: 0.55.0</summary> ## [0.55.0](barretenberg-v0.54.0...barretenberg-v0.55.0) (2024-09-13) ### ⚠ BREAKING CHANGES * Add Not instruction in brillig ([#8488](#8488)) * **avm:** variants for CAST/NOT opcode ([#8497](#8497)) * **avm:** variants for REVERT opcode ([#8487](#8487)) ### Features * (bb) remove redundant constraints on field/group elements when using goblin plonk ([#8409](#8409)) ([12a093d](12a093d)) * Add Not instruction in brillig ([#8488](#8488)) ([ceda361](ceda361)) * **avm:** Parallelize polynomial alloc and set ([#8520](#8520)) ([7e73531](7e73531)) * **avm:** Variants for CAST/NOT opcode ([#8497](#8497)) ([bc609fa](bc609fa)) * **avm:** Variants for REVERT opcode ([#8487](#8487)) ([a0c8915](a0c8915)) * **bb:** Iterative constexpr_for ([#8502](#8502)) ([02c3330](02c3330)) * Checking finalized sizes + a test of two folding verifiers ([#8503](#8503)) ([d9e3f4d](d9e3f4d)) * Native world state ([#7516](#7516)) ([c1aa6f7](c1aa6f7)) * New test programs for wasm benchmarking ([#8389](#8389)) ([0b46e96](0b46e96)) * Verification key stuff ([#8431](#8431)) ([11dc8ff](11dc8ff)) ### Miscellaneous * **bb:** Fix mac build ([#8505](#8505)) ([32fd347](32fd347)), closes [#8499](#8499) * **bb:** Fix mac build ([#8522](#8522)) ([986e703](986e703)) * Protogalaxy verifier matches prover 1 ([#8414](#8414)) ([5a76ec6](5a76ec6)) * Use uint32_t instead of size_t for databus data ([#8479](#8479)) ([79995c8](79995c8)) </details> --- This PR was generated with [Release Please](https://github.com/googleapis/release-please). See [documentation](https://github.com/googleapis/release-please#release-please).
1 parent cb20e07 commit bcec12d

File tree

8 files changed

+131
-7
lines changed

8 files changed

+131
-7
lines changed

.release-please-manifest.json

+4-4
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
{
2-
".": "0.54.0",
2+
".": "0.55.0",
33
"yarn-project/cli": "0.35.1",
4-
"yarn-project/aztec": "0.54.0",
5-
"barretenberg": "0.54.0",
6-
"barretenberg/ts": "0.54.0"
4+
"yarn-project/aztec": "0.55.0",
5+
"barretenberg": "0.55.0",
6+
"barretenberg/ts": "0.55.0"
77
}

CHANGELOG.md

+75
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,80 @@
11
# Changelog
22

3+
## [0.55.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.54.0...aztec-packages-v0.55.0) (2024-09-13)
4+
5+
6+
### ⚠ BREAKING CHANGES
7+
8+
* Add Not instruction in brillig ([#8488](https://github.com/AztecProtocol/aztec-packages/issues/8488))
9+
* refactor NoteGetterOptions::select API ([#8504](https://github.com/AztecProtocol/aztec-packages/issues/8504))
10+
* **avm:** variants for CAST/NOT opcode ([#8497](https://github.com/AztecProtocol/aztec-packages/issues/8497))
11+
* **avm:** variants for REVERT opcode ([#8487](https://github.com/AztecProtocol/aztec-packages/issues/8487))
12+
13+
### Features
14+
15+
* (bb) remove redundant constraints on field/group elements when using goblin plonk ([#8409](https://github.com/AztecProtocol/aztec-packages/issues/8409)) ([12a093d](https://github.com/AztecProtocol/aztec-packages/commit/12a093d25e0c32fed5eceee424b24111ad2f14a4))
16+
* Add `Module::structs` (https://github.com/noir-lang/noir/pull/6017) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
17+
* Add `TypedExpr::get_type` (https://github.com/noir-lang/noir/pull/5992) ([875cfe6](https://github.com/AztecProtocol/aztec-packages/commit/875cfe649e76d96a2b07a25c870500543566efd1))
18+
* Add assertions for ACVM `FunctionInput` `bit_size` (https://github.com/noir-lang/noir/pull/5864) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
19+
* Add Not instruction in brillig ([#8488](https://github.com/AztecProtocol/aztec-packages/issues/8488)) ([ceda361](https://github.com/AztecProtocol/aztec-packages/commit/ceda3612f0d12d43bffde9c9b992a432d1a13d75))
20+
* Add timeouts for request / response stream connections ([#8434](https://github.com/AztecProtocol/aztec-packages/issues/8434)) ([190c27f](https://github.com/AztecProtocol/aztec-packages/commit/190c27f20e5849eb50c4c33233e36565c21bb51a))
21+
* **avm:** Parallelize polynomial alloc and set ([#8520](https://github.com/AztecProtocol/aztec-packages/issues/8520)) ([7e73531](https://github.com/AztecProtocol/aztec-packages/commit/7e7353195592d503a92c7222788c739006fa81fc))
22+
* **avm:** Variants for CAST/NOT opcode ([#8497](https://github.com/AztecProtocol/aztec-packages/issues/8497)) ([bc609fa](https://github.com/AztecProtocol/aztec-packages/commit/bc609fa457b029dee0dc19818e3709a6ea9564ab))
23+
* **avm:** Variants for REVERT opcode ([#8487](https://github.com/AztecProtocol/aztec-packages/issues/8487)) ([a0c8915](https://github.com/AztecProtocol/aztec-packages/commit/a0c8915ccf00fe1c329bf87760d28b3c42725cf1))
24+
* **bb:** Iterative constexpr_for ([#8502](https://github.com/AztecProtocol/aztec-packages/issues/8502)) ([02c3330](https://github.com/AztecProtocol/aztec-packages/commit/02c333028bf186f0472738f4a5c39d36f4980941))
25+
* Better error message for misplaced doc comments (https://github.com/noir-lang/noir/pull/5990) ([875cfe6](https://github.com/AztecProtocol/aztec-packages/commit/875cfe649e76d96a2b07a25c870500543566efd1))
26+
* Change the layout of arrays and vectors to be a single pointer ([#8448](https://github.com/AztecProtocol/aztec-packages/issues/8448)) ([3ad624c](https://github.com/AztecProtocol/aztec-packages/commit/3ad624cc343834e8c078c3fe99f3add08f22ffe3))
27+
* Checking finalized sizes + a test of two folding verifiers ([#8503](https://github.com/AztecProtocol/aztec-packages/issues/8503)) ([d9e3f4d](https://github.com/AztecProtocol/aztec-packages/commit/d9e3f4d42118d16b343b818a0649e6cfbc14ea31))
28+
* Extract brillig slice ops to reusable procedures (https://github.com/noir-lang/noir/pull/6002) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
29+
* Format trait impl functions (https://github.com/noir-lang/noir/pull/6016) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
30+
* Impl Hash and Eq on more comptime types (https://github.com/noir-lang/noir/pull/6022) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
31+
* Implement LSP code action "Implement missing members" (https://github.com/noir-lang/noir/pull/6020) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
32+
* Let `has_named_attribute` work for built-in attributes (https://github.com/noir-lang/noir/pull/6024) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
33+
* LSP completion function detail (https://github.com/noir-lang/noir/pull/5993) ([875cfe6](https://github.com/AztecProtocol/aztec-packages/commit/875cfe649e76d96a2b07a25c870500543566efd1))
34+
* Native world state ([#7516](https://github.com/AztecProtocol/aztec-packages/issues/7516)) ([c1aa6f7](https://github.com/AztecProtocol/aztec-packages/commit/c1aa6f73d13e860d5fcee07e82347a7633f8b334))
35+
* New test programs for wasm benchmarking ([#8389](https://github.com/AztecProtocol/aztec-packages/issues/8389)) ([0b46e96](https://github.com/AztecProtocol/aztec-packages/commit/0b46e96e8e5d05876a3700b9e50d29d6f349ea6e))
36+
* Output timestamps in prover-stats raw logs ([#8476](https://github.com/AztecProtocol/aztec-packages/issues/8476)) ([aa67a14](https://github.com/AztecProtocol/aztec-packages/commit/aa67a14c21e258bf42b9f878fbd5f876980f4d96))
37+
* Rate limit peers in request response p2p interactions ([#8498](https://github.com/AztecProtocol/aztec-packages/issues/8498)) ([00146fa](https://github.com/AztecProtocol/aztec-packages/commit/00146fa06361a86f0c6e45c46d8b6dff4d4561bf))
38+
* Refactor NoteGetterOptions::select API ([#8504](https://github.com/AztecProtocol/aztec-packages/issues/8504)) ([e527992](https://github.com/AztecProtocol/aztec-packages/commit/e52799256d67e2f992c141784102e9b97b114e49))
39+
* Sync from aztec-packages (https://github.com/noir-lang/noir/pull/5971) ([875cfe6](https://github.com/AztecProtocol/aztec-packages/commit/875cfe649e76d96a2b07a25c870500543566efd1))
40+
* Sync from aztec-packages (https://github.com/noir-lang/noir/pull/6001) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
41+
* Use Zac's quicksort algorithm in stdlib sorting (https://github.com/noir-lang/noir/pull/5940) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
42+
* Validators ensure transactions live in their p2p pool before attesting ([#8410](https://github.com/AztecProtocol/aztec-packages/issues/8410)) ([bce1eea](https://github.com/AztecProtocol/aztec-packages/commit/bce1eea90deb8fabf2324554681628144f4ee08d))
43+
* Verification key stuff ([#8431](https://github.com/AztecProtocol/aztec-packages/issues/8431)) ([11dc8ff](https://github.com/AztecProtocol/aztec-packages/commit/11dc8ff185d74e6e5bc51e85d6bcd6577ac83161))
44+
45+
46+
### Bug Fixes
47+
48+
* Correctly print string tokens (https://github.com/noir-lang/noir/pull/6021) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
49+
* Enable verifier when deploying the networks ([#8500](https://github.com/AztecProtocol/aztec-packages/issues/8500)) ([f6d31f1](https://github.com/AztecProtocol/aztec-packages/commit/f6d31f10365c2d31aef15bb679a7cf97f3172654))
50+
* Error when comptime types are used in runtime code (https://github.com/noir-lang/noir/pull/5987) ([875cfe6](https://github.com/AztecProtocol/aztec-packages/commit/875cfe649e76d96a2b07a25c870500543566efd1))
51+
* Error when mutating comptime variables in non-comptime code (https://github.com/noir-lang/noir/pull/6003) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
52+
* Fix some mistakes in arithmetic generics docs (https://github.com/noir-lang/noir/pull/5999) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
53+
* Fix using lazily elaborated comptime globals (https://github.com/noir-lang/noir/pull/5995) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
54+
* Help link was outdated (https://github.com/noir-lang/noir/pull/6004) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
55+
* Load prover node config from env ([#8525](https://github.com/AztecProtocol/aztec-packages/issues/8525)) ([7065962](https://github.com/AztecProtocol/aztec-packages/commit/7065962bb507555bcbb25cb3bbfc2a0a90687000))
56+
* Remove claim_public from fee juice ([#8337](https://github.com/AztecProtocol/aztec-packages/issues/8337)) ([dca74ae](https://github.com/AztecProtocol/aztec-packages/commit/dca74aeaa3b25290967e0591025dab8aad6e3ad1))
57+
* Try to move constant terms to one side for arithmetic generics (https://github.com/noir-lang/noir/pull/6008) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
58+
* Use module name as line after which we'll insert auto-import (https://github.com/noir-lang/noir/pull/6025) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
59+
60+
61+
### Miscellaneous
62+
63+
* Add some `pub use` and remove unused imports ([#8521](https://github.com/AztecProtocol/aztec-packages/issues/8521)) ([8bd0755](https://github.com/AztecProtocol/aztec-packages/commit/8bd0755a40357a0bc3c56ae5f60e7ff71552a69c))
64+
* **bb:** Fix mac build ([#8505](https://github.com/AztecProtocol/aztec-packages/issues/8505)) ([32fd347](https://github.com/AztecProtocol/aztec-packages/commit/32fd347f887af57456767bcb7a38070f8c4b2b28)), closes [#8499](https://github.com/AztecProtocol/aztec-packages/issues/8499)
65+
* **bb:** Fix mac build ([#8522](https://github.com/AztecProtocol/aztec-packages/issues/8522)) ([986e703](https://github.com/AztecProtocol/aztec-packages/commit/986e70353d28eab48cc0028bf31a2c8d67ffb29d))
66+
* **ci:** Fix bb publishing ([#8486](https://github.com/AztecProtocol/aztec-packages/issues/8486)) ([c210c36](https://github.com/AztecProtocol/aztec-packages/commit/c210c36c96102aaf5dcd36419b488d4c146c38a5))
67+
* Fix a load of warnings in aztec-nr ([#8501](https://github.com/AztecProtocol/aztec-packages/issues/8501)) ([35dc1e1](https://github.com/AztecProtocol/aztec-packages/commit/35dc1e1be1b182e616f700c6ea6f387bae55db21))
68+
* Protogalaxy verifier matches prover 1 ([#8414](https://github.com/AztecProtocol/aztec-packages/issues/8414)) ([5a76ec6](https://github.com/AztecProtocol/aztec-packages/commit/5a76ec61fb9dee976cdee8bba8198854d9249bf3))
69+
* Remove RC tracking in mem2reg (https://github.com/noir-lang/noir/pull/6019) ([cb20e07](https://github.com/AztecProtocol/aztec-packages/commit/cb20e078dd909656110d133339b2b425e6c3ebb0))
70+
* Remove unneeded propose and da oracle ([#8474](https://github.com/AztecProtocol/aztec-packages/issues/8474)) ([274a6b7](https://github.com/AztecProtocol/aztec-packages/commit/274a6b73281e5b9a7bc037aaf8888230de7b99a9))
71+
* Replace relative paths to noir-protocol-circuits ([b179c6b](https://github.com/AztecProtocol/aztec-packages/commit/b179c6b31e7d59d8be6e9d0bb54cd319b6a6f458))
72+
* Replace relative paths to noir-protocol-circuits ([1c042be](https://github.com/AztecProtocol/aztec-packages/commit/1c042be39595b848bc4cf9021d7f725650370a59))
73+
* Replace relative paths to noir-protocol-circuits ([1c8409f](https://github.com/AztecProtocol/aztec-packages/commit/1c8409f57dfa0116770bbc0a56521ee2f6d42aec))
74+
* Run mac builds on master ([#8519](https://github.com/AztecProtocol/aztec-packages/issues/8519)) ([c458a79](https://github.com/AztecProtocol/aztec-packages/commit/c458a7929697b85d170c42f7e927c658428ec955))
75+
* Single install script for cargo-binstall (https://github.com/noir-lang/noir/pull/5998) ([20d7576](https://github.com/AztecProtocol/aztec-packages/commit/20d75766cc533b3cb024937dd62251329c78b395))
76+
* Use uint32_t instead of size_t for databus data ([#8479](https://github.com/AztecProtocol/aztec-packages/issues/8479)) ([79995c8](https://github.com/AztecProtocol/aztec-packages/commit/79995c84e0f88c1ee72876fd21c50c33830597fc))
77+
378
## [0.54.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.53.0...aztec-packages-v0.54.0) (2024-09-10)
479

580

barretenberg/CHANGELOG.md

+30
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,35 @@
11
# Changelog
22

3+
## [0.55.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.54.0...barretenberg-v0.55.0) (2024-09-13)
4+
5+
6+
### ⚠ BREAKING CHANGES
7+
8+
* Add Not instruction in brillig ([#8488](https://github.com/AztecProtocol/aztec-packages/issues/8488))
9+
* **avm:** variants for CAST/NOT opcode ([#8497](https://github.com/AztecProtocol/aztec-packages/issues/8497))
10+
* **avm:** variants for REVERT opcode ([#8487](https://github.com/AztecProtocol/aztec-packages/issues/8487))
11+
12+
### Features
13+
14+
* (bb) remove redundant constraints on field/group elements when using goblin plonk ([#8409](https://github.com/AztecProtocol/aztec-packages/issues/8409)) ([12a093d](https://github.com/AztecProtocol/aztec-packages/commit/12a093d25e0c32fed5eceee424b24111ad2f14a4))
15+
* Add Not instruction in brillig ([#8488](https://github.com/AztecProtocol/aztec-packages/issues/8488)) ([ceda361](https://github.com/AztecProtocol/aztec-packages/commit/ceda3612f0d12d43bffde9c9b992a432d1a13d75))
16+
* **avm:** Parallelize polynomial alloc and set ([#8520](https://github.com/AztecProtocol/aztec-packages/issues/8520)) ([7e73531](https://github.com/AztecProtocol/aztec-packages/commit/7e7353195592d503a92c7222788c739006fa81fc))
17+
* **avm:** Variants for CAST/NOT opcode ([#8497](https://github.com/AztecProtocol/aztec-packages/issues/8497)) ([bc609fa](https://github.com/AztecProtocol/aztec-packages/commit/bc609fa457b029dee0dc19818e3709a6ea9564ab))
18+
* **avm:** Variants for REVERT opcode ([#8487](https://github.com/AztecProtocol/aztec-packages/issues/8487)) ([a0c8915](https://github.com/AztecProtocol/aztec-packages/commit/a0c8915ccf00fe1c329bf87760d28b3c42725cf1))
19+
* **bb:** Iterative constexpr_for ([#8502](https://github.com/AztecProtocol/aztec-packages/issues/8502)) ([02c3330](https://github.com/AztecProtocol/aztec-packages/commit/02c333028bf186f0472738f4a5c39d36f4980941))
20+
* Checking finalized sizes + a test of two folding verifiers ([#8503](https://github.com/AztecProtocol/aztec-packages/issues/8503)) ([d9e3f4d](https://github.com/AztecProtocol/aztec-packages/commit/d9e3f4d42118d16b343b818a0649e6cfbc14ea31))
21+
* Native world state ([#7516](https://github.com/AztecProtocol/aztec-packages/issues/7516)) ([c1aa6f7](https://github.com/AztecProtocol/aztec-packages/commit/c1aa6f73d13e860d5fcee07e82347a7633f8b334))
22+
* New test programs for wasm benchmarking ([#8389](https://github.com/AztecProtocol/aztec-packages/issues/8389)) ([0b46e96](https://github.com/AztecProtocol/aztec-packages/commit/0b46e96e8e5d05876a3700b9e50d29d6f349ea6e))
23+
* Verification key stuff ([#8431](https://github.com/AztecProtocol/aztec-packages/issues/8431)) ([11dc8ff](https://github.com/AztecProtocol/aztec-packages/commit/11dc8ff185d74e6e5bc51e85d6bcd6577ac83161))
24+
25+
26+
### Miscellaneous
27+
28+
* **bb:** Fix mac build ([#8505](https://github.com/AztecProtocol/aztec-packages/issues/8505)) ([32fd347](https://github.com/AztecProtocol/aztec-packages/commit/32fd347f887af57456767bcb7a38070f8c4b2b28)), closes [#8499](https://github.com/AztecProtocol/aztec-packages/issues/8499)
29+
* **bb:** Fix mac build ([#8522](https://github.com/AztecProtocol/aztec-packages/issues/8522)) ([986e703](https://github.com/AztecProtocol/aztec-packages/commit/986e70353d28eab48cc0028bf31a2c8d67ffb29d))
30+
* Protogalaxy verifier matches prover 1 ([#8414](https://github.com/AztecProtocol/aztec-packages/issues/8414)) ([5a76ec6](https://github.com/AztecProtocol/aztec-packages/commit/5a76ec61fb9dee976cdee8bba8198854d9249bf3))
31+
* Use uint32_t instead of size_t for databus data ([#8479](https://github.com/AztecProtocol/aztec-packages/issues/8479)) ([79995c8](https://github.com/AztecProtocol/aztec-packages/commit/79995c84e0f88c1ee72876fd21c50c33830597fc))
32+
333
## [0.54.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.53.0...barretenberg-v0.54.0) (2024-09-10)
434

535

barretenberg/cpp/CMakeLists.txt

+1-1
Original file line numberDiff line numberDiff line change
@@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24 FATAL_ERROR)
66
project(
77
Barretenberg
88
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
9-
VERSION 0.54.0 # x-release-please-version
9+
VERSION 0.55.0 # x-release-please-version
1010
LANGUAGES CXX C
1111
)
1212
# Insert version into `bb` config file

barretenberg/ts/CHANGELOG.md

+7
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,12 @@
11
# Changelog
22

3+
## [0.55.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.54.0...barretenberg.js-v0.55.0) (2024-09-13)
4+
5+
6+
### Features
7+
8+
* New test programs for wasm benchmarking ([#8389](https://github.com/AztecProtocol/aztec-packages/issues/8389)) ([0b46e96](https://github.com/AztecProtocol/aztec-packages/commit/0b46e96e8e5d05876a3700b9e50d29d6f349ea6e))
9+
310
## [0.54.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.53.0...barretenberg.js-v0.54.0) (2024-09-10)
411

512

barretenberg/ts/package.json

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
{
22
"name": "@aztec/bb.js",
33
"packageManager": "yarn@1.22.22",
4-
"version": "0.54.0",
4+
"version": "0.55.0",
55
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/barretenberg/ts",
66
"license": "MIT",
77
"type": "module",

yarn-project/aztec/CHANGELOG.md

+12
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,17 @@
11
# Changelog
22

3+
## [0.55.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.54.0...aztec-package-v0.55.0) (2024-09-13)
4+
5+
6+
### Bug Fixes
7+
8+
* Load prover node config from env ([#8525](https://github.com/AztecProtocol/aztec-packages/issues/8525)) ([7065962](https://github.com/AztecProtocol/aztec-packages/commit/7065962bb507555bcbb25cb3bbfc2a0a90687000))
9+
10+
11+
### Miscellaneous
12+
13+
* Remove unneeded propose and da oracle ([#8474](https://github.com/AztecProtocol/aztec-packages/issues/8474)) ([274a6b7](https://github.com/AztecProtocol/aztec-packages/commit/274a6b73281e5b9a7bc037aaf8888230de7b99a9))
14+
315
## [0.54.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.53.0...aztec-package-v0.54.0) (2024-09-10)
416

517

yarn-project/aztec/package.json

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
{
22
"name": "@aztec/aztec",
3-
"version": "0.54.0",
3+
"version": "0.55.0",
44
"type": "module",
55
"exports": {
66
".": "./dest/index.js"

0 commit comments

Comments
 (0)