Skip to content

Commit d45b03c

Browse files
committed
[1 changes] fix: let LSP suggest fields and methods in LValue chains (noir-lang/noir#6051)
feat(metaprogramming): Add `#[use_callers_scope]` (noir-lang/noir#6050) feat: show test output when running via LSP (noir-lang/noir#6049) feat: add `Expr::as_lambda` (noir-lang/noir#6048) feat: faster LSP by caching file managers (noir-lang/noir#6047) feat: implement `to_be_radix` in the comptime interpreter (noir-lang/noir#6043) fix: prevent check_can_mutate crashing on undefined variable (noir-lang/noir#6044) feat: add `Expr::as_for` and `Expr::as_for_range` (noir-lang/noir#6039) fix: Fix canonicalization bug (noir-lang/noir#6033) fix: Parse a statement as an expression (noir-lang/noir#6040) chore: rename CustomAtrribute to CustomAttribute (noir-lang/noir#6038) fix: error on `&mut x` when `x` is not mutable (noir-lang/noir#6037) feat: add `Expr::as_constructor` (noir-lang/noir#5980) chore: Fix docs (noir-lang/noir#6035) chore: document array methods (noir-lang/noir#6034)
1 parent bcec12d commit d45b03c

File tree

240 files changed

+16594
-935
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

240 files changed

+16594
-935
lines changed

.noir-sync-commit

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
9bf2dcbf166f9ffd97c369c0de3d95329c850d47
1+
5bf6567320629835ef6fa7765ca87e9b38ae4c9a
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
11
{
2-
".": "0.33.0",
3-
"acvm-repo": "0.49.0"
2+
".": "0.34.0",
3+
"acvm-repo": "0.50.0"
44
}

noir/noir-repo/CHANGELOG.md

+207
Large diffs are not rendered by default.

noir/noir-repo/Cargo.lock

+29-29
Some generated files are not rendered by default. Learn more about customizing how changed files appear on GitHub.

noir/noir-repo/Cargo.toml

+8-8
Original file line numberDiff line numberDiff line change
@@ -42,7 +42,7 @@ resolver = "2"
4242

4343
[workspace.package]
4444
# x-release-please-start-version
45-
version = "0.33.0"
45+
version = "0.34.0"
4646
# x-release-please-end
4747
authors = ["The Noir Team <team@noir-lang.org>"]
4848
edition = "2021"
@@ -59,13 +59,13 @@ unused_qualifications = "warn"
5959
[workspace.dependencies]
6060

6161
# ACVM workspace dependencies
62-
acir_field = { version = "0.49.0", path = "acvm-repo/acir_field", default-features = false }
63-
acir = { version = "0.49.0", path = "acvm-repo/acir", default-features = false }
64-
acvm = { version = "0.49.0", path = "acvm-repo/acvm" }
65-
brillig = { version = "0.49.0", path = "acvm-repo/brillig", default-features = false }
66-
brillig_vm = { version = "0.49.0", path = "acvm-repo/brillig_vm", default-features = false }
67-
acvm_blackbox_solver = { version = "0.49.0", path = "acvm-repo/blackbox_solver", default-features = false }
68-
bn254_blackbox_solver = { version = "0.49.0", path = "acvm-repo/bn254_blackbox_solver", default-features = false }
62+
acir_field = { version = "0.50.0", path = "acvm-repo/acir_field", default-features = false }
63+
acir = { version = "0.50.0", path = "acvm-repo/acir", default-features = false }
64+
acvm = { version = "0.50.0", path = "acvm-repo/acvm" }
65+
brillig = { version = "0.50.0", path = "acvm-repo/brillig", default-features = false }
66+
brillig_vm = { version = "0.50.0", path = "acvm-repo/brillig_vm", default-features = false }
67+
acvm_blackbox_solver = { version = "0.50.0", path = "acvm-repo/blackbox_solver", default-features = false }
68+
bn254_blackbox_solver = { version = "0.50.0", path = "acvm-repo/bn254_blackbox_solver", default-features = false }
6969

7070
# Noir compiler workspace dependencies
7171
fm = { path = "compiler/fm" }

0 commit comments

Comments
 (0)