Skip to content

Commit

Permalink
chore: sync bb master (#1947)
Browse files Browse the repository at this point in the history
Ran:

```
 ./scripts/git_subrepo.sh pull circuits/cpp/barretenberg 
  git checkout origin/master -- .gitmodules
  ```

# Checklist:
Remove the checklist to signal you've completed it. Enable auto-merge if the PR is ready to merge.
- [ ] If the pull request requires a cryptography review (e.g. cryptographic algorithm implementations) I have added the 'crypto' tag.
- [ ] I have reviewed my diff in github, line by line and removed unexpected formatting changes, testing logs, or commented-out code.
- [ ] Every change is related to the PR description.
- [ ] I have [linked](https://docs.github.com/en/issues/tracking-your-work-with-issues/linking-a-pull-request-to-an-issue) this pull request to relevant issues (if any exist).
  • Loading branch information
kevaundray authored Sep 2, 2023
1 parent f24814b commit eed58e1
Show file tree
Hide file tree
Showing 9 changed files with 35 additions and 7 deletions.
2 changes: 1 addition & 1 deletion circuits/cpp/barretenberg/.gitrepo
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
[subrepo]
remote = https://github.com/AztecProtocol/barretenberg
branch = master
commit = 5d8db8eb993334b43e24a51efba9c59e123320ab
commit = 41e028d834e4540a95ea10afba946299745eac8a
parent = e72830468362f2ea26b3f830b7e056b096f56d6a
method = merge
cmdver = 0.4.6
2 changes: 1 addition & 1 deletion circuits/cpp/barretenberg/.release-please-manifest.json
Original file line number Diff line number Diff line change
@@ -1 +1 @@
{".":"0.4.6","ts":"0.4.6"}
{".":"0.5.0","ts":"0.5.0"}
17 changes: 17 additions & 0 deletions circuits/cpp/barretenberg/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,22 @@
# Changelog

## [0.5.0](https://github.com/AztecProtocol/barretenberg/compare/barretenberg-v0.4.6...barretenberg-v0.5.0) (2023-09-01)


### ⚠ BREAKING CHANGES

* update to acvm 0.24.0 ([#1925](https://github.com/AztecProtocol/barretenberg/issues/1925))

### Bug Fixes

* Benchmark preset uses clang16 ([#1902](https://github.com/AztecProtocol/barretenberg/issues/1902)) ([cd0ff0e](https://github.com/AztecProtocol/barretenberg/commit/cd0ff0e2c049917ec47a110b45d76bed4c00ae2a))
* Reset keccak var inputs to 0 ([#1881](https://github.com/AztecProtocol/barretenberg/issues/1881)) ([23011ee](https://github.com/AztecProtocol/barretenberg/commit/23011ee1ea7f1b00b0f4194ebceedc75ea01c157))


### Miscellaneous Chores

* Update to acvm 0.24.0 ([#1925](https://github.com/AztecProtocol/barretenberg/issues/1925)) ([5d8db8e](https://github.com/AztecProtocol/barretenberg/commit/5d8db8eb993334b43e24a51efba9c59e123320ab))

## [0.4.6](https://github.com/AztecProtocol/barretenberg/compare/barretenberg-v0.4.5...barretenberg-v0.4.6) (2023-08-29)


Expand Down
2 changes: 1 addition & 1 deletion circuits/cpp/barretenberg/VERSION
Original file line number Diff line number Diff line change
@@ -1 +1 @@
v0.4.6 x-release-please-version
v0.5.0 x-release-please-version
2 changes: 1 addition & 1 deletion circuits/cpp/barretenberg/barretenberg-wasm.nix
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ in
stdenv.mkDerivation
{
pname = "barretenberg.wasm";
version = "0.4.6"; # x-release-please-version
version = "0.5.0"; # x-release-please-version

src = ./cpp;

Expand Down
2 changes: 1 addition & 1 deletion circuits/cpp/barretenberg/barretenberg.nix
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ in
buildEnv.mkDerivation
{
pname = "libbarretenberg";
version = "0.4.6"; # x-release-please-version
version = "0.5.0"; # x-release-please-version

src = ./cpp;

Expand Down
2 changes: 1 addition & 1 deletion circuits/cpp/barretenberg/cpp/CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24)
project(
Barretenberg
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
VERSION 0.4.6 # x-release-please-version
VERSION 0.5.0 # x-release-please-version
LANGUAGES CXX C
)

Expand Down
11 changes: 11 additions & 0 deletions circuits/cpp/barretenberg/ts/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,16 @@
# Changelog

## [0.5.0](https://github.com/AztecProtocol/barretenberg/compare/barretenberg.js-v0.4.6...barretenberg.js-v0.5.0) (2023-09-01)


### ⚠ BREAKING CHANGES

* update to acvm 0.24.0 ([#1925](https://github.com/AztecProtocol/barretenberg/issues/1925))

### Miscellaneous Chores

* Update to acvm 0.24.0 ([#1925](https://github.com/AztecProtocol/barretenberg/issues/1925)) ([5d8db8e](https://github.com/AztecProtocol/barretenberg/commit/5d8db8eb993334b43e24a51efba9c59e123320ab))

## [0.4.6](https://github.com/AztecProtocol/barretenberg/compare/barretenberg.js-v0.4.5...barretenberg.js-v0.4.6) (2023-08-29)


Expand Down
2 changes: 1 addition & 1 deletion circuits/cpp/barretenberg/ts/package.json
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
{
"name": "@aztec/bb.js",
"version": "0.4.6",
"version": "0.5.0",
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/circuits/cpp/barretenberg/ts",
"license": "MIT",
"type": "module",
Expand Down

0 comments on commit eed58e1

Please sign in to comment.