|
1 | 1 | #
|
2 | 2 | # This file is auto-generated. DO NOT EDIT
|
3 | 3 | # Generated by: autospec.py
|
| 4 | +# Using build pattern: pyproject |
4 | 5 | #
|
5 | 6 | Name : pypi-jaraco.functools
|
6 |
| -Version : 3.6.0 |
7 |
| -Release : 51 |
8 |
| -URL : https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz |
9 |
| -Source0 : https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz |
| 7 | +Version : 3.7.0 |
| 8 | +Release : 52 |
| 9 | +URL : https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz |
| 10 | +Source0 : https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz |
10 | 11 | Summary : Functools like those found in stdlib
|
11 | 12 | Group : Development/Tools
|
12 | 13 | License : MIT
|
13 | 14 | Requires: pypi-jaraco.functools-license = %{version}-%{release}
|
14 | 15 | Requires: pypi-jaraco.functools-python = %{version}-%{release}
|
15 | 16 | Requires: pypi-jaraco.functools-python3 = %{version}-%{release}
|
16 | 17 | BuildRequires : buildreq-distutils3
|
17 |
| -BuildRequires : pypi(more_itertools) |
18 | 18 | BuildRequires : pypi(py)
|
19 | 19 | BuildRequires : pypi(setuptools)
|
20 | 20 | BuildRequires : pypi(setuptools_scm)
|
@@ -59,23 +59,23 @@ python3 components for the pypi-jaraco.functools package.
|
59 | 59 |
|
60 | 60 |
|
61 | 61 | %prep
|
62 |
| -%setup -q -n jaraco.functools-3.6.0 |
63 |
| -cd %{_builddir}/jaraco.functools-3.6.0 |
| 62 | +%setup -q -n jaraco.functools-3.7.0 |
| 63 | +cd %{_builddir}/jaraco.functools-3.7.0 |
64 | 64 | pushd ..
|
65 |
| -cp -a jaraco.functools-3.6.0 buildavx2 |
| 65 | +cp -a jaraco.functools-3.7.0 buildavx2 |
66 | 66 | popd
|
67 | 67 |
|
68 | 68 | %build
|
69 | 69 | export http_proxy=http://127.0.0.1:9/
|
70 | 70 | export https_proxy=http://127.0.0.1:9/
|
71 | 71 | export no_proxy=localhost,127.0.0.1,0.0.0.0
|
72 | 72 | export LANG=C.UTF-8
|
73 |
| -export SOURCE_DATE_EPOCH=1676920033 |
| 73 | +export SOURCE_DATE_EPOCH=1685402200 |
74 | 74 | export GCC_IGNORE_WERROR=1
|
75 |
| -export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz " |
76 |
| -export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz " |
77 |
| -export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz " |
78 |
| -export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz " |
| 75 | +export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 76 | +export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 77 | +export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 78 | +export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
79 | 79 | export MAKEFLAGS=%{?_smp_mflags}
|
80 | 80 | python3 -m build --wheel --skip-dependency-check --no-isolation
|
81 | 81 | pushd ../buildavx2/
|
|
92 | 92 | export MAKEFLAGS=%{?_smp_mflags}
|
93 | 93 | rm -rf %{buildroot}
|
94 | 94 | mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools
|
95 |
| -cp %{_builddir}/jaraco.functools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools/8e6689d37f82d5617b7f7f7232c94024d41066d1 || : |
| 95 | +cp %{_builddir}/jaraco.functools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || : |
96 | 96 | pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
|
97 | 97 | echo ----[ mark ]----
|
98 | 98 | cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
|
|
112 | 112 |
|
113 | 113 | %files license
|
114 | 114 | %defattr(0644,root,root,0755)
|
115 |
| -/usr/share/package-licenses/pypi-jaraco.functools/8e6689d37f82d5617b7f7f7232c94024d41066d1 |
| 115 | +/usr/share/package-licenses/pypi-jaraco.functools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 |
116 | 116 |
|
117 | 117 | %files python
|
118 | 118 | %defattr(-,root,root,-)
|
|
0 commit comments