Skip to content

Commit aa81729

Browse files
committed
pypi-jaraco.functools: Autospec creation for update from version 3.6.0 to version 3.7.0
Jason R. Coombs (9): Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78. Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt. Make substitution fields more prominent and distinct from true 'skeleton' references. (#71) Suppress EncodingWarning in build.env. Ref pypa/build#615. Remove reference to EncodingWarning as it doesn't exist on some Pythons. Add pass_through_when. Rely on boolean value of check. Use mutability for dynamic behavior. Invert the logic and rename the function to 'bypass_unless' Refactor as 'bypass_when' and 'bypass_unless' because one is likely much more useful to the caller than the other. Joyce (1): Feat: initial permissions to main.yml (jaraco/skeleton#76)
1 parent a55671a commit aa81729

File tree

5 files changed

+22
-20
lines changed

5 files changed

+22
-20
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-jaraco.functools
2-
URL = https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+4-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-jaraco.functools
3-
url = https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/jaraco.functools/
66
domain =
@@ -19,6 +19,8 @@ autoupdate = true
1919
broken_c++ = false
2020
# disable parallelization during build
2121
broken_parallel_build = false
22+
# create vendor archive with cargo
23+
cargo_vendor = false
2224
# this package is a library compatibility package and only ships versioned library files
2325
compat = false
2426
# set conservative build flags
@@ -58,7 +60,7 @@ skip_tests = false
5860
# add .so files to the lib package instead of dev
5961
so_to_lib = false
6062
# configure build for avx2
61-
use_avx2 = false
63+
use_avx2 = true
6264
# configure build for avx512
6365
use_avx512 = false
6466
# add clang flags

pypi-jaraco.functools.spec

+15-15
Original file line numberDiff line numberDiff line change
@@ -1,20 +1,20 @@
11
#
22
# This file is auto-generated. DO NOT EDIT
33
# Generated by: autospec.py
4+
# Using build pattern: pyproject
45
#
56
Name : pypi-jaraco.functools
6-
Version : 3.6.0
7-
Release : 51
8-
URL : https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
7+
Version : 3.7.0
8+
Release : 52
9+
URL : https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz
1011
Summary : Functools like those found in stdlib
1112
Group : Development/Tools
1213
License : MIT
1314
Requires: pypi-jaraco.functools-license = %{version}-%{release}
1415
Requires: pypi-jaraco.functools-python = %{version}-%{release}
1516
Requires: pypi-jaraco.functools-python3 = %{version}-%{release}
1617
BuildRequires : buildreq-distutils3
17-
BuildRequires : pypi(more_itertools)
1818
BuildRequires : pypi(py)
1919
BuildRequires : pypi(setuptools)
2020
BuildRequires : pypi(setuptools_scm)
@@ -59,23 +59,23 @@ python3 components for the pypi-jaraco.functools package.
5959

6060

6161
%prep
62-
%setup -q -n jaraco.functools-3.6.0
63-
cd %{_builddir}/jaraco.functools-3.6.0
62+
%setup -q -n jaraco.functools-3.7.0
63+
cd %{_builddir}/jaraco.functools-3.7.0
6464
pushd ..
65-
cp -a jaraco.functools-3.6.0 buildavx2
65+
cp -a jaraco.functools-3.7.0 buildavx2
6666
popd
6767

6868
%build
6969
export http_proxy=http://127.0.0.1:9/
7070
export https_proxy=http://127.0.0.1:9/
7171
export no_proxy=localhost,127.0.0.1,0.0.0.0
7272
export LANG=C.UTF-8
73-
export SOURCE_DATE_EPOCH=1676920033
73+
export SOURCE_DATE_EPOCH=1685402200
7474
export GCC_IGNORE_WERROR=1
75-
export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
76-
export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
77-
export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
78-
export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
75+
export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
76+
export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
77+
export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
78+
export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
7979
export MAKEFLAGS=%{?_smp_mflags}
8080
python3 -m build --wheel --skip-dependency-check --no-isolation
8181
pushd ../buildavx2/
@@ -92,7 +92,7 @@ popd
9292
export MAKEFLAGS=%{?_smp_mflags}
9393
rm -rf %{buildroot}
9494
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools
95-
cp %{_builddir}/jaraco.functools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
95+
cp %{_builddir}/jaraco.functools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
9696
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
9797
echo ----[ mark ]----
9898
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
@@ -112,7 +112,7 @@ popd
112112

113113
%files license
114114
%defattr(0644,root,root,0755)
115-
/usr/share/package-licenses/pypi-jaraco.functools/8e6689d37f82d5617b7f7f7232c94024d41066d1
115+
/usr/share/package-licenses/pypi-jaraco.functools/0445ed0f69910eeaee036f09a39a13c6e1f37e12
116116

117117
%files python
118118
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
51
1+
52

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
c37c641d5b39a3b383e69191601a942ee7161e19/jaraco.functools-3.6.0.tar.gz
1+
a53423547d6fc7e3b16f3c58782afd5da141f6d7/jaraco.functools-3.7.0.tar.gz

0 commit comments

Comments
 (0)